Jump to content

Rocksmith Custom Song Toolkit (toolkit) Q&A


Recommended Posts

  • Replies 492
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I am pleased to announce that new Rocksmith Custom Song Toolkit.   All thanks to the developers involved in the project that made this feasible possibility in so little time.   DEVS: * me; * Sn

Added Popup to ask if user wants to set new ID's or keep it safe Fixed RS1 to RS2014 converter for PC platform Altered write comments function so now we write comments inside node Allowed Scroll Spee

Here is tutorial for the new RS2012 --> RS2014 conversion feature. Really pretty easy ...   1) Use unpacker, select "RS2012", check "Decode Audio", click "Unpack", select RS1 CDLC *.dat file and un

A user posted some XML files that cause the toolkit to crash:

http://customsforge.com/topic/7026-help-with-generating-custom

 

The issue seems to be that several phrase names were more than 32 characters long. The toolkit didn't handle this gracefully though and it crashes after throwing an error dialog. It mentions to submit the log file, but it doesn't seem to create a log file before it closes out.

Link to post
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

It's been requested for EOF to support specifying an arrangement as being a bonus arrangement:

http://customsforge.com/topic/7599-can-you-name-a-bonus-arrangement-eoftookit-question

 

Would I be able to just have EOF indicate this in the "bonusArr" attribute of the arrangementProperties tag? Is this something the toolkit can already support when loading an XML file?

Link to post
Share on other sites

  • 1 month later...
  • 3 weeks later...
  • 2 weeks later...

For the past 2 weeks, when I click on "click here to update", instead of what happened until now (the toolkit update appeared and started downloading the latest build), after the "Update Available" window, I click on "Install Update" and I get the same error window

http://s6.postimg.org/60vbrh1ox/screenshot_3.png
 

So, now I have to go to the website and download the latest build. I've tried deleting all files, installing older builds and then try to update them, it always gives the same result... as soon as I click "Install Update" I get that message.

Is this a problem with my system or something wrong with the toolkit updater?

Does anyone else have the same issue?

 

This started to happen after build 1e175f6dda80

 

Thanks

Link to post
Share on other sites

@Alex360: I have Win7 Ultimate 64bit, and the Microsoft .NET version I have installed is 4.5.1.

 

My C: HDD fried 2 weeks ago and I had to re-install everything after replacing the HDD... do you think there's something missing?... The .NET framework was installed once the PC booted the 1st time after the installation through windows update. I have several .exe files of .NET framework, I'm gonna run Microsoft .NET framework repair tool and I'll report to see if that solved the issue. At least now I know it's something wrong with my system.

 

Thanks

Link to post
Share on other sites

Ok, so after removing .NET 4.5.1, I tried with .NET 4.0, .NET 4.5 and then .NET 4.5.1 again. The result was always the same, I keep getting the same error window, but now I know the problem is not with the toolkit, the problem is with my system.

 

Thanks for the help Alex360.

Link to post
Share on other sites

Hello Fabianosan, I'm fine and you?

 

Thanks for the explanation.

I don't know why the installation file doesn't install the x32 and the x64 versions. I've always used Windows 7 Ultimate x64 and it always worked. Maybe Microsoft changed something in the installation, because the files I have are "dotNetFx45_Full_x86_x64.exe", "NDP451-KB2858728-x86-x64-AllOS-ENU.exe" and I got this one today "NDP452-KB2901907-x86-x64-AllOS-ENU.exe".

 

Although all files say "x86_x64", when I run the .exe file I can't choose just the 32 or 64 bit version, I assumed that the files installed both versions, but they only install the 64 bit version and don't allow me to install the 32 bit. I've "googled" for installation files of .NET x32 only, but every one I found was for both. On Microsoft the website, the only installation files I could find were the ones I mention above, so I don't think I'll be able to install a 32bit version of .NET framework on this OS.

 

If by any chance one of you has the 32bit installation file only, could you provide me the file?

The only other option I can think of is installing Win7 x32, but I don't have it.

 

It's not a big deal, I can see in the toolkit when new builds are released and I just have to go to the website and get the latest.

 

Thanks for your help as always guys. :)

Link to post
Share on other sites

@@Kaijin, I think I need to askmore ppls i updater works for them, cause it's maybe only me and it works for me only.. xD

Updater works fine for me (Windows 8.1, 64bit)

  • Like 1

Check out my easy tutorial on how to add a metronome to your CDLC: Mute the original music, play only with the metronome and find out how good you really sound! Also: Find CDLCs that have the metronome enabled!

 

Want a USB-Footswitch that you can use to control the tone selection and all the menus in Rocksmith? Check out Rodman's Tutorial and my additions to that!  Footswitch_Logo.png

My CDLCs: Devin Townsend - Life, Deep Peace, Ih-Ah!, Deadhead; Farin Urlaub - Ok

My ideas for new features in Ignition, e.g. filters for Multitrack CDLC and Metronome CDLC.

Link to post
Share on other sites

@@Alex360, thanks for your help, but I'm 99.(9)% sure the problem is with my system.

As I mentioned in my previous post, today I installed .NET framework 4.5.2, the installation file says "x86_x64", so it should work, but for some reason I cannot find an explanation for, it doesn't work, I get always the same error window.

 

In the meantime, today I downloaded the latest build (04f3aafac1c8) and when I try to import a custom, I get a window saying "Thread Exception catched!". In the bottom of the window it says to provide the log file, this is the link to the file.

What I find very strange is that I only get the error when I have the "Import Structured Packages" unselected. If I check that option and import the same or another .psarc file, the toolkit imports the file with no errors.

I've always imported customs in the toolkit with the structured packages not selected, so I wonder if this error has to do with my system too, although I deleted the new build and extracted the zip file of the build I've been using (99447fd6be9e) and with that build the import package function works both with "Import Structured Packages" selected or unselected.

 

So, from what I could gather, the error I get when importing a package without structure (not sure if this is the proper way to say it, but I think you understand what I'm trying to explain) only happens with the last 4 builds (b4847dcd8e40, 563a3b602a2b, 3fb44538c821 and 04f3aafac1c8). I've noticed that this only started to happen after the revision saying "Small code review". Before that, I've tried with 4 older builds and importing a package without structure works fine with all.

I don't know if this matters or not, but when I get the error with the last 4 builds, despite the fact that I get the thread exception caught, the folder I choose to unpack the custom contains the extracted package, but all the information that should be in the toolkit window (name of the song, arrangements, tones, etc) doesn't show.

 

Sorry for giving this trouble, I've been using the toolkit for many months without any errors, I just want to be sure that the update problem and now this import package problem are related with my system and not the toolkit.

 

As always, thanks for all your time and patience.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy