Jump to content

Rocksmith Custom Song Toolkit (toolkit) Q&A


Recommended Posts

  • Replies 490
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I am pleased to announce that new Rocksmith Custom Song Toolkit.   All thanks to the developers involved in the project that made this feasible possibility in so little time.   DEVS: * me; * Sn

Added Popup to ask if user wants to set new ID's or keep it safe Fixed RS1 to RS2014 converter for PC platform Altered write comments function so now we write comments inside node Allowed Scroll Spee

Here is tutorial for the new RS2012 --> RS2014 conversion feature. Really pretty easy ...   1) Use unpacker, select "RS2012", check "Decode Audio", click "Unpack", select RS1 CDLC *.dat file and un

Hi Alex360, I just downloaded the last build and I still get the same error.

 

I compared the log files and the information is exactly the same on both. I deleted all files from the build I had before and extracted the new files from build e03aabfbdc38. The error is the same. Is it something I'm doing wrong?

 

Sorry for being such a pain in the ass... I feel like I'm complaining a lot, if that's the case, I apologize. I'm very used to work with the unpacked files without structure, that's why I'm boring you with this.

 

Once again, thanks for looking into this.

Link to post
Share on other sites

@@Alex360, please don't apologize, you guys do so much for the community, we all have to thank you guys for all your efforts.

 

I still remember the early days, when there were so many issues to solve and you guys were always ready to help/fix/add whatever was/is needed.

 

I just tested 1d45d6373add and it's working like a charm. :D

 

About the updater, I'm 100% sure it's something wrong with my system. Although I had to re-install everything only a few weeks ago, I have the idea that there was something wrong with the .NET installation and I'm pretty sure my problem with the update started to happen at the same time, so it can't be a coincidence.

 

If and when I found what is causing that error window, I'll let you guys know, just in case someone in the future encounters the same issue, you will know what's the cause of it.

 

Again, I know I repeat this a lot of times, but it's in my "nature"....

 

Thanks a lot :)

  • Like 1
Link to post
Share on other sites

  • 2 weeks later...

I tried for the first time the score attack mode in the game and i have noticed that in score attack mode the bass arr gets recognized always as to be plucked instead of to be picked even if picked is selected in the toolkit.

 

In normal mode it gets recognized correctly but not in attack mode. Maybe an attribute is missing in the xml for the arcade stuff.

 

i can open an issue if its really a bug or something missing.

Edited by MadMaxx
Link to post
Share on other sites

@@TomSawyer2112, yes it is. but EOF can't handle rs2 xml import, use psarc>gp5>import one guitar xml in eof and than import from gp5>????>done! as i can say it should work with very small loss in accuracy.

  • Like 1
Link to post
Share on other sites

I did have a quick read, but...

 

My toolkit (2.6.0.0) is stuck in Drop D.  I messed about with custom tuning and now I can;t go back to E Standard, Drop D is the highest choice in the list.  It does this now for all saves.

 

 

Thanks :D

 

 

Edit - I try the newer one.

 

Double Edit - After much messing about I can't get a custom tuning arrangement into the game with other standard E arrangements.  Either they are all the custom tuning or they are all E standard.

 

In the toolkit (2.6.1.0) when you  "Add a new tuning" it overwrites the one you are on, it does not create a new one.  When the box is not ticked it does the same thing.

 

The only way (that I have found so far) to get a custom tuning into the game is to use the E Standard slot, but this then messes up the toolkit and you can't get E standard back.  Requires reinstall of toolkit.

 

You do not even have to go in game to see the problem.  Toolkit setup with >1 arrangement, make 1 a custom tuning and the other(s) standard E.  Save toolkit.  Reload.  Custom tuning arrangement now standard E.  The custom tuning never made it into the game - game fine, toolkit has fault.

 

 

 

Any ideas?

 

How do I get into the game a Custom Tuning Lead, Standard E Rhythm and Standard E Bass?

 

 

Thank you :D

Link to post
Share on other sites

@PC Plum, oh god.

Use last beta 2.6.1.x releases. there was reworked tuning behaviour.
I still don't get why you edited E Standard tuning while you could add a new one(use add as new button, this will not replace Original tuning for all other arrangements. and if you use same strings you basically just rename it)

Just Don't use those "stable old" toolkit builds :lol:
I'll add some fixes and ask Fab to put a new version as "stable one".

Link to post
Share on other sites

Hi,

 

I used the version from your sig "master-2.6.1.0-1d45d6373add", which I think is the latest version.

 

Man, I dunno what to say...  the tuning is broken or I am broken :)

 

Please explain how to make a new custom tuning, because when I try it then it does not work?  If you tick "Add as new tuning" or if you do not tick "Add as new tuning" it does not make a new tuning.

 

When I manually add a new tuning to RocksmithTuningLib.XML then it does show up in drop down box, but it is not generated into package and it does not save in the toolkit template save - when you reload the save the arrangement says "Standard E" not the new custom tuning.

 

 

I have began to discuss this in another thread if you do not want it here.

 

 

The only way I have found to get a custom tuning actually into the game is to overwrite Standard E, otherwise it always comes up as Standard E.

 

I realise it is possible, because others have managed it.  But I am wondering whether anyone has succesfully mixed custom tunings in one arrangement and standard tuning in another?

Link to post
Share on other sites

  • 4 weeks later...

Hi fabianosan

 

The toolkit wont auto update, so i downloaded the the latest build and scanned it with Avast and its marking it as win 32 malware gen?

thats probably why the auto update is not currently working from the previous build, thought i would mention it as other people could be having the same problem.

Link to post
Share on other sites

  • 2 weeks later...

Whenever I'm trying to launch Toolkit system says that program has been closed. It worked fine when I last used it about 3 months ago. I installed the newest version but same issue. My antivirus was initially blocking it but restored the files and excluded it from antivirus scan but to no avail.

I'm using Windows 8 and toolkit version is 2.6.1.0

Link to post
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy