Jump to content

Latest EOF releases (9-26-2020)


Recommended Posts

Well as it happens ...

 

When I originally authored the chart, I did not have any problems. The arrangement came directly from a GP5 import with no tweaks that I can remember. I was revising the bass arrangement last week and got into the problem when re-building the .psarc. Tried lots of things but just gave up in the end and just used the lead arrangement ripped from the original version for the update.

 

Here is the gp file I've got if it's of any use to you. 

http://www.mediafire.com/file/c3de5okzrtre13f/The_Fratellis_-_Got_Ma_Nuts_From_A_Hippy_%28guitar_pro%29.gp5

Link to post
Share on other sites

  • Replies 2.6k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi, folks. I'll be using this thread to maintain the latest versions of EOF in one place. To start, download and extract EOF 1.8RC12: http://www.mediafire.com/file/ih70h6p67iy77ka/eof1.8RC12.zip You

Hi, folks. The latest hotfix (r1363) is in the first post. Changes are as follows: *Added a warning during save if any lyrics have extended ASCII or Unicode characters, as these aren't compatible wit

Hi, folks. The latest hotfix (2-28-2017) is in the first post. Changes are as follows: *Fixed a bug with the handling of chord definitions that would cause thumb usage to be omitted from definitions i

 

Something about the included XMLs are crashing RS

 

https://drive.google.com/file/d/0B2oZs0ta32KyZHpGZHltcy0tVEk/view?usp=sharing

 

I just don't know what.

 

I build the custom with bass and vocals and it works.  I include Rhythm or Lead and the custom plays the intro music, but as soon as you press "go" it fails and locks the game up.

 

Any help would be great :D

 

Using the DD XML files that you provided, the game will freeze like you said. If I use the non-DD XML files straight from EOF (which is what I did at first), both guitar arrangements can be played without problems, even if you generate DD using the .psarc file.
 
The showlights are causing the issue. The Toolkit seems to have problems generating them if you use those DD XML files. cst_showlights.xml is generated only(?) when the order of the arrangements is rhythm, lead, bass in the arrangement list.
  • Like 2
Link to post
Share on other sites

when the order of the arrangements is rhythm, lead, bass in the arrangement list.

 

 

Indeed, I did actually manage to build a couple of working .psarcs during my testing, but I did not record the order I added the arrangements.

 

The working .psarcs likely had Rhythm as the primary arrangement, as you say.

 

Thanks for having a look :D

 

I should find some time to test further later this evening.

 

 

----------------------------

 

And sorry for hogging the EoF thread with this, I did originally think the problem came from the EoF stage of development.  I'll transfer to a Toolkit thread for this in the future.

Link to post
Share on other sites

There is this one bug that annoys me very much but also appears somewhat random, where BPM grid (or notes and FHP?) will suddenly move just by a tiniest amount (only noticeable when you zoom in) making all of the notes non grid snapped. This also happens at a random time, usually after making some changes (adding or editing notes) or after hitting space to stop the track or sometimes it will happen only after saving and loading the project next time.
And I finally just found a way to reliably reproduce it:
1. Import a tab (loading existing project probably will work too), all notes should be gridsnapped
2. Use Beat->BPM change (with adjust notes checkbox, won't work if bpm doubled)
3. Use Beat->Push offset back
Now you can save and load or wait and track will turn cyan by itself at some random point

Link to post
Share on other sites

  • Developer

 

On another topic, I updated the toolkit to the latest beta (the one released yesterday) and it wasn't accepting lyrics files (that I was producing with the 4-17-2017 release of EoF) that older versions of the toolkit did when I reverted. Anyone else having a problem with this, and know if it's an incompatibility issue or a problem with the toolkit?

 

It's a toolkit problem. Currently it will only accept lyrics files that end with "vocals.xml".

 

This should be fix now.  Can you confirm?

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to post
Share on other sites

  • Developer

 

 

This should be fix now.  Can you confirm?

 

 

It works, but it's not foolproof since one can change the name of the vocals track in EOF.

 

I'm not sure how it could be made foolproof without creating a list of reserved words that can not be used in file names, which would include, 'vocals',  'showlights', etc.  If one can change the name of the vocals track in EOF then one must be an expert user and should know better, right?  ;)

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to post
Share on other sites

1. Import a tab (loading existing project probably will work too), all notes should be gridsnapped

2. Use Beat->BPM change (with adjust notes checkbox, won't work if bpm doubled)

3. Use Beat->Push offset back

Now you can save and load or wait and track will turn cyan by itself at some random point

To help me troubleshoot this issue, could you send me an EOF project file (no audio necessary) and a list of minimum steps needed to cause the problem, ie:

1. Open the project.

2. Select beat #.

3. Use "Beat>BPM change" to set a tempo of #.# BPM, and indicate which (if any) of the checkbox options you enabled.

4. Use "Beat>Push offset back" # number of times, also indicate if you selected a different beat number than what was selected in step #2.

 

I'm not sure how it could be made foolproof without creating a list of reserved words that can not be used in file names, which would include, 'vocals', 'showlights', etc. If one can change the name of the vocals track in EOF then one must be an expert user and should know better, right? ;)

Since the XML file names are arbitrary, I don't know if they can really be counted on. If you're willing to parse the file to validate it as being a lyric file, checking for the presence of a tag as the first non-comment tag should be enough to tell for sure.
Link to post
Share on other sites

  • Developer

 

Since the XML file names are arbitrary, I don't know if they can really be counted on. If you're willing to parse the file to validate it as being a lyric file, checking for the presence of a tag as the first non-comment tag should be enough to tell for sure.

 

I actually thought of doing that too (parse the file to validate it as being a lyric file), and then realized there is only one of me. 

  • Like 1

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to post
Share on other sites

https://drive.google.com/open?id=0B86b0ZnKItPUQ2JzOGsxV3BEQnM

1. Open the project.
2. Select beat 1 (though same thing will happen if you bpm changed from any beat)
3. Use "Beat>BPM change" to set a tempo of 145.00 BPM only adjust notes selected (I just tried to change bpm to 150 and that surprisingly works fine)
4. Use "Beat>Push offset back" 5 times (I always use this from the first beat and push it back 1 measure)

 

And if I do ctrl+a, ctrl+shift+r on a track after this most FHPs left a bit too late, which is the most annoying part of this bug if FHPs were edited manually.

Edited by theSG
Link to post
Share on other sites

I have spoken about this issue a long, long time ago, although I did not articulate the problem similarly.

 

I do not have "highlight non-grid snapped notes" option switched on in EoF because I would be looking at cyan graphs almost permanently.

 

It's not the grid moving, it's the notes.  It comes because (I think, I am sure raynebc can correct me) of difficult maths i.e. sums that require rounding.

 

For example, you say that it never happens when you double the bpm.  Because doubling something is mathematically easy and does not require rounding multiple decimal places.

 

But when you go from 120 (the defaut number) to something like 145 then the multiplier is 1.20833333 which cause some of the notes to come off grid ever so slightly.

 

I think it happens as soon as you change BPM, it's just that EoF seems to not be highlighting it straight away.  There is possibly logic to why EoF takes a step or 3 before it realises notes are off grid and highlights them.

 

To reproduce what I mean

 

- Change BPM (with auto adjust notes)

- Press Ctrl+A to highlight all notes

- Hit Ctrl+Shift+R to re-snap all notes

- Hit Ctrl+Z to make EoF "undo"

- Notes will now be highlighted cyan

 

 

 

The moral of the story is that when you change BPM (especially when you are actually changing individual beats to beat map the song) then notes come off grid.  It is good practice to selct all the notes and re-snap them again manually at regular intervals.

 

I always re-snap all arrangements (including tech notes) before saving an EoF project.  Even if I plan to come back to the project and work some more on it later (i.e. it not "finished" yet), I always re-snap before saving.

 

To re-cap, the commands that will solve your issue

 

- Ctrl+A to highlight all notes

- Ctrl+Shift+R to re-snap

 

 

 

Enjoy :D

  • Like 1
Link to post
Share on other sites

The moral of the story is that when you change BPM (especially when you are actually changing individual beats to beat map the song) then notes come off grid.  It is good practice to selct all the notes and re-snap them again manually at regular intervals.

 

This is exactly my problem, I did resnapped the notes before saving and still got the cyan track, so this seems to be slightly different issue

Link to post
Share on other sites

I can only get cyan consistently after using the Push Offset Back.  I cannot generate it, even with your save file, on loading EoF after a save (I re-snap before saving).

 

I am only trying to help.

 

I do have the Note Auto-Adjust setting switched on though, have you tried that?

Link to post
Share on other sites

https://drive.google.com/open?id=0B86b0ZnKItPUQ2JzOGsxV3BEQnM

1. Open the project.

2. Select beat 1 (though same thing will happen if you bpm changed from any beat)

3. Use "Beat>BPM change" to set a tempo of 145.00 BPM only adjust notes selected (I just tried to change bpm to 150 and that surprisingly works fine)

4. Use "Beat>Push offset back" 5 times (I always use this from the first beat and push it back 1 measure)

 

And if I do ctrl+a, ctrl+shift+r on a track after this most FHPs left a bit too late, which is the most annoying part of this bug if FHPs were edited manually.

I can't reproduce the problem with these steps with either the current hotfix or 1.8RC12. For "Beat>Push offset back", it doesn't matter which beat is selected, the result is the same.

Link to post
Share on other sites

I believe that I am using the lastest EoF (eof1.8RC12 5-3-2017) and I can produce cyan at will:

 

- Load the sample project

- Select any beat

- Use Push Offset Back (the more times you use POB, the more cyan lines you get)

- Resnap chart

- Hit undo

 

POB looks to be knocking the notes off slightly, I don't know how much of a problem it is though.  My normal workflow would deal with slightly off grid notes, plus I don;t use the highlight non grid snapped notes feature so I don't know how often (or if) notes are going slightly off grid in my own projects.

Link to post
Share on other sites

 
I can't reproduce the problem with these steps with either the current hotfix or 1.8RC12. For "Beat>Push offset back", it doesn't matter which beat is selected, the result is the same.

 

Weird, just tried downloading rc12 and I can reproduce it exactly as in hotfix every time.

Thanks for looking into it anyway, at least now I know how to avoid the problem.

Link to post
Share on other sites

The next hotfix will have multiple corrections to improve this type of issue (notes losing grid snap when clicking and dragging beats, or when undoing an operation that changed beat positions).

Link to post
Share on other sites

Hi, Guys


 


  I just installed the new EOF and Toolkit and I have a problem with EOF. The new customs I have been making have the problem in the picture below while playin' on RockSmith. Could it be a preference setting set wrong in EOF? Has anybody seen a problem like this before? Bass line looks OK and Lead Looks OK , but some chords look like the pic. below.


 


Thanks, Avdocatwork


 


lOvDFMW.jpg


Link to post
Share on other sites

Hi, folks.

 

The latest hotfix (5-22-2017) is in the first post. Changes are as follows:

*Corrected the "Export time range" function to export all of the track-specific details (ie. customized name, fret/string count, etc).

*Corrected the "Export time range" function to ensure the first exported beat explicitly has whatever time signature was in effect in the source project.

*Fixed a bug where setting the difficulty of the pro drum or harmony vocal difficulty to undefined while it was already undefined would mark the chart as modified.

*Improved the "Track>Set difficulty" menu to display a check mark reflecting the active track's currently defined difficulty. If the vocal and harmony difficulties are different, or drums and pro drums difficulties are different, the "Manually set" item is checked.

*Fixed a bug with the project save logic (also affects undo/redo states) that prevented supplemental precision beat timing data from being written in a usable way. Beat timings are now stored in the project to a precision of over 10 decimal places. This should reduce the number of notes that lose sync during certain beatmap alterations.

*Improved beat click and drag logic to immediately update the note and tab highlighting if any notes lost grid snap.

*Fixed bugs with the click and drag logic that (under specific timing circumstances) could cause beats to become desynced by 1ms with notes after the notes are auto-adjusted.

 

@@avdocatwork

A common cause for this is not really using the latest toolkit (the "test build" which is version 2.8.2.0) and then not disabling the abridged XML feature in EOF despite the warning that older versions of the toolkit won't support it. If that isn't really the cause of the problem, please reply with more information.

  • Like 6
Link to post
Share on other sites

@@raynebc,

 

During a GP tab import in EOF, a single note with a slide is terminated with a new gem related to the end fret position. I was expected to have only the first note with the slide and its end fret position, but not the last gem at the end of the sustain.

Is it the normal behaviour ?

 

Thanks

 

Envoyé de mon SM-G920F en utilisant Tapatalk

Link to post
Share on other sites

I am not sure what the problem is, but I just launched EoF after having not used it in about a month and suddenly the entire program is lagging a lot. I tried updating to the latest hotfix, same thing. I tried downloading and making a complete new install, same thing.

 

Absolutely nothing have changed on my end since I last ran the software fine, so I'm clueless as to why it runs so bad now. When I click on a menu item, the entire menu bar flashes 1-2 times and then the menu pops up about a second later. Tried running as admin or different compatibility modes, but that did nothing. I'm at a loss on what to do to fix this. :(

 

Edit: Well, this just disappeared as randomly as it appeared. Was working on a song for a while, quit EoF and then came back a bit later and suddenly the program was back to normal. ¯\_(ツ)_/¯

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy