Jump to content

Latest EOF releases (9-26-2020)


Recommended Posts

  For each character it displays in the game the following informations :

  - ASCII code

  - the character itself

  - [ND] tag if the character isn't displayed in the game (with no crash)

  - [NV] tag if the character is special and hasn't a visible symbol

 

 

I am interested to know how you built the .psarc with these characters in?

 

It seems to me that the toolkit is filtering out some characters during the build process.  Was the toolkit behaviour amemded after your testing, using the results?

 

 

Thanks :D

Link to post
Share on other sites

  • Replies 2.7k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi, folks. I'll be using this thread to maintain the latest versions of EOF in one place. To start, download and extract EOF 1.8RC12: http://www.mediafire.com/file/ih70h6p67iy77ka/eof1.8RC12.zip You

Hi, folks. The latest hotfix (r1378) is in the first post. Changes are as follows: *Improved GP import to process bend status for grace notes, it will apply a bend strength to the grace note correspo

Hi, folks. The latest hotfix (r1363) is in the first post. Changes are as follows: *Added a warning during save if any lyrics have extended ASCII or Unicode characters, as these aren't compatible wit

I had commas working yes.

 

https://drive.google.com/file/d/0B2oZs0ta32KyNVljX3RKMmxLcFE/view?usp=sharing

 

Built with the latest (as of now) EoF and Toolkit.

 

It's getting ã to work that the problem.  Even though it works in the name/title, it doesn't work in lyrics :(

 

 

 

Edit - I think there is a fix on the way for the Vocals_EXT.  Use the normal Vocals XML for now.

Link to post
Share on other sites

I am interested to know how you built the .psarc with these characters in?

 

It seems to me that the toolkit is filtering out some characters during the build process.  Was the toolkit behaviour amemded after your testing, using the results?

 

Thanks :D

 

@Pc Plum,

 

  Some characters are not displayed in the game (those with [ND] or [NV] tags in my testing XML file)

  Can you give me an example of a specific character you can't use in RS ?

 

Thanks

Link to post
Share on other sites

The character is ã.

 

I could not get it to appear in game in the lyric lines, which is concurrent with your test results.

 

What was slightly confusing me is that it appears no problem in the artist name.

 

 

And cozy1 has explained how to get any character you want passed the checks and into the game using the Toolkit XML Editor.  Although, obviously some characters do not work.

 

 

Thanks :D

Link to post
Share on other sites

  • Developer

@PC Plum 'What was slightly confusing me is that it appears no problem in the artist name.'

 

Artist, title, album names have different validation rules than do lyrics.  Lyrics characters are validated to be consistent with the lyrics.dds font file.  If you make a custom font DDS file that contains ã then you may be able to use the ã for lyrics in-game.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to post
Share on other sites

  • Developer

@Chlipouni 

 

Have you tried replacing '-' with –

 

Here's a thread with other alternatives for how to use dashes.

  • Like 1

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to post
Share on other sites

Can anyone get a comma to work within lyrics with the latest release?

 

Looks like commas etc. work only if there are extended ASCII characters in the lyrics. I haven't really missed commas, but I'd like to be able to use double quotes and parentheses without having to edit the lyrics files manually.

Link to post
Share on other sites

When these characters were previously suspected of causing crashes, they were blacklisted from XML in general:

( } , \ : { " )

 

When extended ASCII is present, EOF uses different logic to create the XML lyrics and uses the more comprehensive list of characters verified to work in-game. If everybody is satisfied that the above characters should work for lyrics even though they can't be used in other parts of the XML (ie. phrase names, tone names, chord names), I can work on changing the "normal" lyric export to allow them.

  • Like 1
Link to post
Share on other sites

There is confision going on.  Commas have always worked.  In the screenshot I provided not a few posts above, the comma is present and I used the normal EoF vocals output.

Link to post
Share on other sites

Those characters were banned from lyric export about a year and a half ago. Only recently has it been brought up for discussion again. In your example, the commas are showing up because your chart has extended ASCII characters and is using the new lyric export logic that doesn't filter the characters out. The old logic (used to export lyrics when there are no extended ASCII characters) still does filter those characters out, but it seems like that's been found to be unnecessary.

Link to post
Share on other sites

Hi, folks.

The latest hotfix (5-3-2017) is in the first post.  Changes are as follows:
*Changed the warning about extended ASCII in lyrics to not be given unless extended ASCII export isn't enabled or any non Rocksmith exports are enabled during save.
*Improved the RS import logic so that if no chart is loaded, the destination track selected by default reflects whether the input file's name reflects having been authored in one of EOF's bass, bonus or 22 fret tracks (ie. if the track wasn't manually given a name).
**Fixed a bug where unsupported extended ASCII characters weren't correctly omitted from exported UTF-8 RS2 lyric files.
*Changed RS lyric exports to allow ( } ,  \  : { " and ) since it had been determined that even though these characters can't be used for most named items in the chart, they are usable for lyrics.
*Improved RS lyric exports to substitute unsupported accented Latin characters with non-accented versions as appropriate, for example, Ã is replaced with A.  If RS2 extended ASCII export is enabled, only the accented characters that Rocksmith doesn't allow to be used in lyrics are substituted, otherwise all accented characters are substituted.  The RS2_EXT lyric file will still contain all accented characters as-is (even those Rocksmith doesn't allow) and is only meant to be used to import back into EOF or FoFLC.

  • Like 3
Link to post
Share on other sites

Hi I have a problem with EOF it has been working great for me until i upgraded my computer from windows 7 to windows 10. Now when i try to load EOF there is just a white screen it doesnt show the menu or anything can anyone help me theres a CDLC song i really want to create and I can't do it :( has anyine else experienced this issue if so how can i fix it 

Link to post
Share on other sites

@@raynebc - So, I was working on a big song and some subparts of it for which I used the "Export time range" function and noticed a few flaws with how it works (I was using 4-17-2017 version at the time). The first one is pretty major, the others are less important and fairly easy to work around.

 

1) The exported EoF file seems to "forget" most of the track information. The tuning, number of strings, and arrangement type seem to reset to default for those tracks, and "Ignore tuning/capo" seems to get set to on (I haven't tested on a track with a capo to see if that gets reset or not, and I may have missed other variables that get changed). Tone changes (though defaults and stuff may need to be changed due to how the track is chopped up), track fret number, and all of the visible chart information (gems, FHP, sections, and so on.) seems to export as you'd expect, though. Anyway, the big annoyance is that for me, a six-string bass track that I have set on "Part Real_Bass_22" only remembers the lowest 4 strings when I export. I was able to work around this by cloning it to the bonus track and then exporting, then cloning the bonus track back to the bass part.

 

2) (This is more of an FYI than a bug, I guess) If you export from an off-beat time-stamp then it seems that EoF will shift the beats in the exported file so the first beat happens at the start of the song, which moves all of the beats so it basically becomes a note-synced and not beat-synced map. And if you don't start on the beginning of a measure, it shifts things so that the measures don't start at the appropriate place. So you need to be careful to use the exact timestamps of the beginning of a measure. But there might be a better way of doing the "padding" so that the beatsync stays in place.

 

3) Until the first measure that has a time signature explicitly defined (rather than no change), the exported file has the time signature undefined. I was able to get it to export the time signature as well by manually defining the time signature on the measures where I chose to start the exports (if they weren't already new time signatures). So again, this isn't a major deal, but there might be a better way to deal with it so that it doesn't have to be entered manually (whether in the original file or in the export).

 

If you have trouble reproducing any of these I can send some of the files I was using along.

 

 

On another topic, I updated the toolkit to the latest beta (the one released yesterday) and it wasn't accepting lyrics files (that I was producing with the 4-17-2017 release of EoF) that older versions of the toolkit did when I reverted. Anyone else having a problem with this, and know if it's an incompatibility issue or a problem with the toolkit?

My CDLC releases and my workshop 
My CDLC previews (Lots of bass only stuff)
Join us at the Rocksmith Championship!

Link to post
Share on other sites

On another topic, I updated the toolkit to the latest beta (the one released yesterday) and it wasn't accepting lyrics files (that I was producing with the 4-17-2017 release of EoF) that older versions of the toolkit did when I reverted. Anyone else having a problem with this, and know if it's an incompatibility issue or a problem with the toolkit?

 

It's a toolkit problem. Currently it will only accept lyrics files that end with "vocals.xml".

Link to post
Share on other sites

Hi I have a problem with EOF it has been working great for me until i upgraded my computer from windows 7 to windows 10. Now when i try to load EOF there is just a white screen it doesnt show the menu or anything

I've only finding two instances where people reported this behavior on this forum. One of the users never came back to follow up. The other mentioned it turned out to be an antivirus issue.

 

@@albatross213

I'll look into the first issue you mentioned.

 

2) (This is more of an FYI than a bug, I guess) If you export from an off-beat time-stamp then it seems that EoF will shift the beats in the exported file so the first beat happens at the start of the song, which moves all of the beats so it basically becomes a note-synced and not beat-synced map. And if you don't start on the beginning of a measure, it shifts things so that the measures don't start at the appropriate place. So you need to be careful to use the exact timestamps of the beginning of a measure. But there might be a better way of doing the "padding" so that the beatsync stays in place.

Unless I'm misunderstanding you, this is what is meant to happen. The resulting chart should still be as beat-synced (beat markers synced to the music) as it was before the time range export. If you want to pad the beginning with empty beats to fill in the measure, you can add leading silence (specifying an appropriate number of beats), and then use "Beat>Push Offset Back" a number of times equal to the number of beats of leading silence that was added. This should result with the chart's first beat beginning on a measure.

 

3) Until the first measure that has a time signature explicitly defined (rather than no change), the exported file has the time signature undefined.

I'll look into this.
Link to post
Share on other sites

  • 2 weeks later...

Double post ftw :)

 

Alas it was not FHP causing my problem.  The following project files will show that the arrangements I think are causing the problems do not contain FHPs.

 

Something about the included XMLs are crashing RS

 

https://drive.google.com/file/d/0B2oZs0ta32KyZHpGZHltcy0tVEk/view?usp=sharing

 

I just don't know what.

 

I build the custom with bass and vocals and it works.  I include Rhythm or Lead and the custom plays the intro music, but as soon as you press "go" it fails and locks the game up.

 

Any help would be great :D

 

EoF v1.8RC12 4/17/2017

Toolkit rstoolkit-2.8.2.0-69be634f-win

  • Like 1
Link to post
Share on other sites

Double post ftw :)

 

Alas it was not FHP causing my problem.  The following project files will show that the arrangements I think are causing the problems do not contain FHPs.

 

Something about the included XMLs are crashing RS

 

https://drive.google.com/file/d/0B2oZs0ta32KyZHpGZHltcy0tVEk/view?usp=sharing

 

I just don't know what.

 

I build the custom with bass and vocals and it works.  I include Rhythm or Lead and the custom plays the intro music, but as soon as you press "go" it fails and locks the game up.

 

Any help would be great :D

 

EoF v1.8RC12 4/17/2017

Toolkit rstoolkit-2.8.2.0-69be634f-win

 

I've had this problem too. Seems to only occur after I use the toolkit to add DDC to the arrangement.

New toolkit doesn't throw an error when generating the DDC, but using and older version I get a weird error creating DDC about the first chord having intensity or something, even though the xml looked find. Gave up after an hour... 

 

Here is XML. http://www.mediafire.com/file/37qrz6fy0r9v805/PART_REAL_GUITAR_RS2.xml

  • Like 1
Link to post
Share on other sites

Well as it happens the problem is coming from (I believe) the stuff I ripped off from your custom of the recorded version :D

 

The bass and vocals play fine, I think there is something in the chords I copied from your custom that is causing the issue.  I was thinking FHPs or chord fingering.  I was also thinking it may be related to Rocksmith Import because I unpacked your custom and stole the chords basically :D

 

I was testing for ages last night, making many builds and loading the game up to try things out, and I gve up.  I was hoping for a descerning eye to cast over the XMLs quickly to see if they could spot any glaring flaws that I can't see.

 

I'll have another bash at fixing it later, I'll probably start with erasing all fingering from the chords.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy