Jump to content

  • 0

Sync problems PC


Mr. Dahl
 Share

Question

Hi guys.

I just bought the game everybody recommend, and was speaking so great about. But unfortunately I overlooked all the issues.

The sound of my guitar is lagging, and is definitely out of sync.

Is there anyone who could guide my to a better life with RockSmith..?

Thanks a million.

Link to comment
Share on other sites

22 answers to this question

Recommended Posts

  • 0

Thx guys. I have tried pretty much everything. But still the same.

My laptop is less then a year, it's a windows 10 though, but I'm sure that's not the problem.

The ini file should be the right place to change settings from default, and I tried this all day now, one setting at the time. I also made the recommended chances in the sound card, still no good. Updated all drivers (sound card, and RC cable). And now I'm stuck, can't figure out what to do from this point.

Link to comment
Share on other sites

  • 0

here,s my settings... runs on 40" tv through hdmi with no problems...(no guarantee it will work for you though)

 

[Audio]
EnableMicrophone=0
ExclusiveMode=1
LatencyBuffer=4
ForceDefaultPlaybackDevice=
ForceWDM=0
ForceDirectXSink=0
Win32UltraLowLatencyMode=1
DumpAudioLog=0
MaxOutputBufferSize=0
[Renderer.Win32]
ShowGamepadUI=0
ScreenWidth=1280
ScreenHeight=720
Fullscreen=2
VisualQuality=3
RenderingWidth=0
RenderingHeight=0
EnablePostEffects=0
EnableShadows=1
EnableHighResScope=0
EnableDepthOfField=0
EnablePerPixelLighting=1
MsaaSamples=1
DisableBrowser=1
[Net]
UseProxy=1

Link to comment
Share on other sites

  • 0

I don´t have my laptop right now, but your settings looks familiar. 

To double check the reliability on the IDI  file. I set the latency buffer to 16. Saved it, and opened the game, and clicked my way into "Audio option", and there by I could see the latency buffer has increased the value to 16. so all good to this point. 

 

I`ll check the settings latter today, but I`m beginning to think its a hardware problem. 

 

For now I have only tried this direct to my PC, as soon this work I will also use my tv screen. The setup now is simply the USB cable which included in the box.

Are you using a HDMI adaptor to your PC, and from this point HDMI to the 40" screen of yours ? 

Link to comment
Share on other sites

  • 0

hdmi cable from "hdmi out" on laptop to hdmi port on back of tv..

then make sure , on playback devices, hdmi is set to default..

 

guessing from what you said,, your pc doesn,t have an " hdmi out" port ? although using an adapter should work ok..

 

looks like the latency buffer at 16 is going to give you a lot of lag.go to the smaller number of 4 and try..

 

Rocksmith INI File Details
There are two major sections to the Rocksmith.INI file. The first controls the audio settings of Rocksmith:EnableMicrophone [default: 0] - Set this value to 1 to enable the use of voice microphone. This is duplicated in the Rocksmith menus.

LatencyBuffer [default: 4] - This value allows you to adjust one of the audio buffers used by Rocksmith. A smaller value will use a smaller buffer. Smaller buffers mean lower latency, but increase the demands on your PC to avoid audio crackling. Most recent high performance PCs can handle a setting of 2. The fastest PCs might be able to run reliably at 1.

ExclusiveMode [default: 1] - Set this value to 0 if you want to have other audio programs running at the same time as Rocksmith. You may need to increase your LatencyBuffer setting to avoid audio issues.


ForceWDM [default: 0] - Set this value to 1 if you've tried the fine tuning configuration options and still cannot get good audio latency or have audio issues you cannot resolve. This will force the game to use the previous Windows mechanism to control your audio devices. It can impose higher latency than the default system, but is a good fallback.

ForceDirectXSink [default: 0] - Set this value to 1 if you've tried all other configuration options and still cannot get good audio. This forces the game to use an old Windows mechanism to control your audio devices. It will almost always impose high latency, but should allow you to run the game. Use this as your last option.

DumpAudioLog [default: 0] - Set this value to 1 if you need to send debugging information to Ubisoft. It will create a text file called audiodump.txt, located in the same directory as the Rocksmith application. Once you have run the game with this switched on, be sure to set the value back to 0. Leaving the audio log enabled can degrade performance so leave it set to 0 for normal gameplay.

MaxOutputBufferSize [default: 0] - A few audio devices have been found to have very large output buffers. In this case, the game does its best to choose a reliable audio buffer size. However, you might find that setting this variable will help to resolve audio issues. In its default setting of 0, it leaves the configuration of this value up to Rocksmith. Most audio cards end up using an audio buffer size of 1024. Fast PCs can usually run with this at 512. If you have disabled Exclusive Mode, you may need to use a higher setting for this. We haven’t run into any specific issues regarding the choice of values for MaxOutputBufferSize, but you have have better luck using multiples of 8 or 32.

Link to comment
Share on other sites

  • 0

Try to set LatencyBuffer to 1 and MaxOutputBuffersize to 1024 . Start the game and if you hear crackling and ugly noise in the intro, just Alt-F4 out of the game and set LatencyBuffer to 2. But if you hear clean sounds, then go with LAtencyBuffer 1 and lower the OutputBuffer by 256, 128 or similar increments until you hear crackling. Revert to the last value with clean sound and you should be good to go. Start the game and see if the latency got better.

 

There are also speaker systems like TV soundbars, Logitec UE Boom or Sonos Play that will introduce enough latency to drive you crazy. They can add up to 70ms or more. Also wireless headsets or BT Speakers are usually a no go. It is also a good idea to disable HDMI audio and other input/output audio devices you do not need on the computer.

  • Like 1
Link to comment
Share on other sites

  • 0

Hi all.

Thx a million for all your help.

Another evening went with fighting these settings, and it just didn't got any better.

juppStein. I tried your suggestion. It was really clear that the maxoutputbuffersize had a sound effect to the game. I started with 1024, and latencybuffer in 1. Game sounded clean, but still a lot of latency. Then I jumped all the way down to 128, now the game started crackling really bad, so I increased the value step by step. When I hit 512 the game sounded clean. From this point, I increased the latencybuffer from 1 to 2. But it didn't made any difference, nor did 3 4 and 5. So it didn't make sense to increase it further.

Spacy7. I tried your sittings as well, but no luck.

I'v been playing guitar for around 10 years now, so I have several amps. Last test this evening was putting a miniJack in my laptop headphone output, direct in a small amp, but still no good.

At this very moment, my only idea is to try install the game on my sons gaming PC. Just to hear the difference.

Any other ideas from you guys is much appreciated.

Link to comment
Share on other sites

  • 0

try without hdmi, it's the highest probability for a sound delay.

Maybe in the one or other cases it may work with hdmi, but generally it does a high latency what makes the game unplayable.

  • Like 1
 YouTube                                                           The Phantastic 3                                                       Facebook

Captain-Sparton-weiss minimini.png

Link to comment
Share on other sites

  • 0

Firstly, latency is subjective.  Some people just don't bother about quite high latency, and others can't stand the tinyest bit.  It may be the same latency we all hear, it's just that it completely nips your head.

 

How long is the latency, like half a second?

 

 

Some other things to try, other than what has been said

 

- Play using headphones.  Try to drown out the acoustic noise of your strings.  This does not change latency, only the perception of it.

 

- Get a splitter box, playing through your own amp (and effects) with a signal split off to go to the computer for processing.  This method costs more money, but lots of people play this way and swear by it.

 

- Disable any sound driver effects which may be causing extra latency (extra bass/eq/etc).

 

- Try Audio Exclusivity setting On/Off (requires game restart each time you change this)

 

 

 

Good luck :)

  • Like 1
Link to comment
Share on other sites

  • 0

Hi all.

The latency I'll guess is around half a second. Actually it makes it impossible to pass the bending lesson. As I said previously, I'm not a beginner on a guitar so all this lesson should be walk in a park, but the latency kills it.

 

I haven't been testing for a while now, it simply took to much time. But tonight I started the game again and tried ones more everything you guys recommended without any success.

Tomorrow I'll contact Ubisoft, and if necessary ask them to Teamview my laptop.

Link to comment
Share on other sites

  • 0

Hey FireKorn..

All my focus up until now have been trying fix this issue, so I could actually start using the game. Next step will be investigating how to get my hands on all my favorite guitar bands like Metallica, Megadeth etc. The standard setliste in the game is to me completely useless and ducked up.. So I guess I'll take a deeper look into this CDLC as soon my game works properly.

Link to comment
Share on other sites

  • 0

Hey guys..

An update with good and bad.

As you know, I wrote a mail to ubisoft last week and they still haven't replied to me, I assume I left them speechless.

The good news is that I ones again armed my self up with patience and took all settings step by step ones again this evening. The latency is still there but decreased to a 'accepted' level. So I jumped back to game lessons, and started the 'bending' session. Before it was absolutely impossible to complete even the most simple bends, but now it seems a little easier. I was pretty sure I played the lesson perfect, so I new there was more to bring from the audio setting. It turns out, that the audio performers was set to 3.7 db, so I put it back to default (-1.2db).

At this very moment I'm still not totally

satisfied, but it's a lot better now.

I'll see whether I can get used to the minor latency in the upcoming days.

Next step will be installation of this CDLC stuff. I'm looking so much forward to kill some metallica, and megadeth riffs.

  • Like 1
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy