Jump to content

  • 0

RSInjector Not Loading (Just Crashes)


sclaxplayer
 Share

Question

System: Mac OSX 10.11.6

 

Yesterday I was playing CDLC fine through the new version of RSInjector. Today I went to launch it again and it just crashes before anything even loads. I see all my failed launches in Mac's Console.

 

Here's a small snippet of the error message from Console:

Process:               Rocksmith2014 [32791]
Path:                  /Users/USER/Library/Application Support/Steam/*/Rocksmith2014.app/Contents/MacOS/Rocksmith2014
Identifier:            Rocksmith2014
Version:               1.0 (1)
Code Type:             X86 (Native)
Parent Process:        ??? [1]
Responsible:           Rocksmith2014 [32791]
User ID:               502

Date/Time:             2016-11-02 18:54:51.521 -0700
OS Version:            Mac OS X 10.11.6 (15G1108)
Report Version:        11
Anonymous UUID:        DEE35852-C391-C4D8-63CF-86971FF940F7


Time Awake Since Boot: 4200 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000037845fa6
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x37845fa6:
    MALLOC_SMALL           0000000003800000-0000000004800000 [ 16.0M] rw-/rwx SM=PRV  
--> 
    __TEXT                 000000008fe42000-000000008fe77000 [  212K] r-x/rwx SM=COW  /usr/lib/dyld

Application Specific Information:
/Users/USER/Library/Application Support/Steam/steamapps/common/Rocksmith2014/./Rocksmith2014.app/Contents/MacOS/Rocksmith2014

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   Ubisoft.Rocksmith2014         	0x0000c86e 0x1000 + 47214
1   dyld                          	0x8fe56190 ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 64
2   dyld                          	0x8fe51e9e ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 296
3   dyld                          	0x8fe51d31 ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 105
4   dyld                          	0x8fe51f91 ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 79
5   dyld                          	0x8fe43f7f dyld::initializeMainExecutable() + 218
6   dyld                          	0x8fe47c5b dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**, unsigned long*) + 3534
7   dyld                          	0x8fe43231 dyldbootstrap::start(macho_header const*, int, char const**, long, macho_header const*, unsigned long*) + 427
8   dyld                          	0x8fe43047 _dyld_start + 71

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0x00000001  ebx: 0x00000000  ecx: 0xbffffc24  edx: 0xbffffc2c
  edi: 0x0000c810  esi: 0xbffffc70  ebp: 0xbfffd7c8  esp: 0xbfffd76c
   ss: 0x00000023  efl: 0x00010246  eip: 0x0000c86e   cs: 0x0000001b
   ds: 0x00000023   es: 0x00000023   fs: 0x00000000   gs: 0x0000000f
  cr2: 0x37845fa6
  
Logical CPU:     2
Error Code:      0x00000004
Trap Number:     14

Here's what I have tried to do to remedy the situation:

1) Uninstall/Reinstall RSInjector

2) Uninstall/Reinstall Rocksmith through Steam

3) Tried running Rocksmith from the "Application Specific Information" stated above by opening terminal and running "/Users/USER/Library/Application Support/Steam/steamapps/common/Rocksmith2014/./Rocksmith2014.app/Contents/MacOS/Rocksmith2014" but I just got a Segmentation fault:11.

 

Has anyone experienced this issue before? I'm not sure how I can fix this.

Thanks for any help!

  • Like 2
Link to comment
Share on other sites

Recommended Posts

  • 0

Oh, the screen shot didn't send haha...

Once I download it, I drag the 'MAC_Patch' folder out of my downloads (It isn't a zip file btw), left click but the only options are 'open', 'move to trash', 'get info' etc. There is no 'other' option either.

Link to comment
Share on other sites

  • 0

If you haven't disabled the option, Safari might unzip it automatically when you download it.  If that's the case, make sure you have read/write permissions for all three files.  You can find detailed instructions on how to check that here:

http://customsforge.com/topic/33889-how-to-add-custom-songs-on-mac/

 

Then just double click on "RUN_PATCH_RS.command" and that will open the Terminal app and run the patch.

 

 

Also, you don't need to move the file anywhere.  It's fine to run it from your Downloads folder.

Link to comment
Share on other sites

  • 0

Here's a patching system that does what @@Angra1982 do in a more "practical" way for different cases :

 

https://drive.google.com/open?id=0B1ZKYtpB0vu2WnJWZzdtUkp6SU0

 

1) Extract anywhere

2) Run the "RUN_PATCH_RS.command"

3) Launch Rocksmith 2014 Remastered via steam (do not use the RSinjector anymore)

4) ???

5) Profit!

 

Note 1 : You won't have to repatch the app unless there's a new update

 

Note 2 : RS should be in the standard installation path and Steam too.

 

Some user might encounter permission issue, here are two way to edit it :

Anyone that have issue with this please indicate :

  • MAC OS version
  • Steam path
  • How RS react to CDLC

 

Side note, if it works for you please indicate your MAC OS version so that we can know which version are correctly supported.

Confirmed so far :

  • 10.12
  • 10.11
  • 10.10

@@Wepeel you might be very interesting in this post ;)

 

Credits :

 

Thanks for 0x0L over the github too for tolerating me and creating msot of that script!

https://github.com/rscustom/RSInjector-Mac/

 

@@Lovroman for the same thing :D

 

@@Angra1982 that insert_dylib is quite a discovery! Nice work!

 

thank you so much for the "idiot-proof" solution. i know nothing about code stuff in my computer i just know "download this place there cross fingers see if it worked"

Link to comment
Share on other sites

  • 0

If you don't see them, it's usually because you don't have Cherub Rock.

Thanks Magna Charter.  I had forgotten that I unchecked the Cherub Rock song as I was trying to fix the problem.  Once I checked it all my CDLC came back.  Also, thanks Wepeel for helping me get the patch working.  I really appreciate it.  

  • Like 1
Link to comment
Share on other sites

  • 0

I am curious about something... I don't know whether it is related to this CDLC patch or not (so if not I apologize in advance for posting it here; but I didn't notice this before the patch), but.... I don' seem to be able to turn off Master Mode. No matter what I do, whether I'm playing the track or in Riff Repeater, if it gets it into its head that I know the track well enough, it makes me play invisibly.

 

I've turned it off, on, off....

 

If anyone has an idea about this, let me know! Thanks!

Link to comment
Share on other sites

  • 0
  • Administrator

@@dr150 CDLC need to be repacked with the latest beta toolkit to be fix the 100% bug

 

@@nick_beat many user have mentioned this and it is mostly suggested to try to set back to default all the option. Not sure it will fix your issue but it's the only option i can think off right now.

  • Like 1

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to comment
Share on other sites

  • 0

@@dr150 CDLC need to be repacked with the latest beta toolkit to be fix the 100% bug

 

How can you do a "Repack" if the you have the Mac song file in Mac and encode again to Mac?  The software doesn't allow this.

 

Would I take the "corrupted" Mac song file, convert it to PC with Toolkit, then back to Mac? 

 

Would you suggest I do this "Toolkit reconversion" on all my 600 files or only the offending ones as they pop up as I play new songs?...

 

Thanks in advance.

Link to comment
Share on other sites

  • 0

This latest patching system posted by Firekorn works for me on 10.12.1. Thanks for the help

How did you get it to work? All the instructions I read make no sense. Can you help me figure this out? I just got 2014 remastered for my mac, I really want the cdlc but I don't know how to set it up.

Thanks

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy