Jump to content

  • 0

RSInjector Not Loading (Just Crashes)


sclaxplayer
 Share

Question

System: Mac OSX 10.11.6

 

Yesterday I was playing CDLC fine through the new version of RSInjector. Today I went to launch it again and it just crashes before anything even loads. I see all my failed launches in Mac's Console.

 

Here's a small snippet of the error message from Console:

Process:               Rocksmith2014 [32791]
Path:                  /Users/USER/Library/Application Support/Steam/*/Rocksmith2014.app/Contents/MacOS/Rocksmith2014
Identifier:            Rocksmith2014
Version:               1.0 (1)
Code Type:             X86 (Native)
Parent Process:        ??? [1]
Responsible:           Rocksmith2014 [32791]
User ID:               502

Date/Time:             2016-11-02 18:54:51.521 -0700
OS Version:            Mac OS X 10.11.6 (15G1108)
Report Version:        11
Anonymous UUID:        DEE35852-C391-C4D8-63CF-86971FF940F7


Time Awake Since Boot: 4200 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000037845fa6
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x37845fa6:
    MALLOC_SMALL           0000000003800000-0000000004800000 [ 16.0M] rw-/rwx SM=PRV  
--> 
    __TEXT                 000000008fe42000-000000008fe77000 [  212K] r-x/rwx SM=COW  /usr/lib/dyld

Application Specific Information:
/Users/USER/Library/Application Support/Steam/steamapps/common/Rocksmith2014/./Rocksmith2014.app/Contents/MacOS/Rocksmith2014

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   Ubisoft.Rocksmith2014         	0x0000c86e 0x1000 + 47214
1   dyld                          	0x8fe56190 ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 64
2   dyld                          	0x8fe51e9e ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 296
3   dyld                          	0x8fe51d31 ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 105
4   dyld                          	0x8fe51f91 ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 79
5   dyld                          	0x8fe43f7f dyld::initializeMainExecutable() + 218
6   dyld                          	0x8fe47c5b dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**, unsigned long*) + 3534
7   dyld                          	0x8fe43231 dyldbootstrap::start(macho_header const*, int, char const**, long, macho_header const*, unsigned long*) + 427
8   dyld                          	0x8fe43047 _dyld_start + 71

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0x00000001  ebx: 0x00000000  ecx: 0xbffffc24  edx: 0xbffffc2c
  edi: 0x0000c810  esi: 0xbffffc70  ebp: 0xbfffd7c8  esp: 0xbfffd76c
   ss: 0x00000023  efl: 0x00010246  eip: 0x0000c86e   cs: 0x0000001b
   ds: 0x00000023   es: 0x00000023   fs: 0x00000000   gs: 0x0000000f
  cr2: 0x37845fa6
  
Logical CPU:     2
Error Code:      0x00000004
Trap Number:     14

Here's what I have tried to do to remedy the situation:

1) Uninstall/Reinstall RSInjector

2) Uninstall/Reinstall Rocksmith through Steam

3) Tried running Rocksmith from the "Application Specific Information" stated above by opening terminal and running "/Users/USER/Library/Application Support/Steam/steamapps/common/Rocksmith2014/./Rocksmith2014.app/Contents/MacOS/Rocksmith2014" but I just got a Segmentation fault:11.

 

Has anyone experienced this issue before? I'm not sure how I can fix this.

Thanks for any help!

  • Like 2
Link to comment
Share on other sites

Recommended Posts

  • 0

Hey, I'm completely new here but this worked fine for me. On Sierra 10.12.3.

It took me a while to get a song to show up in my list but apparently it didn't have anything to do with this script, which seems pretty straight forward to me. It was because I didn't have Cherub Rock installed.

I don't know if this is necessary but I also changed the permissions on the song that I downloaded.
 

cd /path/to/dlc
chmod 755 my_song_m.psarc

I also don't know if this is necessary but I also removed a bunch of extra file attributes that OS X attached to the song I downloaded. That process is described here:
http://superuser.com/questions/155458/what-does-the-mean-on-the-output-of-ls-on-os-x-terminal

It basically goes like this: 
 

cd /path/to/dlc
xattr -l my_song_m.psarc 

And then for each attribute listed:
 

xattr -d com.apple.<attribute_name> my_song_m.psarc

^replace <attribute_name> with the actual attribute names listed. example:
 

xattr -d com.apple.quarantine my_song_m.psarc

Again, I don't know if the file permissions and attribute stuff is necessary but I'm kinda OCD. I suspect the file permissions on the song are necessary though.

 

Thanks!

Link to comment
Share on other sites

  • 0

Changing the file permission should not be necessary and the attributes are added by your browser, but should be no harm that the customs don't work or not showing up in the songlist.

 

http://apple.stackexchange.com/questions/104712/what-causes-os-x-to-mark-a-folder-as-quarantined

 

Which problem should the change of the permission or deleting attributes solve? Or was it because you were not aware that you need a dlc and it's ID to play a custom? If you've bought the Cherub dlc you don't have to change anything with the files - only converting them to mac if there's no mac version and adding it to the dlc. If it does not show up there might be another reason, for example duplicates or broken custom(s) - another possible reason: there was an update of RS and you've to re-apply the patch (and hopefully it works again) or we are doomed :).

Link to comment
Share on other sites

  • 0

Hi!

Sorry, I guess I was unclear. I got it working correctly after adding Cherub Rock to my library. That was the problem.

 

And apparently you're right, I just loaded a song without altering it at all and it worked fine. That's surprising to me since the official Rocksmith song file permissions are:

-rwxr-xr-x

And these custom songs are:

-rw-r--r--@

Oh well, I guess it's just reading the files into memory and doesn't need execute permissions. I wonder why the official ones are created with execute permissions?  ¯\_(ツ)_/¯

 

Thanks for the response.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy