Jump to content

  • 0

RSInjector Not Loading (Just Crashes)


sclaxplayer
 Share

Question

System: Mac OSX 10.11.6

 

Yesterday I was playing CDLC fine through the new version of RSInjector. Today I went to launch it again and it just crashes before anything even loads. I see all my failed launches in Mac's Console.

 

Here's a small snippet of the error message from Console:

Process:               Rocksmith2014 [32791]
Path:                  /Users/USER/Library/Application Support/Steam/*/Rocksmith2014.app/Contents/MacOS/Rocksmith2014
Identifier:            Rocksmith2014
Version:               1.0 (1)
Code Type:             X86 (Native)
Parent Process:        ??? [1]
Responsible:           Rocksmith2014 [32791]
User ID:               502

Date/Time:             2016-11-02 18:54:51.521 -0700
OS Version:            Mac OS X 10.11.6 (15G1108)
Report Version:        11
Anonymous UUID:        DEE35852-C391-C4D8-63CF-86971FF940F7


Time Awake Since Boot: 4200 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000037845fa6
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x37845fa6:
    MALLOC_SMALL           0000000003800000-0000000004800000 [ 16.0M] rw-/rwx SM=PRV  
--> 
    __TEXT                 000000008fe42000-000000008fe77000 [  212K] r-x/rwx SM=COW  /usr/lib/dyld

Application Specific Information:
/Users/USER/Library/Application Support/Steam/steamapps/common/Rocksmith2014/./Rocksmith2014.app/Contents/MacOS/Rocksmith2014

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   Ubisoft.Rocksmith2014         	0x0000c86e 0x1000 + 47214
1   dyld                          	0x8fe56190 ImageLoaderMachO::doInitialization(ImageLoader::LinkContext const&) + 64
2   dyld                          	0x8fe51e9e ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 296
3   dyld                          	0x8fe51d31 ImageLoader::processInitializers(ImageLoader::LinkContext const&, unsigned int, ImageLoader::InitializerTimingList&, ImageLoader::UninitedUpwards&) + 105
4   dyld                          	0x8fe51f91 ImageLoader::runInitializers(ImageLoader::LinkContext const&, ImageLoader::InitializerTimingList&) + 79
5   dyld                          	0x8fe43f7f dyld::initializeMainExecutable() + 218
6   dyld                          	0x8fe47c5b dyld::_main(macho_header const*, unsigned long, int, char const**, char const**, char const**, unsigned long*) + 3534
7   dyld                          	0x8fe43231 dyldbootstrap::start(macho_header const*, int, char const**, long, macho_header const*, unsigned long*) + 427
8   dyld                          	0x8fe43047 _dyld_start + 71

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0x00000001  ebx: 0x00000000  ecx: 0xbffffc24  edx: 0xbffffc2c
  edi: 0x0000c810  esi: 0xbffffc70  ebp: 0xbfffd7c8  esp: 0xbfffd76c
   ss: 0x00000023  efl: 0x00010246  eip: 0x0000c86e   cs: 0x0000001b
   ds: 0x00000023   es: 0x00000023   fs: 0x00000000   gs: 0x0000000f
  cr2: 0x37845fa6
  
Logical CPU:     2
Error Code:      0x00000004
Trap Number:     14

Here's what I have tried to do to remedy the situation:

1) Uninstall/Reinstall RSInjector

2) Uninstall/Reinstall Rocksmith through Steam

3) Tried running Rocksmith from the "Application Specific Information" stated above by opening terminal and running "/Users/USER/Library/Application Support/Steam/steamapps/common/Rocksmith2014/./Rocksmith2014.app/Contents/MacOS/Rocksmith2014" but I just got a Segmentation fault:11.

 

Has anyone experienced this issue before? I'm not sure how I can fix this.

Thanks for any help!

  • Like 2
Link to comment
Share on other sites

204 answers to this question

Recommended Posts

  • 0
  • Administrator

@@okewlie i've recompile the insert_dylib for older mac OS version that should work for 10.6 and after but i'm waiting on confirmation that it does work before having to update the whole package. @@Lovroman is working on a solution that would likely help you, if you can wait a bit (no idea how much time it will take but don't expect it tomorrow).

  • Like 2

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to comment
Share on other sites

  • 0

Ha ha!

 

The Lion is roaring! (Or is he sleeping tonight? ;) )

 

I've got it working on 10.7.5!  @@firekorn sent me a link to an "older" "insert_dylib" and I've re-set my permissions via Terminal, and it only bloody works! :D

 

Thank you so much, guys!  You're amazing!

Link to comment
Share on other sites

  • 0

i'm on 10.10.5 and it's not working

its write

 

 

/Volumes/Le\ Parrain/Downloads/MAC_Patch/RUN_PATCH_RS.command ; exit;
Mac-Pro-de-Michael:~ michaeltremblay$ /Volumes/Le\ Parrain/Downloads/MAC_Patch/RUN_PATCH_RS.command ; exit;
cp: directory /Users/michaeltremblay/Library/Application Support/Steam/steamapps/common/Rocksmith2014/Rocksmith2014.app/Contents/MacOS does not exist
/Users/michaeltremblay/Library/Application Support/Steam/steamapps/common/Rocksmith2014/Rocksmith2014.app/Contents/MacOS/Rocksmith2014: No such file or directory
logout

[Opération terminée]
 

  • Like 1
Link to comment
Share on other sites

  • 0

 

i'm on 10.10.5 and it's not working

its write

 

 

/Volumes/Le\ Parrain/Downloads/MAC_Patch/RUN_PATCH_RS.command ; exit;

Mac-Pro-de-Michael:~ michaeltremblay$ /Volumes/Le\ Parrain/Downloads/MAC_Patch/RUN_PATCH_RS.command ; exit;

cp: directory /Users/michaeltremblay/Library/Application Support/Steam/steamapps/common/Rocksmith2014/Rocksmith2014.app/Contents/MacOS does not exist

/Users/michaeltremblay/Library/Application Support/Steam/steamapps/common/Rocksmith2014/Rocksmith2014.app/Contents/MacOS/Rocksmith2014: No such file or directory

logout

 

[Opération terminée]

 

 

It looks like you have non standard folders/path.  You probably need to open RUN_PATCH_RS with TextEdit, and change the RS_PATH in there to match yours.

Link to comment
Share on other sites

  • 0
  • Administrator

@@wagonmike Where is located your Rocksmith folder? If it's not in /Users/michaeltremblay/Library/Application Support/Steam/steamapps/common/Rocksmith2014/ it won't work and as @@missis sumner said you'll need to change the path in the command file by using the TextEdit

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to comment
Share on other sites

  • 0

 

 

i'm on 10.10.5 and it's not working

its write

 

 

/Volumes/Le\ Parrain/Downloads/MAC_Patch/RUN_PATCH_RS.command ; exit;

Mac-Pro-de-Michael:~ michaeltremblay$ /Volumes/Le\ Parrain/Downloads/MAC_Patch/RUN_PATCH_RS.command ; exit;

cp: directory /Users/michaeltremblay/Library/Application Support/Steam/steamapps/common/Rocksmith2014/Rocksmith2014.app/Contents/MacOS does not exist

/Users/michaeltremblay/Library/Application Support/Steam/steamapps/common/Rocksmith2014/Rocksmith2014.app/Contents/MacOS/Rocksmith2014: No such file or directory

logout

 

[Opération terminée]

 

 

It looks like you have non standard folders/path.  You probably need to open RUN_PATCH_RS with TextEdit, and change the RS_PATH in there to match yours.

 

i have check the path yesterday.... i was pretty sure it's the same.... but ill check back tonight 

thank 

Link to comment
Share on other sites

  • 0

@@treyfoges3, what do you mean it won't give you access?

 

Are you getting a permission denied error?  If so, you need to change the permissions on all three files that are in the zip folder.

 

Right-click on each, and select "Get Info".  Then click the little lock icon on the bottom right corner and enter your Admin password.  Make sure all 3 users in the list under "Sharing & Permissions" have Read/Write privileges.

 

Also, just in case, make sure that Rocksmith isn't running while you're trying to apply the patch.

  • Like 1
Link to comment
Share on other sites

  • 0

Many thanks Firekorn/weepel.  Your (and your colleagues) efforts are much appreciated :-)

 

I'm on 10.12.1 btw

Fender Classic Player Baja Telecaster; Epiphone Nighthawk Custom; Westone Concord 1: Italia Mondial Classic;


Epiphone J Mascis Jazzmaster; Chapman ML2 Classic Gold-top


 

Link to comment
Share on other sites

  • 0

Anyone tried adding new songs after applying this patch?  I am able to run RS and can use songs I downloaded previously, but I downloaded a new song last night that doesn't appear in the game.  is anyone else having this issue?  

 

is there anything I can do?  would re-running the patch help?

 

Thanks so much for your help.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy