Jump to content

Rocksmith Custom Song Toolkit (toolkit) Q&A


fabianosan
 Share

Recommended Posts

  • Administrator

Ok back to that tone issue :

 

i load my saved package to update my work quickly :

http://i.imgur.com/IBl21K8.png

Everything seems good then i just click generate and i have this error :

http://i.imgur.com/IMFst4y.png

 

The tone definition is like that after the generation :

http://i.imgur.com/n9lfdjF.png

The 3 first name are those in the toolkit and the other are those i put into EOF because i don't always remember and don't want to type the whole tone name.

Either the name are changed all the way or not at all but right now i have to manually edit every single .xml before being able to generate anything if i don't put the same tone name between EOF and the toolkit which i never did before and worked great since that v2.6.1.0-fe59ccde beta version...

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to comment
Share on other sites

  • Developer

PM me link to your EOF project files along with the custom tones that you are using and I will take a look.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

@@firekorn load up your EoF project and have it re-save the XMLs, thats how I fixed it.  Maybe your problem is slightly different, just want to suggest a possible solution.

 

Also, when editing tones in the toolkit just remove all arrangements, do the edits then pull the arrangements back in.

 

I have this habit from before toolkit made new arrangement numbers, but it still seems to work.

Link to comment
Share on other sites

  • Administrator

Tried to generate the xml again. This time the xml aren't edited by the toolkit and i can generate fine IF i do nothing in the toolkit.

 

But if i delete and add back the vocals arrangement for exemple the xml are edited again which makes the generation fail and force me to resave the project in EOF to make it work.

 

The thing is that i never had this problem before and having to resave things back in EOF to avoid an xml modification that shouldn't occur in the first place seems weird to me.

 

Anyway i'm uploading all the files for @@cozy1 to test it out by himself.

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to comment
Share on other sites

  • Developer

@@firekorn et al
Most of the problems associate with tones occur with arrangements that use multiple tones.  The toolkit alerts you of this potential issue.  In the Add/Edit Arrangement form there is a checkbox "If checked, tone slots are disabled to prevent auto-tone failure".  Auto-tone actually refers to the presence of "multiple tones".  If the arrangement has multiple tones then this checkbox should/will be checked.

The toolkit does not have the ability to add (the image area in the red circle) multiple tone and time information.  This is done only by EOF.  The associated tone name is initialized by EOF.  When you ADD an arrangement the Tones automatically populate.  If you subsequently change the tone names using ADD Tones this will cause errors as shown in the above images.  If you EDIT the tones the toolkit will update the tone names accordingly.  Only use the Tones EDIT button ... now I sound like a broken record ;)

https://drive.google.com/file/d/0B4cUtRaobva6Wk1hVlhkR25Vb2s/view


Just released beta toolkit update that:

Improved RS1->RS2 CDLC conversions with actual tone mapping and improved conversion algos.
Revised showLight generator made compatible with RS1->RS2 conversions.
Added Showlights checkbox for on/off/debugging (if CDLC is causing in game hangs try unchecking this box and regenerate the CDLC without showlights).
Implement auto correction of RS1->RS2 Section Times that are bad (poorly placed Section Times cause in game hangs).  @@comp U2 converts properly now.
Revised Edit Tone form Load Tone to allow poorly formed Tone2014 files to be read (Load Package and Save Package work again).
Fixed bug in Edit Tone form Save Tone so that tone files can be properly named.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

  • Administrator

That behaviour wasn't existing before and that's what bothering me i never had any issue like that in earlier version (can't remember the exact reference about that sorry).

The thing is that in my case i don't touch the tone nor the actual arrangement with tones, i just added a vocal arrangement and had to resave the project in EOF to get it to work again which i find really odd to say the least.

 

I'm a broken record here too so don't worry :)

 

about that box, i've always disabled it as i understood that it would deactivate the tone change the way it is phrases, maybe i misunderstood this box function though and a ticking box isn't really an alert for me but that's just playing with word :p

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to comment
Share on other sites

  • Developer

@@firekorn Never uncheck the box and I am waiting for your project files.

 

EDIT: NVM think I got them.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

  • Developer

So for the communities benefit, @@firekorn and I have been PMing about his project issues.  Happily the project builds with the Toolkit and plays in game with no errors.  Here is my workflow which firekorn and I have agreed to share:

 

Project Summary
Artist: aaa (Edited these to protect real identity of project)
Song: bbb
Album: ccc

Arrangement Type Guitar (EOF XML):
PART REAL_BASS_22_RS2_unmod.xml (multi tone Disto, Acoustic) Lead selected by EOF
PART REAL_GUITAR_22_RS2_unmod.xml (multi tone Distortion, Acoustic) Lead selected by Toolkit
PART REAL_GUITAR_RS2_unmod.xml (multi tone Disto, Acoustic) Rhythm selected by Toolkit
Note: EOF does not always provide arrangement information so Toolkit assigns initial arrangement
Note: Arrangement Name (Lead or Rhythm) can be changed, using Arrangements Edit

Arrangement Type Bass (EOF XML):
PART REAL_BASS_RS2_unmod.xml (contains no EOF tone information so Toolkit defaults to single tone) Bass selected by EOF
CRITICAL Note: Must Add tone in Toolkit and then use Arrangements Edit, Tone Selector to assign correct bass tone

Custom Tones:
Bass.tone2014.xml (use for Bass tone parts)
ifOldrhythm.tone2014.xml (will be used for Disto and Distortion tone parts)
acousticIF.tone2014.xml (use for Acoustic tone parts)
Note: Disto and Distortion are assumed to use the same tone since only three custom
tones were provided for the four arrangements.
Note: Interchangeable use of Disto and Distortion could be a point of confusion (it was for me)

Initialize Project in Toolkit:
1. Open Toolkit
Select Creator menu tab
Select Arrangements, Add button
2. Add 4 original EOF project arrangement files *.xml (add Bass arrangement first)

CRITICAL NOTE: Add the Bass arrangement first in Toolkit because if it contains no tone information (like this project)
then Toolkit will assign Bass arrangement a Default tone. If bass is added after other arrangements Toolkit will
assign it an already used existing tone which then MUST be Edited later.
EOF Bass tuning does not import correctly into Toolkit because strings 4,5 are zeroed.
RS2014 expects full guitar tuning information for bass arrangements.
Toolkit Quick Fix: When tuning editor form pops up, click X (to close form).
In the Add Arrangement form, Select desired bass tuning from combobox (D-standard for this project).

3. Add 1 vocal *.xml file
4. Add 1 Album Artwork *.jpg
5. Add 1 Audio *.wem
NOTE: make sure *_preview.wem is in same project folder with main audio *.wem file

Assigning Custom Tones:
Note: Need to be careful because once a Tone is changed the Toolkit patches the XML file (always save a copy of original EOF XML files)
Toolkit establishes a link between tone names and tone IDs. Need to reload the original EOF XML files if you make a mistake in selecting custom tones.

6. Select Tones, Add button
Click "Load Tone"
Select "Bass.tone2014.xml" Click "OK"
Toolkit adds "bassstandard" custom tone to Tones list
Highlight (select) Bass in the Arrangements list
Select Arrangements, Edit button
In Tone Selector, Bass, select "bassstandard"
Click "OK"
Toolkit updates tone information
Highlight (select) "Default" in the Tones list and delete it

7. Select (highlight) tone "Disto"
Click "Edit", Click "Load Tone"
Select "ifOldrhythm.tone2014.xml" Click "OK"
Toolkit updates tone information

8. Select (highlight) tone "Distortion"
Click "Edit", Click "Load Tone"
Select "ifOldrhythm.tone2014.xml" Click "OK"
Toolkit updates tone information

9. Select (highlight) tone "Acoustic"
Click "Edit", Click "Load Tone"
Select "acousticIF.tone2014.xml" Click "OK"
Toolkit updates tone information
Highlight (select) the first "ifOldrhythm" in the Tones list and delete it

10. Final Steps
Enter Song Information, Version Number "1" if not already filled in
Click "Generate" and "Save"

Conlcusion
The project builds and plays in game (confirmed by testing xxxx_xxxx_xxx_p.psarc)
Just use/follow the above work flow to find joy.

EndNote: This project was initially hard to follow because it uses three custom tones for
four arrangements and one arrangement (bass) contains no EOF tone designation.
Further complicated by the use of Disto and Distortion in EOF to designate custom tones.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

I did find one bug in the Tone Editor which is unrelated to your original issue.  The Load Tone and Save Tone are not working as expected which has no effect on CDLC Generation.  I could not load tones from my archived tones2014.xml files and saved tones are not being named correctly for reuse.  I will fix this in a future release.

 

This must be the issue I'm having. I recently updated the toolkit and now whenever I load any of my old project files the tones are all gone, only one tone named Default in their place. This is a massive issue for me, so I may need to revert to an older release until this issue is fixed.

Link to comment
Share on other sites

  • Developer

@Aquilae  "Load Tone" and "Save Tone" issues are fixed in latest beta.

 

"I recently updated the toolkit and now whenever I load any of my old project files the tones are all gone"

 

If you are trying to use "Load Package" and your system/project folder structure has changed then the package may not load correctly.  Just use "Import Package" to load the *.psarc file and all should be good.

 

EDIT:  I will take a look at the code to see if it is possible to get older save packages to load properly.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

  • Developer

@@firekorn, @Aquila, et.al.  Found a compatibility issues that was causing old Save Package (Templates) to not load fully and implemented fix to auto correct and load them.  This was similar to the problem with "Load Tone".

 

For the fix to work ... all of your project files must be in the same folder or in subfolders below the template file *.dlc.xml

 

The latest beta rev change log:

 

Fixed "Load Package" compatibility issue.
Added "Quick Add" button to Creator GUI to allow multiple arrangements to be selected quickly.
Added new tooltips and popups to make the CDLC creation process more user friendly.
Changed bass tuning behavior popup to be more user friendly.

  • Like 1

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

Great work guys as always! I'm just wondering when the Latest release build - 2.6.0.0 (rev 4174fc7b) finally change to the current test build as "Latest release build"?

 

I bet a lot of newer people are still using 2.6.0.0 that was put out way back on Apr 19, 2014. A lot has changed since then.

  • Like 1

Always check and use -> The latest Toolkit builds

 

To disable dynamic difficulty and not get the 100% accuracy bug don't use the override to max option, but instead disable DD and set sight reading level to Max. With this configuration the 100% bug does not surface.

Link to comment
Share on other sites

  • Developer

@TimeIsFading 

 

I think the answer to you question is that Latest Release Build - 2.6.0.0 (rev 4174fc7b) is the current official stable release.  The current Beta Build 84f9df1c0b could still have bugs which are unacceptable to some users.  Once the current beta is determined by testing and use to be stable it may become the "Latest Release Build".  I think a new official "Latest Release Build" could happen soon. 

 

I'm sure @@Alex360 and @@fabianosan can add more to this.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

More tone issues! Yay!

 

I've used the workflow that has been prescribed (Tone changes in EoF, load in toolkit, edit the tones and load the tones I want). Now, when I change something in EoF and re-save, I get the following error upon re-generating:

 

http://puu.sh/iYS9k/5165ec8d65.png

 

And I'm getting sick of it. The only way to fix it is to re-add the arrangement and then go to edit tone -> load the tone again. Re-saving the file in EoF does NOT work. And with the tone window taking forever to show up, it's really annoying. 

 

Now, if you'd just implement the fix I've set out before, I bet my ass that it will solve EVERY tone change issue that might crop up. 

 

I'm talking about this fix in http://customsforge.com/topic/989-custom-song-toolkit-v2600-was-released/page-20?do=findComment&comment=154110 :

 

 

 

The fix would probably be to change the name of "clean" and "distortion" in <tone time...> to reflect the names as defined in tonebase/tonea/toneb etc. After I did that manually, the package generated without errors.

 

Guess what I did. I manually changed the XML file from 

 

http://puu.sh/iYSrn/f7619b0c53.png

 

to

 

http://puu.sh/iYSt1/9b4971feb9.png

 

And it worked.

This is the EoF tone list:  http://puu.sh/iYSvi/5994fa5f80.png

 

And here's the arrangement window:

 

http://puu.sh/iYSxH/163b780a89.png

Link to comment
Share on other sites

  • Developer

@SmellyOrc  Sorry to hear you are still having tone issues.   "The fix would probably be to change the name of "clean" and "distortion" in to reflect the names as defined in tonebase/tonea/toneb etc."

When toolkit Creator GUI, Tones "Edit" button is pressed the "Edit Tone" form pops up.  Change Tone Information (top left) from "Acoustic" to "Clean_Reverb" and press "OK".  The toolkit does above fix.  I just tested latest beta 15e1a63 and toolkit produces expected results.

 

@@raynebc Is above screenshot of EOF "Rocksmith tone changes(2)" consistent with the screenshot of EOF XML output, i.e. should EOF XML output also have "Distortion" tone at 17.6 seconds?

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

That looks normal. Whichever tone is marked as the default is in effect automatically when the chart begins, and EOF will skip writing a tone change that tries to change to a tone already in use, so you wouldn't see a tone change at 17.6s in the XML.

Link to comment
Share on other sites

@SmellyOrc  Sorry to hear you are still having tone issues.   "The fix would probably be to change the name of "clean" and "distortion" in <tone time...> to reflect the names as defined in tonebase/tonea/toneb etc."

 

When toolkit Creator GUI, Tones "Edit" button is pressed the "Edit Tone" form pops up.  Change Tone Information (top left) from "Acoustic" to "Clean_Reverb" and press "OK".  The toolkit does above fix.  I just tested latest beta 15e1a63 and toolkit produces expected results.

 

That's what I did. THEN I changed something in the arrangement, saved it again in EoF, and THEN when I generate a package, I get that error. 

THEN when I change the XML as described in my previous post, it works just fine. 

 

And to add to raynebc's answer, yes it's normal, and it's only there in order to get a song working with only one actual tone change. EoF needs two tone changes in order to export them correctly (afaik), so I set tone change at the start of the song which "changes" to the tone already set. It's aaaaaallll good. 

Link to comment
Share on other sites

  • Developer

@@raynebc

I seem to recall that EOF does not insert tone id elements into the XML.  Is that correct?  If so then this XML has already been edited with the toolkit. 

 

@SmellyOrc  This is an important point because once you edit the tone with the toolkit it inserts the XML tone id elements.  If you make a mistake in tone naming then you must start over with the original EOF XML that has no tone id elements.  If you don't use an original EOF XML there are likely to be all kinds of issues because the toolkit has no way of fixing the early error in tone naming.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

 I changed something in the arrangement, saved it again in EoF, and THEN when I generate a package, I get that error. 

 

With the current behaviour of the toolkit overwriting tone info in the XMLs this is what I would expect to happen, if you just loaded up the saved toolkit and hit "generate" (because the tone info in the XML now does not match what the toolkit thinks it is building).

 

You would really need to pull the altered arrangement XML back into the toolkit (remove then re-add) and re-assign your tone to it.

 

I am slowly getting used to how this new tone assignment works (I don't do nearly as many customs now), or moreover allowing for the fact that as soon as you alter tones in any arrangement while in the toolkit, it overwrites the arrangement XML IMMEDIATELY.  I suppose this is what cozy1 calls "inserting tone id elements"?

 

 

 

It's complicated I know, but no-one said progress was easy :)

Link to comment
Share on other sites

@SmellyOrc  This is an important point because once you edit the tone with the toolkit it inserts the XML tone id elements.  If you make a mistake in tone naming then you must start over with the original EOF XML that has no tone id elements.  If you don't use an original EOF XML there are likely to be all kinds of issues because the toolkit has no way of fixing the early error in tone naming.

 

I'm not changing any tone changes or names in EoF, but simply editing the arrangement. Then the ORIGINAL Eof XML is used by the toolkit (of course, because they have the same name as the altered one afaik), and this generates an error. 

 

 

 

You would really need to pull the altered arrangement XML back into the toolkit (remove then re-add) and re-assign your tone to it.

 

Except that if you have a ton of tone changes in your arrangement, it'll add those generic names that I use in EoF to the tone list, and after re-assigning the tone, I'll end up with multiple tones with the same name.

Also, removing and re-adding an arrangement because I changed a note from non-mute to palm muted (for example) seems a bit over-the-top, does it not? 

 

 

 

It's complicated I know, but no-one said progress was easy  :)

 

It's not complicated, the fix is easy. But somehow, they're not seeing it.

Link to comment
Share on other sites

  • Developer

I'm not changing any tone changes or names in EoF, but simply editing the arrangement. Then the ORIGINAL Eof XML is used by the toolkit (of course, because they have the same name as the altered one afaik), and this generates an error. 

 

It's not complicated, the fix is easy. But somehow, they're not seeing it.

 

 

It has been confirmed that the XML that you posted is not EOF original ... so there is high probability the toolkit output is not going to be valid.  Maybe it is time for you to take up C# coding and make a contribution to the toolkit if you think it is not complicated.   Then maybe you will see it.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

I noticed in github that a commit as been done about quarter

 

Merge pull request #232 from Dreddfoxx/master

quarter step bends.
 
Does this means all custom before this commit doesn't hndle quarter bend ? Do i have to repack all songs with this new build or is it ok ?

Take a look at my Workshop. You'll find which song I plan to create someday.

 

Please leave constructive feedback, it helps me creating better customs !

Please don't thanks with comment but with the button !

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy