Jump to content

Index was out of range. Must be a non-negative and less than the size of the collection ERROR.


Go to solution Solved by Alex360,

Recommended Posts

  Tried every tutorial on the web and here. No matter what I do I simply cannot write the file. Searched all over here and could not find this error mentioned anywhere. Im sure Im missing something completely stupid but I don't see why every tutorial gives me the same error. This last build was just the bass, no vocal or lead. Any help would be swell, TIA.

 

 

 

 

http://i1377.photobucket.com/albums/ah49/Cataclysmmm/rocksmitheditor%20error_zpsshozacly.png

Link to post
Share on other sites

Ok I'll try to be as detailed as I can. I am using the rstoolkit-2.8.3.1-9605d7f3-win download with the hotfix applied. Audacity 2.3.1, Go Playalong 3.42, Guitar Pro 6 with a gp3 tab, (seems accurate enough without playing it.) paint.net for the cover-art @512x512 rez dds. I I tried the latest and reverted to the Wwise_v2015.1.9 5624 desperate for a fix, no change of course. Starting out I ran Audacity and the tab, added silence to beginning, cleaned the ending up and exported as WAV (Microsoft 16 mit PCM) I also exported it as guitar.ogg for eof. I clipped a nice 30 second clip for the preview and exported that accordingly, same name, _preview appended. Playalong was brought up next and the tab properly synced.  This time I skipped the lyrics, it made no difference to the error and I can't sing anyways so onward I went.
Ran EOF,  The initial config below.http://i1377.photobucket.com/albums/ah49/Cataclysmmm/Screenshot_1_zpsefnwcxtr.png

 

loaded the guitar.ogg to a new file. Song/Part Real Bass...and imported the gp3. set the intro, chorus and clicked the also add as RS Phase. (unchecking this did not end errors.)  The album art and preview ogg was added, (ogg or wav no difference) here's a pic of the data all ready to build

:http://i1377.photobucket.com/albums/ah49/Cataclysmmm/Screenshot_2_zpsjjqupij6.png
So it runs the wise and no errors till after I set the filename at the end, then the instant crash as soon as it attempts to write the file. With the MAC and others checked it builds them then crashes on the PC part.  Any help would be amazing. TIA..
OH, here's a rar with the files, maybe something is making empty file or something, I have no clue.

Link to post
Share on other sites

"reverted to the Wwise_v2015.1.9 5624 desperate for a fix, no change of course"
It's showlights issue, go unpack any odlc and grab showlights from there, than use it in the toolkit for your cdlc it should work now
or just hit that default showlights, oh, that's only works in debug version.

I guess @@raynebc was right about bass only arrangements so @@cozy1 missed a thing maybe, I haven't looked that precisely on showlights system so using your files we'll fix this.

 

Reproduced this already. thanks!

also Charting part wasn't the case this time, but you're missing eof file so i did manually gpa import part, here's bass only version:
https://drive.google.com/open?id=0B6zOE-7JCxwjYnAwb0FaRk1BbFk

One thing is you've got preview for a audio file as main file! Use guitar.ogg next time.. (I've done it correctly for you..)

Can put all the arrangements, but I think you'll figure out next steps? :D

  • Like 1
Link to post
Share on other sites

  • Developer

@@Alex360 you are telepathic magician.  So the bass arrangement xml was missing from @Cataclysmm EOF project files (go figure ... only the most critical file, right?) so you decided to reproduce it from the gp3 file.  Briliant!  I see you also fixed the issue with the missing/bad tone.

 

Now to showlights issue.  What is with these bass only arrangements?  Thought I had that SOB bug whipped.  Looks like it whipped me.  Will fix in next beta now that I have bass arrangement xml from your psarc.

  • Like 2

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to post
Share on other sites

Thank you for the help Alex360 and cozy1..I have no idea what the showlights bit is but you mentioned I can snag it from an odlc, I'm assuming you mean an original like the cherubrock or another I've purchased. I guess I have to figure out what you mean by the end of file file being missing..I'm a complete beginner in this CDLC stuff.  I'll search the forums and see what I can see about the showlights and the rest.

Link to post
Share on other sites

"reverted to the Wwise_v2015.1.9 5624 desperate for a fix, no change of course"

It's showlights issue, go unpack any odlc and grab showlights from there, than use it in the toolkit for your cdlc it should work now

or just hit that default showlights, oh, that's only works in debug version.

 

This showlights thing was a mess. Until I downloaded the source, built it and copied the files over was I able to use a copied showlights file. No idea why this was so. Once the showlights was added it compiled everything perfectly..It's gotta be something Ive messed up. Gonna revert to the original toolkit version and see if Im able to do it in that.

 

Link to post
Share on other sites

  • Solution

@@Cataclysmm, usually you just need to add all arrangements and build your cdlc
well, I think we should just fix it so no additional steps required.

as for now you can import my package in toolkit and add arrangements you need It will work just fine

Link to post
Share on other sites

Thanks again, I never saw that add showlights in that section in any tutorial. Once a file was set to this I have been able to build it with all the parts, minus vocals, (whoever wrote that UltraStar, your on my list pal.)  wink wink. I'm only teasing, that is a huge challenge to get those lyrics synced right. Getting the tones closer and figuring out what songs she uses a Colorsound pedal for it's effect,(from an interview comment she made) how that will be achieved in RS, I have no clue. Any idea what's close to a Boss NS-2 pedal?

Link to post
Share on other sites

  • Administrator

@@Cataclysmm Nobody talks about showlights in any tutorial because they are automatically created and managed by the toolkit entirely. Thing is the last few revision of the toolkit have been wonky when it comes to showlights creation...

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to post
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy