Jump to content

  • 0

Freshly made DLC is crashing. HELP!


VermillionRED
 Share

Question

So after finally getting tones made for my chart, I'm ready to test the guitar parts in game and see if it works....except that it doesn't.  The song I'm making is "311 - Creatures (For a While)"  It crashes right after I pass the tune check.  So I repackaged it.  Still crashes.  I decided to rebuild the .psarc file, thinking that I might have screwed something up along the way.  Crashes.  I've even tried repackaging it and getting rid of the "()" in the song title to see if it might be a naming issue. Hell, I've even repacked my repackages. Still crashes.  I've even tried packaging it with and without the bass chart.  I've even tried changing the DLC ID to a different DLC I own.

 

Editor on Fire reports no errors when I save everything and the same thing goes for Wwise.  Other custom DLC I have works just fine.  All three parts are charted, however I don't have the bass chart ready because I have yet to make a tone for it.  I simply wanted to test the guitar parts and their tones before moving on.  

 

I'm at my wits end and I've tried everything I can think of.  I'll happily provide the source files upon request so that I can get this fixed and ready to release.

Link to comment
Share on other sites

Recommended Posts

  • 0

I had similar problems with a few songs when converting the audio files directly using Wwise. Try converting the audio with the toolkit instead (just select the guitar.ogg or the .wav file instead of the .wem file) and it should handle everything necessary from there (and I find this process much easier than using Wwise). I hope this works!

My CDLC releases and my workshop 
My CDLC previews (Lots of bass only stuff)
Join us at the Rocksmith Championship!

Link to comment
Share on other sites

  • 0

So first I get this lovely error from the toolkit

Wwise audio file conversion failed: You have an incompatible version of Audiokinect Wwise installed.
Install Wwise v2013.2.x or v2014.1.x series if you would like to use the toolkit OGG/WAV audio to Wwise WEM audio auto convert features.

So I grab v2013.2.7, install that after uninstalling the latest build of Wwise and then I get this other lovely error.

Exception Wwise audio file conversion failed: Could not find file 'C:\Users\Matt\Downloads\RockSmith Customs\Installers\RocksmithCustomSongToolkit-v2.6.0.0-4174fc7b3141_PC\Wwise2013.tar.bz2'

I then say well fuck where the hell am I gonna get those files.  I reconvert the wwemfiles in the 2015 build of Wwise and it still doesn't work.  This is getting on my nerves.

Link to comment
Share on other sites

  • 0
This is getting on my nerves.

Welcome to the world of custom making :D

 

 

I'll suggest something, you might think I'm mad but I tell you its worked for me a couple of times...

 

 

Start a blank toolkit and type everything in again, do not use a template save.

 

 

 

Also, what's the current state of your game - is it playing other CDLC just now or do they crash too?

 

 

Also, are you sure you converted the audio properly, did you use Seek Table Granularity of 16438?

Link to comment
Share on other sites

  • 0

@@VermillionRED - Not sure about the toolkit errors as I've never had them. @@Alex360 or @@cozy1 might know better.

 

Another thing that can cause issues is if the DLC Name is too similar too another custom in your folder, so if it's not already it might pay off to try to make it more unique. If you have multiple versions of the song in your folder all with the same DLC name that can also cause problems.

My CDLC releases and my workshop 
My CDLC previews (Lots of bass only stuff)
Join us at the Rocksmith Championship!

Link to comment
Share on other sites

  • 0

 

This is getting on my nerves.

Welcome to the world of custom making :D

 

 

I'll suggest something, you might think I'm mad but I tell you its worked for me a couple of times...

 

 

Start a blank toolkit and type everything in again, do not use a template save.

 

 

 

Also, what's the current state of your game - is it playing other CDLC just now or do they crash too?

 

 

Also, are you sure you converted the audio properly, did you use Seek Table Granularity of 16438?

 

 

I did check the project in wwise and they are set correctly.  In my OP, I did state that I tried making a fresh project in the Toolkit.  Could making a fresh project in wwise make a difference?  Also other CDLC works fine.  I suppose worth noting is the source of the song file itself.  Its a FLAC file converted to an MP3 using LAME from inside of Foobar2000

@@VermillionRED - Not sure about the toolkit errors as I've never had them. @@Alex360 or @@cozy1 might know better.

 

Another thing that can cause issues is if the DLC Name is too similar too another custom in your folder, so if it's not already it might pay off to try to make it more unique. If you have multiple versions of the song in your folder all with the same DLC name that can also cause problems.

What if it is too similar to actual DLC? It is a 311 song and they did get a official DLC pack.  Should I try to contact those two you mentioned?

 

Again, if I need to, I will upload the source files for someone to take a look at.  I'm at a complete loss at this point.

Link to comment
Share on other sites

  • 0
  • Administrator

About DLC name, add a random number or your nickname at the end will assure you that it's not conflicting with any other CDLC or DLC or you are really unlucky...

 

You could always try to make a fresh project in Wwise just to make sure. For the toolkit auto convertion to wem, if you're missing a file you might wanna try to update it again or redownloading the toolkit completely cause it seems a bit weird that are missing a file (that i have in my folder).

 

You know you can also use a more recent version of wwise with the toolkit (@cozy01 might be more able to tell exactly which version will work).

  • Like 1

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to comment
Share on other sites

  • 0

So I grabbed the latest beta of the Toolkit and made a fresh package.  The conversion worked, yay!  It still crashes, even after repackaging it.......FUCK!  The only thing I can think of at this point is that something in EoF is causing this mess.  I'm gonna redo everything but the fret charting and see if that helps.

Link to comment
Share on other sites

  • 0

So I grabbed the latest beta of the Toolkit and made a fresh package.  The conversion worked, yay!  It still crashes, even after repackaging it.......FUCK!  The only thing I can think of at this point is that something in EoF is causing this mess.  I'm gonna redo everything but the fret charting and see if that helps.

 

Just for fun see if it works in score attack mode (not learn a song).

  • Like 1
Link to comment
Share on other sites

  • 0

I'm kind of confused now. @@Rockfirstlast, do you have a fix given that it works in score attack?

 

Anyway, @@VermillionRED, when you say it crashes after the tuning check, do you mean the kind of crash where the amps show and you can play things but the noteway doesn't show up and the song doesn't start playing? If so, how long did you wait? Sometimes I've had long waits (maybe 15 seconds, maybe a bit longer) for DLC that I know function (i.e. I've played the same version previously), including even some official songs on occasion. So if you only waited a few seconds it's possible that you didn't wait long enough for whatever the computer's doing behind the scenes to happen.

 

Now that we know it works in Score Attack, I'm intrigued by what the problem is or solution will be.

My CDLC releases and my workshop 
My CDLC previews (Lots of bass only stuff)
Join us at the Rocksmith Championship!

Link to comment
Share on other sites

  • 0

Umm, instead of trying to describe the symptoms, how about I just show you instead :D.  

 

https://www.youtube.com/watch?v=Q8UkCpVpDlQ

 

It happens on both Rhythm and Lead.

 

One thing I did notice while researching the issue was this issue report on Github: https://github.com/rscustom/rocksmith-custom-song-toolkit/issues/112

Link to comment
Share on other sites

  • 0

That thread mentions @@Rockfirstlast and a similar issue, but is almost two years old, so I would have thought that issue would be fixed by now.

 

It might also have something to do with the Showlights, simply because that's one of the things that's in "Learn a Song" but not "Score Attack" and has been known to cause problems. Don't really know how to fix that, though.

My CDLC releases and my workshop 
My CDLC previews (Lots of bass only stuff)
Join us at the Rocksmith Championship!

Link to comment
Share on other sites

  • 0

I know that the toolkit automatically generates showlights.  Here is the output I get from importing the package itself.  Maybe there is something wrong with it?

<?xml version="1.0" encoding="utf-8"?>
<showlights count="14">
  <showlight time="10" note="33" />
  <showlight time="127.517" note="45" />
  <showlight time="215.639" note="44" />
  <showlight time="218.162" note="45" />
  <showlight time="220.684" note="44" />
  <showlight time="223.205" note="45" />
  <showlight time="225.728" note="44" />
  <showlight time="228.25" note="45" />
  <showlight time="232.978" note="46" />
  <showlight time="238.023" note="46" />
  <showlight time="243.067" note="46" />
  <showlight time="248.11" note="46" />
  <showlight time="253.155" note="47" />
  <showlight time="256.676" note="66" />
</showlights>
Link to comment
Share on other sites

  • 0

I think GTLO had a similar issue with his All Along The Watchtower custom, he couldn't get it working.

 

It did turn out to be a showlights issue, and I could fix it because I use an old toolkit with the stable version of showlights.

 

Basically, @@Alex360 tried to make the showlights far more interesting and I think a bug or two must remain.

 

 

I would try to build your custom with an old toolkit.  I don't know the specific version I use, and I don't know how "available" old versions are.  If you can't get an old toolkit post up the latest build and I will try to rebuild it using my toolkit.

 

I'd be looking for a toolkit before they had the "Include Showlights" tick box in the Arrangements pane.

  • Like 3
Link to comment
Share on other sites

  • 0

Thanks for the kind words LaceyB.  Chances are high that I'm likely gonna mark this in the purgatory folder.  Its such a shame really.  The tab I got off of Songster was practically perfect and required hardly any editing on my part, aside from 1 or 2 timing issues.  Anyways,  If anyone wants to take a stab at somehow making this work, here are all the project files.

 

https://drive.google.com/file/d/0B_1qqBojoolaY0dkY3ZBaDZib1k/view?usp=sharing

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy