Jump to content

Toolkit is Breaking Notes


EeveeonE
 Share

Recommended Posts

It's as the title says. Now I can't remember what version of the Toolkit I had, because when I tried to update it to fix the issue, it deleted itself because I had Rocksmith running. I wish I was joking, but it literally did. And I'm calling it a night before I bother to do anything with it (Update or use an older version). Because there's a bigger problem. 

 

To sum up what I mean by breaking notes, it's when notes are invisible, or are cutting off, or just not showing at all. (There's also a slide bug where I have a strangely shaped chord not sliding to the next note). The invisible notes, they are a really annoying bug because this CDLC I am currently working on, that isn't gonna see a release until this is fixed, is reliant on multiple slides. The slides have max, 3 notes to slide to, and they cut off.

But that is hardly the worst thing. Even those where it slides to one note, if the same note is played after that, it is randomly invisible but the sustain is there. The note is gone.

 

There's some really bizarre bugs, I'll post some screenshots later. It's been happening to a lot of my CDLC, but not as bad as I've seen it with this WIP one. And I don't think it's EOF, The reason I don't think it's EOF is because all the notes appear there. The notes are fine, they have sustains, they are all there. Showing as I wrote it in the tab. 

 

In case it's important, I am using Guitar Pro 7 to add finishing touches to my tabs. 

 

Thanks in advance.

Link to comment
Share on other sites

  • Developer

Once you are sure you have the latest versions of all the tools, plz come back for more abuse.  ;)

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

@SuperSonic
 

Hmm, I'm curious... It sounds like a DD problem.

Are your sections/phrases on beat 1 of a measure (white beat bars) in eof? 
If not, try putting them only on beat 1 and nowhere else.
That might fix it.

Um, also try generating it without DD.

Check out the Triumph Discography

and my Workshop for my upcoming CDLCs.

Link to comment
Share on other sites

Once you are sure you have the latest versions of all the tools, plz come back for more abuse.  ;)

Got the latest versions. Same issue. 

https://imgur.com/a/ZcNDcgJ

 

Top image, sustains have disappeared

Bottom, a note is to be played is not there. There's no ghost notes there in the tab.

 

My last resort is going to be removing ghost notes. Which sucks because now you can't tell what notes are to be played and sustained or not. 

 

Edit: Crap. Spoiled the song. Oh well. I'm updating Scar Tissue. The old version on the database was abandoned

 

Edit 2: I guess another question I could ask is, since Ghost Notes are one of the things breaking it. Is there a way to make a smooth slide?  Like Official DLC quality where the slide isn't broken by another note and it is simply sustained? 

Link to comment
Share on other sites

  • Developer

Peeking into your CDLC lead arrangement xml, we see:

<?xml version="1.0" encoding="utf-8"?>
<song version="7">
  <!-- CST v2.9.2.1-37451264 -->
  <!-- DDC by CDLC author -->
  <!-- EOF v1.8RC12 (2-20-2019) -->
  <title />
  <arrangement>PART REAL_GUITAR</arrangement>
  <part>1</part>
  <offset>0</offset>
  <centOffset>0</centOffset>
  <songLength>221.522</songLength>
  <startBeat>0</startBeat>
  <averageTempo>89.117</averageTempo>
  <tuning string0="0" string1="0" string2="0" string3="0" string4="0" string5="0" />
  <capo>0</capo>
  <artistName />
  <artistNameSort />
  <albumName />
  <albumYear />
  <crowdSpeed>1</crowdSpeed>

The EOF version you are using () is outdated.  Should be 10-30-2019 or later.  Regenerate your EOF project files with the latest version.

Looks like SlickWilly could be onto something ().  Try using the toolkit to create DDC.  If the problem you are seeing goes away with the toolkit generated DDC then you know that it is an issue with your custom DDC. 

Use the toolkit CDLC Creator to Generate the CDLC, and allow the toolkit to update the Arrangement ID when asked to fully populate these elements:





Looks like you changed the toolkit default song and tone volumes.  This could effect the tone issue you are having.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

Peeking into your CDLC lead arrangement xml, we see:

<?xml version="1.0" encoding="utf-8"?>
<song version="7">
  <!-- CST v2.9.2.1-37451264 -->
  <!-- DDC by CDLC author -->
  <!-- EOF v1.8RC12 (2-20-2019) -->
  <title />
  <arrangement>PART REAL_GUITAR</arrangement>
  <part>1</part>
  <offset>0</offset>
  <centOffset>0</centOffset>
  <songLength>221.522</songLength>
  <startBeat>0</startBeat>
  <averageTempo>89.117</averageTempo>
  <tuning string0="0" string1="0" string2="0" string3="0" string4="0" string5="0" />
  <capo>0</capo>
  <artistName />
  <artistNameSort />
  <albumName />
  <albumYear />
  <crowdSpeed>1</crowdSpeed>

The EOF version you are using (<!-- EOF v1.8RC12 (2-20-2019) -->) is outdated.  Should be 10-30-2019 or later.  Regenerate your EOF project files with the latest version.

 

Looks like SlickWilly could be onto something (<!-- DDC by CDLC author -->).  Try using the toolkit to create DDC.  If the problem you are seeing goes away with the toolkit generated DDC then you know that it is an issue with your custom DDC. 

 

Use the toolkit CDLC Creator to Generate the CDLC, and allow the toolkit to update the Arrangement ID when asked to fully populate these elements:

<artistName />

<artistNameSort />

<albumName />

<albumYear />

 

Looks like you changed the toolkit default song and tone volumes.  This could effect the tone issue you are having.

It is up to date? I installed the latest hot fix just now. But the only version of EOF available is 1.8 RC12. 

Anyway, I did that, and used the track with the ghost notes. Same problem. Invisible notes, missing notes. 

 

What I Tried:

- Updated EOF with the latest hotfix

- Updated Toolkit (Again because there was another update)

- Generating it without DDC (But it always does for some reason, despite it not being marked in configuration. I haven't made seperate tracks in EOF for it)

 

 

I tried moving the notes a tiny bit (To fix some sync issues that were there anyway) then generating the file with this new XML. Same bug strangely? So it really could be anything at this point. 

 

 

I dunno. Maybe I'm missing something? Here's the EOF files (And GHOST NOTE version of the tab) if you don't mind taking a look thanks. 

https://www.dropbox.com/s/7aew7bq6mbrlvhn/GHOSTS%21.7z?dl=0

Link to comment
Share on other sites

@SuperSonic
 

Removing ghost notes fixed the issues, but it isn't up to the quality of an ODLC.

Hmm, I actually don't think ghost notes are used on slides in odlc.  It's likely the tab author was trying to mimic a delay effect by using them.
From my understanding slide guitars use delay a lot to help with sustains.
(which might help with one of your tones since there is a very, very slight delay in that part of the song.)
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Um, you could change the ghost notes to normal notes and mark it with the crazy status:
VWqCtJR.png
(crazy status shouldn't do anything more in this case (I think :unsure: ), but it'll help you differentiate between what's played and not when viewing in eof.)
(btw, some of your slide notes weren't properly marked as 'linknext' (ex. 13 note in pic above) which also might be causing the issue too.)

Sometimes, slides without ghost notes are marked as ignore which might help too.

Check out the Triumph Discography

and my Workshop for my upcoming CDLCs.

Link to comment
Share on other sites

  • Developer

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

@SuperSonic

 

Removing ghost notes fixed the issues, but it isn't up to the quality of an ODLC.

Hmm, I actually don't think ghost notes are used on slides in odlc.  It's likely the tab author was trying to mimic a delay effect by using them.

From my understanding slide guitars use delay a lot to help with sustains.

(which might help with one of your tones since there is a very, very slight delay in that part of the song.)

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

Um, you could change the ghost notes to normal notes and mark it with the crazy status:

VWqCtJR.png

(crazy status shouldn't do anything more in this case (I think :unsure: ), but it'll help you differentiate between what's played and not when viewing in eof.)

(btw, some of your slide notes weren't properly marked as 'linknext' (ex. 13 note in pic above) which also might be causing the issue too.)

 

Sometimes, slides without ghost notes are marked as ignore which might help too.

I did a dumb dumb. I didn't realize there were other versions of the tab and I heavily edited an old version. 

 

So, I'm trying the removing ghost notes and adding linktext. I don't know how to use crazy status? It feels like I'm learning another language. 

 

OH MY DOG, you are a legend. Thank you. Linktext was the exact thing I was looking for to get those sustained slides. It also fixed some of the bugs, though not all of them it appears. The thing I don't understand about the link text is, does it connect the previous note or the note after? Say those chords at the beginning of the song. If I link text it on the 8--9 chord, would that make the slide, or does it have to be the chord at the end of the slide? I am still sorta confused about that. 

 

 

Edit: I figured it out. It's the note before. WORKED PERFECTLY. The song is actually playable, and the solo is perfect. Thanks. Although I'm left wondering something. How do I add "Linktext" in a tab? I don't really want to be editing every individual note for a tab, each time I import it. Is there an easier way?

 

Also, there is another bug that I had with earlier CDLCs as well as this one. Bends were not keeping their state. A full step bend that is sustained and doesn't move (As it is in the tab) for some reason would cut off in the next measure. It's a weird bug. Sometimes a chord with bends would disappear completely. 

Link to comment
Share on other sites

  • Developer

Good to hear you are getting better results.

Those EOF project files that you posted above still have some conflicting song information elements.  To be sure that the toolkit does not have some kind of underlying bug, could you please post a screenshots of your:

1) toolkit>General Config settings
2) toolkit>CDLC Creator (as it looked before you pressed Generate to create the CDLC)

Thanks

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

Good to hear you are getting better results.

 

Those EOF project files that you posted above still have some conflicting song information elements.  To be sure that the toolkit does not have some kind of underlying bug, could you please post a screenshots of your:

 

1) toolkit>General Config settings

2) toolkit>CDLC Creator (as it looked before you pressed Generate to create the CDLC)

 

Thanks

 

Put both together, not sure if you wanted the template or not for CDLC Creator:

https://imgur.com/a/8sBZUEv

 

The red bits are just anonymity. For some reason my file explorer displays my full name. 

 

The tones aren't an issue now for some reason? I reckon I used the wrong settings for the tones before. It's fine now. 

Link to comment
Share on other sites

  • Developer

This may have nothing to do with the ghost note and tone issues your experienced, but the template *.dlc.xml file that you included in the above Ghost! zip is corrupt.  Delete it. Do not use it to load the artifacts into the toolkit.  Start fresh by loading the EOF project files into the toolkit per these instructions and save a new template.

 

 Also do not use the exclamation mark (!) in a folder name as it causes errors when loading templates.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

  • Moderator

@@SuperSonic "How do I add "Linktext" in a tab?"

 

I use the "legato slide" option, not sure where it is in guitar pro 7 tho since I use 5. Ignore the 0 in the eof I forgot to re import it lol

EMc6Ja6.png

in game, with no fiddling around in eof

iU4nOSu.png

  • Like 1

Ea3cCUQ.png                                               "Be excellent to each others"-Kurokotei / 黒皇帝                                                Gh59blB.png

My todo list (majorly outdated)                                           Modding thread (dead)                                        500 songs hype

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy