Jump to content

First tone change persisitently late on selecting song, fine on restarting from in-song menu


Karmeleaux
 Share

Recommended Posts

There's a good chance this isn't a Toolkit issue, but I was told to post near this area because this is where all the peeps who know the guts of Rocksmith hang.

 

Short version:

Got a custom right now where if I select it under Learn a Song, the first tone change starts late. If I choose to restart it from the pause menu, it changes at the correct time. But if I back out and select it again, it starts late again. Choosing restart from the in-song menu has it start at the correct place again. And so forth.

 

The EoF and XML have the correct start time:

 

http://www.cdlc.wit-n-wiz.com/AirbrushedAlpha/EoF-XML.jpg

 

But the first time it starts about here:

http://www.cdlc.wit-n-wiz.com/AirbrushedAlpha/20181010193033_1.jpg

And on in-song restarts it correctly starts around here:

http://www.cdlc.wit-n-wiz.com/AirbrushedAlpha/20181010193046_1.jpg

 

 

I'm stumped how I hecked this up so the files are up at:

 

http://www.cdlc.wit-n-wiz.com/AirbrushedAlpha/

 

I've changed default tones and moved the first tone change markers around a bit in various iterations as well as deleted and regenerated the XML and arrangement in the Toolkit, but they've had no impact on this issue. The part in question is on REAL_GUITAR (Lead in-game), REAL_GUITAR_22 (Bonus Lead in-game) is synth and has no tone changes.

 

Tones are lifted directly from Chompers.

 

Any help would be appreciated, thanks for your time.

I've always got the multitracks.

Link to comment
Share on other sites

let's say that there was some issues with rif repeater ingame itself, are you able to reproduce same behavior in DLC files?

It may be audio related(if converted by hand) RR related and actually rounding issue with bpm so make sure you follow best practice including making offset 10 sec in your chart\cdlc

Link to comment
Share on other sites

  • Developer

I tested it and the tone change itself happens at the correct time, only the "tone switch" text comes late.

It may be due to the difficulty setting stuff the game displays at the beginning of a song (or not).

Adding more leading silence might fix it.

  • Like 1
Link to comment
Share on other sites

I tested it and the tone change itself happens at the correct time, only the "tone switch" text comes late.

It may be due to the difficulty setting stuff the game displays at the beginning of a song (or not).

Adding more leading silence might fix it.

Interesting, thank you! The song has some non-negligible leading silence already, but it's got a very fast tempo so it's probably not making the usual difference to hide this quirk.

I've always got the multitracks.

Link to comment
Share on other sites

  • Developer

Thought it was a general rule that all events including tone changes happen at time="10" or greater?  Try moving your tone change to time="10" and see what happens.  Like Alex said, 'best practice including making offset 10 sec in your chart\cdlc".  Is it?

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

  • Administrator

@@cozy1 I still see tons of people not following the 10 secondes before the first beat rule and DDC will anyway create an beat at time 0 which will make RS play all the empty time instead of skipping ahead like it does with oDLC...

 

So some people don't follow that rule because they don't want to have the full 10 secondes being played understandably.

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to comment
Share on other sites

  • Developer

@firekorn  I would like to know if not following the guideline is maybe the cause of @@Karmeleaux issue.  Thanks

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

I took a three year break from charting, I looked at some refreshers when I came back but I'm sure that's not the only 'general rule' I missed (I legit wish I could just transcribe the songs and have someone else worry about tone nonsense et al, but such is life). It's definitely a bit unusual to have to add an extra two seconds to the beginning just for that, but I guess if that's how it goes then that's how it goes.

I've always got the multitracks.

Link to comment
Share on other sites

@@Karmeleaux your PC is old and slow? I've got significant delay in graphics part of the tone change after I manually switch it I can hear it faster than amps drop down or sometimes it takes some time to load tone to the rs input mixer, but for powerful PC\MAC you won't met those circumstances at all. and yes @@iminashi has tools to fix ddc work after, not sure why @@Chlipouni haven't fixed at leas 0 sec bug yet?

Link to comment
Share on other sites

@@Karmeleaux your PC is old and slow? I've got significant delay in graphics part of the tone change after I manually switch it I can hear it faster than amps drop down or sometimes it takes some time to load tone to the rs input mixer, but for powerful PC\MAC you won't met those circumstances at all. and yes @@iminashi has tools to fix ddc work after, not sure why @@Chlipouni haven't fixed at leas 0 sec bug yet?

My computer is like three years old, but it was an above average spec at the time. I suspected the tone actually was changing, but tones are something I have very low confidence about so if the game displayed something different than what I thought I trusted the game over me.

 

As stated, it's near definitely a visual glitch due to a tone change before the ten second mark, I'll add two seconds at the beginning later today when I rotate back to it and that'll likely solve it. It was upping my anxiety so I'm working on my off-project at the moment, as this is a cycle I developed for myself to avoid burning myself out with stress.

 

I do appreciate all the information offered though.

I've always got the multitracks.

Link to comment
Share on other sites

Adding just an additional leading two seconds of silence did fix this visual glitch, thanks. Apologies, it was my first song since my return that had such an early tone switch (possibly ever? Likely, if a song's tone heavy I usually consider it a hard pass).

 

I poked some tips and tricks when I returned to get a refresher, but I'll take a harder look at firekorn's tutorial to make sure I've got a handle on everything that's considered common knowledge nowadays.

  • Like 2

I've always got the multitracks.

Link to comment
Share on other sites

@@Karmeleaux your PC is old and slow? I've got significant delay in graphics part of the tone change after I manually switch it I can hear it faster than amps drop down or sometimes it takes some time to load tone to the rs input mixer, but for powerful PC\MAC you won't met those circumstances at all. and yes @@iminashi has tools to fix ddc work after, not sure why @@Chlipouni haven't fixed at leas 0 sec bug yet?

 

Hi Alex,

 

  Simply because I didn't know that bug ;)

  • Like 1
Link to comment
Share on other sites

  • Administrator

@@Chlipouni should have probably mentionned you but i thought that you would have noticed it considering it's in the DDC topic

http://customsforge.com/index.php/topic/2863-dynamic-difficulty-creator/?p=289576

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy