Jump to content

  • 0

Cdlc Crashes In Game Troubleshooting


spawn666
 Share

Question

Hi all,

 

I've been trying to create some custom content with some success but there is one song in particular where everything seems to work fine in RS and then it always crashes at the same part. Other CDLC i've made work fine. Any ideas on what could be happening here?

 

I've also done a couple of others which dont crash but just get stuck before the song appears - so basically the song doesnt start and you can just see the strings at the bottom of the screen (the guitar still sounds). Any ideas for this occurance?

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0

The game hanging before loading the song happens to everyone every once in a while but regenerating the psarc usually fixes it.  Sometimes I'll repack a million times and it won't work, but making a small change in the chart (move a lyric over a ms) fixes the hang after a repack.

 

Do you get any error messages when you save your EOF file?  What do they say?  Also, have you tried re-doing your wwise file?

Link to comment
Share on other sites

  • 0

Doubtful it's the guitarpro file -- that only imports notes, as long as you tell EOF to ignore the tempo and section information.

 

Have you opened the project in EOF and looked at the spot where you get the crash?

 

Things to look at:

 

List of tone changes and tone names.

List of section and phrases.

The list of fret hand positions -- try deleting all and regenerating them.

The difficulty level tabs -- if a level is marked with an asterisk, it means there's information in it. Make sure only one level for each track has note information.

Chord fingering -- make sure there are no conflicts there. If you added in your own fingering, delete this, let EOF generate those.

 

One thing to be aware of is that when you set a lot of these things, like sections, tone changes, etc., they're fixed according to the TIME, not the beat. This means that if you'd set one of these things, like a section or a tone change, according to a beat marker, but later move the beat marker for some reason, the tone change or section won't move with it. This is especially problematic with things like fret hand positions, which is why I recommend deleting all and regenerating them again just before you save.

Link to comment
Share on other sites

  • 0

Tried again and it doesn't work - I can only think there is something in the guitar pro import that it doesn't like.

Try to generate DD (on the XML files of each arrangement) with the generate log option. Then check the log file if there are warnings or errors inside ... This can help to identify the issue
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy