Jump to content

How to add custom songs on Mac


Wepeel

Recommended Posts

Oh, thanks for the reply @@firekorn, that's great to hear! What's no so good, is that I've followed the steps and troubleshoots to the 'T' and can't seem to have the CDLC show in my game. 

Currently running Mac OSX Yosemite 10.12.2 with the latest version of both Steam and Rocksmith 2014 - remastered (installed in default locations), ran the patch successfully, installed version 4.0.4 of Mono successfully, can use the custom version of the RSToolkit that was posted, purchased the "Cherub Rock" DLC, and have placed GNR - "Welcome to the Jungle" CDLC in my default DLC folder of my game. 

After starting RS through Steam, I go to the "learn a song" tab of my already created profile and cannot find my CDLC anywhere, I can, and have, played the Cherub Rock DLC, however. 

Any thoughts or suggestions? 

Link to comment
Share on other sites

so it looks as though I have installed mono correctly. 

 

The song creator opens giving me a message "it looks like this may be your first time running the toolkit and I need to fill out the config menu with my selections." I'm not exactly sure what to put in here. if I close it I can access the converter by restarting it .

 

After the conversion says its complete and I have a Mac version of the song it doesn't show up in Rocksmith.

 

Other songs show up that I have not converted. 

 

I have tried at least 6 different songs so I know the files I get are not broken.

 

is the converter messed up? Or am I missing something.

 

Running 10.12.2

 

I have read about installing the other version if it doesn't work. I have done that and I still get the same result.

 

Please help.

 

 

Mono JIT compiler version 4.6.2 (mono-4.6.0-branch/ac9e222 Wed Dec 14 17:02:09 EST 2016)

Copyright © 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com

TLS:           normal

SIGSEGV:       altstack

Notification:  kqueue

Architecture:  x86

Disabled:      none

Misc:          softdebug 

LLVM:          yes(3.6.0svn-mono-master/8b1520c)

GC:            

Link to comment
Share on other sites

This is an EXCELLENT one-stop set of instructions to remedy problems related to CDLC and getting them to play on Rocksmith 2014.  Thank you for consolidating all of the advice and instructions posted elsewhere into a single post.  Thanks to your explanations, I was able to remedy not just the problems I was facing getting CDLC to play, but with getting the RS Toolkit to work.

Link to comment
Share on other sites

I am on a clean install of Sierra, using a fresh install of Rocksmith from Steam. After running the patch, I launch Rocksmith through Steam and the icon just bounces endlessly in my dock; Rocksmith never opens. I have no CDLC in my folder, any suggestions?

 

EDIT: Well, after a restart it's working.. I'm an idiot. Thanks so much for this well written guide.

Link to comment
Share on other sites

I'm running OS X 10.7.5 and downloaded the appropriate ZIP file...changed all the permissions to Read & Write...closed Steam and Rocksmith...but when I click on the RUN_PATCH_RS.command file, I get this message:

 

 

 

/Users/admin/Downloads/MAC_Patch/RUN_PATCH_RS.command ; exit;
/Users/admin/Downloads/MAC_Patch/RUN_PATCH_RS.command: line 4: ./insert_dylib: Permission denied
logout

[Process completed]

 

Did I miss something? I went through the whole thread and didn't find a solution, although I apologize if I overlooked a step. All my CDLCs show up in the game but they freeze after the tuning screen. Built-in and legit DLCs run fine. Yes, I did purchase "Cherub Rock" and I have been able to play with CDLCs before updating to the Remastered edition.
 

Link to comment
Share on other sites

@@anthontherun, you need to set your file permissions.

 

From first page of this thread:

 

**If you encounter a permissions error while running the patch:

 

  1. Right-click on the patch and select "Get Info"
  2. Under "Sharing & Permissions", make sure that all users listed have "Read & Write" permissions.
  3. If they do not, click the small lock icon in the bottom right corner to allow the permissions to be changed, and enter your Admin password.  Then select each user that needs to be changed and alter the permissions.
  4. Repeat for the other two files needed for the patch ("insert_dylib" and "libRYBypass.dylib")

Although I had to set my permissions through Terminal for them to have a lasting effect (I'm also on 10.7.5).  I don't have my Mac with me at the moment, so can't elaborate, but you could try Google.

 

Edit:

I believe from Terminal, it's

chmod 777 "filename"

Link to comment
Share on other sites

@missis sumner I had set everything according to the instructions yesterday--everything still indicates that all permissions are Read & Write. Going through the terminal, I followed the 777 command as well as another source I saw online...but I'm still getting the exact same message. If it's not too much trouble to explain step by step exactly what you did to make CDLCs playable, I'd really appreciate it.

 

EDIT: I think I got it to work! The insert_dylib file was being stubborn, but I switched the permissions on that in Terminal and then tried again and it looks to be successful. Unfortunately I don't have time to take out my bass and test right now but I'll check it out soon. Fingers crossed.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

special thanks to @missis sumner and @Wepeel for providing the help I needed to get things running.

 

I'm running Mac OS Sierra Version 10.12

 

what fixed everything for me was uninstalling the Mono Framework I downloaded originally (Version 4.6.1) and downloading Mono 4.04.

 

If you've recently updated your mac download Mono 4.04!!!

 

After hours of trying to figure this out, it was only after downgrading to this version of the Mono Framework that everything started to work.

 

Now excuse me while I roll one and learn how to play some Grateful Dead.

 

Cheers

  • Like 1

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy