Jump to content

  • 0

CDLC Won't Load after tuning


Hunterfox1
 Share

Question

I've downloaded a couple of songs off the custom forge website to try and play on Rocksmith.  I download them and put them into my dlc file for rocksmith.  Rocksmith does recognize them in game. However, whenever I turn on the song, it will take me to the tuning phase and then after that the song will not load.  The speakers and everything still work because you can hear when you pick strings after the tuning.  I've tried using the rocksmith patcher, but it doesnt even recognize the songs. I also downloaded the D3DX9_42.dll file, and it didnt change anything.  Has anyone else had this problem?

  • Like 10
Link to comment
Share on other sites

Recommended Posts

  • 0

It sounds like you don't have the .dll file in the correct folder. It needs to be in the root folder, as per the tutorial: http://customsforge.com/topic/901-how-to-use-custom-dlcs-in-rs2014/

  • Like 1

The Led Zeppelin Discography thread

learning to chart > asking someone else to do it

"The only true currency in this bankrupt world is what you share with someone else when you're uncool." - Lester Bangs
 

Link to comment
Share on other sites

  • 0

It sounds like you don't have the .dll file in the correct folder. It needs to be in the root folder, as per the tutorial: http://customsforge.com/topic/901-how-to-use-custom-dlcs-in-rs2014/

By root folder I'm guessing you mean the Rocksmith2014 folder that you go into under SteamApps > common > Rocksmith2014? If so, I did do that.  That didn't change anything.  The video didn't really explain much about the root folder to begin with.

Link to comment
Share on other sites

  • 0

 

It sounds like you don't have the .dll file in the correct folder. It needs to be in the root folder, as per the tutorial: http://customsforge.com/topic/901-how-to-use-custom-dlcs-in-rs2014/

By root folder I'm guessing you mean the Rocksmith2014 folder that you go into under SteamApps > common > Rocksmith2014? If so, I did do that.  That didn't change anything.  The video didn't really explain much about the root folder to begin with.

 

Yes, it's the one subfolder back from the /dlc folder - it contains the game's .exe file. 

 

In that case, make sure that the file name of the .dll does not end with a "(1)" or "(2)" - it does, just delete that from the filename. This will happen if you've added the .dll multiple times, and is one of known causes of your problem.

 

If you've done things correctly, you should see a small black cmd prompt window open up when you launch Rocksmith. You'll also want to read the rest of that tutorial if you haven't already.

  • Like 1

The Led Zeppelin Discography thread

learning to chart > asking someone else to do it

"The only true currency in this bankrupt world is what you share with someone else when you're uncool." - Lester Bangs
 

Link to comment
Share on other sites

  • 0

 

 

It sounds like you don't have the .dll file in the correct folder. It needs to be in the root folder, as per the tutorial: http://customsforge.com/topic/901-how-to-use-custom-dlcs-in-rs2014/

By root folder I'm guessing you mean the Rocksmith2014 folder that you go into under SteamApps > common > Rocksmith2014? If so, I did do that.  That didn't change anything.  The video didn't really explain much about the root folder to begin with.

 

Yes, it's the one subfolder back from the /dlc folder - it contains the game's .exe file. 

 

In that case, make sure that the file name of the .dll does not end with a "(1)" or "(2)" - it does, just delete that from the filename. This will happen if you've added the .dll multiple times, and is one of known causes of your problem.

 

If you've done things correctly, you should see a small black cmd prompt window open up when you launch Rocksmith. You'll also want to read the rest of that tutorial if you haven't already.

 

Yeah I just had to rename that .dll flie.  Thank you so much for you help. Works really good now! :D

 

  • Like 2
Link to comment
Share on other sites

  • 0

For those of us that this didn't work are there any other fixes?  I only have the one D3DX9_42.dll in my root folder but none of the CDLC songs will actually load after tuning. I do see the debug window load when I open Rocksmith 2014 as well.  By all appearances it should be working fine but it won't load...

  • Like 1
Link to comment
Share on other sites

  • 0
  • Administrator

@@bsgifford05 With the remastered update and the last dll, you shouldn't have a command window anymore :

 

CDLC not working - General Rocksmith - CustomsForge

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to comment
Share on other sites

  • 0

I had the same issue and I did a lot of the steps here. Nothing worked and it always stopped at the tuning part. One solution that worked for me is go to your Rocksmith folder. Find the Rocksmith start icon and right click it. You should have the option to run as administrator. Click that instead of open and if everything is set up as previous stated here you should be good. 

Link to comment
Share on other sites

  • 0

Hi, I'm having this same issue and have tried these fixes and still have the same issue as described. I've ensured the song (it's Run Runaway which is the current challenge song and there's no (1) or (2) attached to it) is in the root directory. I've also tried running as administrator and it still won't work. Any suggestions? Thanks.

 

Here's the name of the file exactly as it appears in my DLC folder: Slade_Run-Runaway_v1_DD_p.psarc

Link to comment
Share on other sites

  • 0

In my case it turned out that the Cherub Rock DLC was added to library but not downloaded even if it was playable from the game. I solved by doing this:

 

From Steam right-click Rocksmith 2014 -> Properties -> DLC tab -> uncheck and then recheck the Cherub Rock DLC

 

It started downloading the DLC and from then everything worked.

Link to comment
Share on other sites

  • 0

I am having this exact same issue despite owning Cherub Rock and going through all the steps individually. CDLC songs just break the game entirely after tuning. Game will show the speakers, will play audio, but pressing keys does nothing and I have to force close the game to get back into the menus. What the heck is going on here? 

  • Like 2
Link to comment
Share on other sites

  • 0

im having the same problem i downloaded everything needed and put the right file in the right place  and everytime i load  a custom song it  will load the song (after i tune) but the song wont play it just shows the amps in the background (it still outputs sound from guitar when this happends.)

  • Like 2
Link to comment
Share on other sites

  • 0

Hi, I've been using CDLC for years without any issues.  I have a an iMac running macOS 10.13.6 (17G5019)) and in the last week or so CDLC songs have stopped working.  So I guess I'm slightly different to the other recent posts who seemed to be attempting to use for the first time as I've been using since Feb 14.  Has there been some sort of change to the core game or elsewhere that might be making CDLC no longer work?  Does anyone have any advice for me please?

 

 

Model Name: iMac

  Model Identifier: iMac10,1

  Processor Name: Intel Core 2 Duo

  Processor Speed: 3.06 GHz

  Number of Processors: 1

  Total Number of Cores: 2

  L2 Cache: 3 MB

  Memory: 12 GB

  Boot ROM Version: 213.0.0.0.0

  SMC Version (system): 1.52f9

  Serial Number (system): W89420FJB9U

  Hardware UUID: 2B0F400B-53D1-5172-BD9F-F68A7BE00EBF

Fender Classic Player Baja Telecaster; Epiphone Nighthawk Custom; Westone Concord 1: Italia Mondial Classic;


Epiphone J Mascis Jazzmaster; Chapman ML2 Classic Gold-top


 

Link to comment
Share on other sites

  • 0

@@firekorn Thanks for the reply, nope not tried that but I can do.  Thought I'd check if some known issue before attempting anything.  

Fender Classic Player Baja Telecaster; Epiphone Nighthawk Custom; Westone Concord 1: Italia Mondial Classic;


Epiphone J Mascis Jazzmaster; Chapman ML2 Classic Gold-top


 

Link to comment
Share on other sites

  • 0
After putting the file and having changed the .dll file, inside the game of the section to learn a song, and from there you play with the search filters, and that one says "edit song" you click and it is updated songs list.After putting the file and having changed the .dll file, inside the game of the section to learn a song, and from there you play with the search filters, and that one says "edit song" you click and it is updatedAfter putting the file and having changed the .dll file, inside the game of the section to learn a song, and from there you play with the search filters, and that one says "edit song" you click and it is updated songs list.gdfgdfgdfg
}}fdgdfg
After putting the file and having changed the .dll file, inside the game of the section to learn a song, and from there you play with the search filters, and that one says "edit song" you click and it is updated songs list.
 

After putting the file and having changed the .dll file, inside the game of the section to learn a song, and from there you play with the search filters, and that one says "edit song" you click and it is updated songs list.

Link to comment
Share on other sites

  • 0

Hey, i try to fix this problem (only the speakers on the screen after tuning the guitar) for many hours. I downloaded the right .dll file that i placed in the root folder but it still doesn't work, please help me, i'm getting crazy, i don't understand

  • Like 5
Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy