Jump to content

USB Hub -- cable not recognized


Recommended Posts

I bought a new Dell G5 PC (now about 2 months old) mainly for the purpose of porting leisure activities from my Mac, and a large part of that is RS.

Problem is, it won't work: it doesn't seem to know that the cable is plugged in.

I understand that this is often a power issue. I tried all the ports (legacy style and new, to the extent that they fit the cable USB end directly), no dice. Plugged in a StarTech USB powered hub (ST4240USB), no dice. Until I used a specific port, closest to the power adapter input. Great!

Then, tried to play the other day, no hardware changes... no dice again. Tried all the USB hub ports, nope, nothing doing.

So I'm supposing the hub is marginal and I need a better one?

Happy to hear anything else I can  try, or recommendations on a good hub. (I've heard that newer USB stuff is lower power but I don't know for sure. I'd rather buy new tech than obsolete, but... priority is getting this working).

Thanks!

Link to post
Share on other sites

I would recommend plugging into one of the USB ports on the computer directly. If you need more cable length, get a 1/4" coupler (I use this one Amazon Link ) and a standard instrument cable. USB Hubs are generally problematic for sensitive peripherals in my personal experience.

Started playing Bass with Rocksmith April 2019

Link to post
Share on other sites

For what it's worth, after having similar issues, I've had the most success plugging into a USB-C port (RS cable + USB to USB-C adapter). 

The Led Zeppelin Discography thread

Don't be that guy who posts in a song's thread, asking for another song by that artist. That guy is weak... and he gets ignored.

"The only true currency in this bankrupt world is what you share with someone else when you're uncool." - Lester Bangs
 

Link to post
Share on other sites

@tdchewyWell, that's how I did it originally, and it did not work. The various experts in the Discord support said it's almost always about power, use a hub. So I did, I used the one I have, and it worked... once. Once only.

@GetTheLedOut I did not try the USB-C as I had been told that is guaranteed not to work (and I don't have an adapter of that kind) but it's worth a try. Thanks.

At the moment, I'm going through the motions with Ubisoft, who never read what you answer... if you say you tried all their steps they ask did you try all their steps, etc. Sigh.

Thanks, folks. Onward....!

Link to post
Share on other sites

@GetTheLedOutUpdate: I do have an Apple USB-C to USB-A/HDMI/USB-C adapter, actually, so I tried that. No good.

Mind you, I don't trust it that much, I've had issues in the past on the Mac so that probably doesn't prove much....

On the other hand... it just WORKED with the USB-C to USB-A Apple adapter AND the USB hub.

Now, once doesn't prove anything, but let's see. I'm not going to tell UBISoft because I'd really like an explanation of what the issue is. But I'm not holding my breath...

!!

  • Like 1
Link to post
Share on other sites

So far, besides not paying attention to what I've said, they've suggested changing the cable (and I reminded them that it works fine on the Mac, so it's not the cable). So then they turned around and suggested I switch guitars to see what happens.

I'm asking what the point of that is, because I'm playing a bass. It doesn't really help if it works with the Strat, and I want to play the bass.... Let's see whether they have an intelligent answer. Again, not holding breath.

Link to post
Share on other sites

Is the Rocksmith cable showing up properly in Device Manager? Never? Sometimes? Only for an instant, then gone?

Also, have you tried testing the cable while all other non-essential USB devices are unplugged?

In my case, I'm nearly certain that the RS cable wasn't happy with the amount of power that it was receiving from almost any USB-A port. This is a PC that I built, while the cable continued to work on my older laptop....

The Led Zeppelin Discography thread

Don't be that guy who posts in a song's thread, asking for another song by that artist. That guy is weak... and he gets ignored.

"The only true currency in this bankrupt world is what you share with someone else when you're uncool." - Lester Bangs
 

Link to post
Share on other sites

@GetTheLedOut No, that's just it. Most of the time (with two exceptions) it comes up as Rocksmith USB Guitar Adapter and then after two seconds gets flagged error 10 can't start; the other half of the time it comes up as USB Audio Device and gets flagged. (And twice it worked, as you know).

I have nothing else on the system except mouse. Not even a keyboard (using bluetooth keyboard). (Oh except for headphones in the headphone jack.) I understand it's likely a power issue; that's why I used the hub.

So so far, I've NEVER managed without the hub, and only twice with it, so hard to know whether the hub is actually doing anything or maybe semi-functional.... Come July 1st I'll have budget to buy a new hub (which I would need anyway) so I can test that further.

In the mean time, RS have now asked me to send a DX Diag file with the game running. So maybe we're getting somewhere. (Hold breath?) 🙂

Thanks for the continued advice.

Link to post
Share on other sites

Yup, those symptoms are very similar to mine.

For what it's worth, I continued to experience error 10 related issues on two different powered USB hubs, in addition to a PCI-E expansion card. Thankfully, I already had these things on hand in my bottomless parts bin....

So, my wholly unqualified, strictly anecdotal advice would be to shy away from pursuing another USB hub until you're fresh out of other options. 

Is it possible that the adapter you tried may not meet some necessary technical/electrical requirement? I'm honestly not sure what the differences are, but I used this one (2 pack for $9) and it's always performed flawlessly directly in my USB-C port. Also, if you haven't already done so, you'll want to make sure that your USB related drivers (like Host Controllers) are correct and up to date. 

 

If things with Ubi don't work out, you can also try using a little tool called USBDeview which just facilitates the easy uninstalling of previously connected USB devices. It didn't resolve my issues, but once you've used it to "forget" the RS cable, Windows will again treat the cable as a new device and force the driver installation/setup.

The Led Zeppelin Discography thread

Don't be that guy who posts in a song's thread, asking for another song by that artist. That guy is weak... and he gets ignored.

"The only true currency in this bankrupt world is what you share with someone else when you're uncool." - Lester Bangs
 

Link to post
Share on other sites

Posted (edited)

Ubisoft have just washed their hands of this. They're now saying that if the cable is USB 3 and my ports are all USB 2 then they can't help me.

Well, my ports AREN'T all USB 2 (as I've said multiple times, I've listed them alll!!) and I don't know anything about the cable, whether there are different types of not...

I just ordered a new hub with Dell rewards dollars, should be here next week, and a USB-C to A adapter along with it. Somewhere i have another RS cable where I replaced the jack as it got damaged, just can't find it right now....

(I only saw your message after I made that order, but it didn't cost me any real money so it's a free option.)

The other thing I can do is buy a new cable, but, as I say, it works on the Mac. Last resort is to play on the Mac... what a waste to have bought a new system. I can also try pestering Dell and see what they say.... EDIT: and I just realized they've got me so wound up with their illogic that a new cable won't solve anything, it's a DRIVER ISSUE... sigh!!!

I'll look into ther links you offered. I do appreciate the help. I'm surprised so few people are offering any advice. Surely we're not the only two people with this issue....!!!

Edited by Nick Beat
Add corrective info
Link to post
Share on other sites

Mmm, there are a few questions.

1. In case if it's a driver issue, did you install a seperate driver for the cable on Win10?
    Win10 does not need a seperate driver, it will reconize it perfectly.
    Remove the driver you got with the cable.

2. did you extend the Usb side of the cable?
    If so, it's a bad thing to do, as Usb can only deliver enough power to a certain lenght
    I would suggest extend the guitar cable in that case.

As for Usb 2 or 3.
Some Usb 2.0 indeed do deliver less power than the ones on the motherboard directly, those on the front of the case most of the times.
And ofc you can use Usb 3 ports, even the ones on the front of the case.
Usb 3 is backwards compatible with previous versions.

Atm that's all I can think of.
I never have seen a error 10 before, it always works perfectly so far.


 


YouTube


Every strum you do, is a lesson, keep strumming.

Link to post
Share on other sites

Hi

Thanks for the suggestions.

No,no separate driver. Windows configured it on its own. No cable extension either.

As for ports, the two times it worked it was front ports, but I had tried the back ones too :( and once it was front USB-A and once front USB-C.

I have a new adapter and hub coming from Dell, should be here in a couple if days. Will report back then.

Appreciate the support!

 

  • Like 1
Link to post
Share on other sites

For anyone else looking for a solution:

My Dell order came in and I got the wrong hub (not powered) so I couldn't test that. But someone at the RS+ event misunderstood something I said which ended up being fortuate....

I installed the DLL files from https://github.com/mdias/rs_asio and used one of the sample configurations files for Steinberg UR22, then moved my Steinberg UR22 mkII to the Dell, installed its driver, plugged the headphones into the Steinberg, and bingo! problem solved.

Not only that, but now I can boost the gain, which RS *always* complained about.

Good solution, if you can afford the hardware. There are plenty of analogue-to-digital boxes out there which will work (see the github site for a list). No more RS cable dependence!!!

  • Like 1
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy