Jump to content

Getting rid of beat markers


Recommended Posts

So, I seem to be having problems with handshapes. For some reason the handshapes vanish in certain points, I looked at the EoF file and it seems that at every song where there is a problem with the handshapes there is a beat marker. I've tried to toggle the beat markers be selecting them and pressing "a", however the beat markers return every time I save the game. Does anyone know of a more permanent way of getting rid of beat markers?

Link to comment
Share on other sites

Beat markers? Are you sure you aren't referring to section marker?

No, I mean beat markers, the little red arrows on top of the number that displays the BPM of that particular song. Like I've said the disappearance of a handshape seems to correspond to the presence of the beat markers.

Link to comment
Share on other sites

  • Administrator

@@Yojimbo1989 and i can tell you that it's impossible, the only reason for an handshape to be cut off prematurly is by having a new section which will obviously happen on a beat marker but deleting the beat marker itself won't resolve anything at all. In fact i would dare say it will only make things worse.


If you didn't make section yourself in EOF, DDC will add section where it consider it needed compared to his algorithm which can explain the issue but, it would indicate largely more important issue in your CDLC that should be taken care off.

Firekorn's workshop
In Flames Discography


Link to comment
Share on other sites

Not yet, but I will at the first opportunity. But it's like I said, none of the sections that I created for DDC, overlap the HS; everytime it does EoF gives a warning about that. 


As a side note I removed the beat markers (with the delete anchor command), which did indeed solve the problem I had with cutting off the sustains. However there are still several peculiarities with the HS, such as keeping the fingering for a chord even after it's ended (which I marked in the EoF chart) or ending prematurely despite being asked to end in a certain point. :huh:

Link to comment
Share on other sites

  • Developer

One workaround is to split the time signature of the measure so that the section starts on the first beat, like splitting it into 3/4 and 1/4 time signatures for example. It's not very pretty.


I've wrote a program that automates a workaround (and does other things) so I don't have to think about it. I've been meaning to release it any day now....

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy