Jump to content

  • 0

Visual glitch in chords self-made CDLC


djsoundnr1
 Share

Question

Hello, I recently tried my hand in making my own CDLC. However, I've ran into the problem - strings that are unused in chords are horribly artifacting/glitching, making the whole note highway unreadable. I've tried to regenerate it and redo it once again, but to no avail.

 

Any help would be greatly appreciated, thanks in advance.

 

Screenshot of said glitch: https://puu.sh/usB3j/7f426bf2d9.jpg

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

It looks like a typo in one of the chord definitions.  This definition:

 

<chordTemplate chordName=""        finger0= "1" finger1= "1" finger2= "3" finger3="-1" finger4="-1" finger5= "1" fret0= "1" fret1= "1" fret2= "3" fret3="-1" fret4="-1" fret5="-1"/>

incorrectly defines use of the index finger on the high E string even though the fret number for that string indicates the string isn't played.  EOF's error checking was automatically removing the fingering for the chord after it was automatically applied due to the fingering being invalid, which is why it was repeatedly saying that chord's fingering was undefined.  By editing the chordshapes.xml file and changing that definition so that finger5 equals -1 like the following:

 

<chordTemplate chordName=""        finger0= "1" finger1= "1" finger2= "3" finger3="-1" finger4="-1" finger5="-1" fret0= "1" fret1= "1" fret2= "3" fret3="-1" fret4="-1" fret5="-1"/>

The problem seemed to go away and EOF stopped complaining about the fingering for that chord.

 

I expect this is the cause of the problem in-game.  If you have time, please replace your chordshapes.xml file with this fixed one and let me know if the problem is indeed fixed:

http://ignition.customsforge.com/eof/download/151

Link to comment
Share on other sites

  • 0
  • Administrator

@@djsoundnr1 what version of EOF and the toolkit are you using? it would also be nice to be able to see the file you used to examine what can be wrong in it.

  • Like 1

Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity

Link to comment
Share on other sites

  • 0

@@raynebc Here is the uncorrupted .eof file: https://puu.sh/uul4t/3bf157577e.eof
File after "fixing" the incorrect finger information: https://puu.sh/uulcg/4e065f42a7.eof
One more info: this message prompts every time I'm trying to save the project - if you saved the project and applied the fix, then saved again, this prompt would appear again.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy