Jump to content
  • 0

New CDLC doesn't show...





First post here so sorry if its in the wrong section. Ive done a search but couldnt find exactly what i was looking for. Ive seen a recent post which sounds similar to my problem but i believe their problem was they are running windows 11.


So ive been using CDLC for awhile now - great, everything worked. Then as you probably recall the whole CDLC thing went down the pan when Rocksmith+ was released. There was a patch to run which solved everything. Great, i can get the songs back and play them.


I decided to try out some other songs so i downloaded the CDLC and the new ones do not appear in the learn a song list..... my other CDLC songs still appear, just not any new ones i downloaded. There are no filters on etc. I tried to download a few just to see if it was maybe the file i downloaded for whatever reason but any new CDLC i download does not appear.


Ive tried running the patch again but no luck....


Is there something else i need to do? or can anyone help me?



Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

are you sure that the cdlc is being put into the DLC folder? I know dumb and a superficial response, but eh, need to cover all bases, because as you already stated the older songs you used work, so that rules out the .dll. You stated you checked filters, so rules that out as well.

Link to comment
Share on other sites

  • 0



Yes theyre all in the same folder. Its weird how the files i put in the folder work and still work - after the patch problem. my cherrub rock file is still in there and playable.


Ive also tried removing the cherrub rock file from my DLC in steam and then checking it back - that didnt work.

Im about to uninstall and install to see if that works but im not holding out any hope.


After this im at a loss and im kinda thinking of giving up on it which is a shame.

Link to comment
Share on other sites

  • 0

Alright, It worked!


What i did:


My original install was on my secondary drive (D:) in the root folder. D : \ Rocksmith 2014

I copied out my dlc folder to another location.

Uninstall through steam

Install through steam - Steam asked me do i want to create a new directory (on my secondary drive) which i dont think happened last time, but whatever. It put the new directory in D : \ steamlibary \ steamapps \ common \ Rocksmith 2014

Loaded the game - everything was fine - I didnt need to use justincaseyouneedit patch. Steam put all the original DLC files including cherrub rock back in - I had some other legit DLC from when i purchased the game. Bob Marley, Elvis etc.

Copied my cdlc back to the new DLC directory and ALL my files showed up. Obviously the ones i couldnt see before were all at 0% complete. All my other files kept their progress.

Closed the game, downloaded another CDLC and put it in the directory to check it works and it has. Its showed up in the list.


Hope this helps someone 🤘


EDIT: all my original dlc and cdlc worked but when i tried to play a 'new' cdlc it just froze. I still got the tone and just a picture of the amps. I ran the patch file and that has sorted it out.


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy