Jump to content

Export Guitar Pro


BHMath
 Share

Recommended Posts

An amazing features this option but it doesn't export the new bonus track.

 

Thanks ahead

Take a look at my Workshop. You'll find which song I plan to create someday.

 

Please leave constructive feedback, it helps me creating better customs !

Please don't thanks with comment but with the button !

 

 

Link to comment
Share on other sites

Oh right didn't updated this version on my computer... It was 1.8RC11 (12-6-2016)

 

My bad

Take a look at my Workshop. You'll find which song I plan to create someday.

 

Please leave constructive feedback, it helps me creating better customs !

Please don't thanks with comment but with the button !

 

 

Link to comment
Share on other sites

I tried it on RC12 but still the problem. I know it's not the latest version, but I won't update now (too messy at the moment on my side)

 

I'll let you know if the problem still occured when I'll get the latest version.

 

Thank you very much

Take a look at my Workshop. You'll find which song I plan to create someday.

 

Please leave constructive feedback, it helps me creating better customs !

Please don't thanks with comment but with the button !

 

 

Link to comment
Share on other sites

@@raynebc

I just upgraded to RC12 + latest hotfix from RC11 (9-14-2016). Now when I enable midi tones, they are way out of sync (it wasn't all that great before). Tried RC11 again and that still works fine. 

Also, is there any way to fix/stop the midi tone sustained drone that remains when you pause playback?

Also, thanks for all your time.

Link to comment
Share on other sites

You probably have to set the MIDI tone delay (in File>Settings) to match what you were using in RC11. EOF can't control how well MIDI tones sync with the chart, but hardware MIDI devices (ie. a synthesizer) seem to be faster than software synths (especially the one built into Windows). Some MIDI tones don't decay on their own and even though I've added logic to try to stop the tone when playback is paused, it doesn't seem to reliably work.

  • Like 1
Link to comment
Share on other sites

You probably have to set the MIDI tone delay (in File>Settings) to match what you were using in RC11. EOF can't control how well MIDI tones sync with the chart, but hardware MIDI devices (ie. a synthesizer) seem to be faster than software synths (especially the one built into Windows). Some MIDI tones don't decay on their own and even though I've added logic to try to stop the tone when playback is paused, it doesn't seem to reliably work.

 

Thanks, that was the problem. Back to it's normal self now, vaguely remember setting this a few years back.

 

You mention using a hardware synth instead of the inbuilt Windows one. How do I do this? How do I let EOF know which midi device (my keyboard) to use? Thanks.

Link to comment
Share on other sites

If you plug a synthesizer into your computer, and set it as the default MIDI device in Windows, EOF should end up using it as the MIDI playback device the next time it is launched.

 

I should note that those instructions worked in Windows XP, but newer versions of Windows don't have the ability to set separate default devices for MIDI and sound playback in general. There might not be a straightforward solution for this. The most immediate solutions I can find involve installing third party MIDI drivers or editing the Windows registry (http://pcaudiohelp.com/how-to-change-the-default-midi-device-in-vista-and-window-7). It might not be good to edit the registry unless you're confident you know how to do so and make a backup of it first.

Link to comment
Share on other sites

Thanks, I might investigate the registry thing further, as I can't find anything relating to Win 10. :/

 

An alternative maybe?

 

From the allegro docs..

 

http://liballeg.org/stabledocs/en/alleg003.html#Standard config variables

 

[sound]

Section containing sound configuration information, using the variables:

digi_card = x

Sets the driver to use for playing digital samples.

midi_card = x

Sets the driver to use for MIDI music.

digi_input_card = x

Sets the driver to use for digital sample input.

midi_input_card = x

Sets the driver to use for MIDI data input.

digi_voices = x

Specifies the minimum number of voices to reserve for use by the digital sound driver. How many are possible depends on the driver.

midi_voices = x

Specifies the minimum number of voices to reserve for use by the MIDI sound driver. How many are possible depends on the driver.

digi_volume = x

Sets the volume for digital sample playback, from 0 to 255.

midi_volume = x

Sets the volume for midi music playback, from 0 to 255.

Would setting the midi_card variable to something different maybe direct the output to the driver for my keyboard?

Link to comment
Share on other sites

I don't think that will do it. The issue is defining which device in Windows itself is going to play MIDI notes. It's likely that the registry changes to configure this in Windows 7 are the same for Windows 10, but I haven't personally tried it.

  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

I don't think that will do it. The issue is defining which device in Windows itself is going to play MIDI notes. It's likely that the registry changes to configure this in Windows 7 are the same for Windows 10, but I haven't personally tried it.

 

Eventually got this going in Windows 10 with CoolSoft MidiMapper

 

http://coolsoft.altervista.org/en/forum/thread/427

 

Thanks

Link to comment
Share on other sites

That's good to know. I might add mention of it to the documentation.

 

I used my Korg midi synth.  I've not tried it, but it sounds like it might also work in combination with the software synth VirtualMidiSynth with suitable SoundFonts.

 

Update: I tried using this in anger today. It turns out that only the notes on the bottom E string were being played on my keyboard (hadn't noticed this), but when I transposed the other notes onto the e string they played fine. After some messing, it looks like  EoF is using different midi channels for each string, not something my keyboard can be set up for... :(

 

Update 2: Tried VirtualMidiSynth with the FluidR3 GM Bank soundfonts, which works and has eliminated the 'drone'. :)

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy