Jump to content

  • 0

How's Rocksmith 2014 working on Windows 10?


BX5
 Share

Question

So, day 29 of this month W10 full version will be officially released, my question is, will the file needed to play the CDLC's still be compatible?

I don't know much about it, but I've read somewhere that the file has some kind of relation with the drivers, so with a new SO, the drivers will have to be updated.

 

That's one of the things that is really making me wonder if I should update it or not. Anyone that tried the preview version got it working?

Link to comment
Share on other sites

16 answers to this question

Recommended Posts

  • 0

I upgraded yesterday and just tried using RS2014 for the first time but now I'm getting "error sound initialization no audio output" etc. Normally it's my speaker cable going into the back of my motherboard playing up or razer synapse but I have tried sorting both out and neither seem to work, tried setting compatibility to w7 and w8 still nothing. If anyone else has w10 and got this but fixed it please help! :P

Link to comment
Share on other sites

  • 0

I upgraded yesterday and just tried using RS2014 for the first time but now I'm getting "error sound initialization no audio output" etc. Normally it's my speaker cable going into the back of my motherboard playing up or razer synapse but I have tried sorting both out and neither seem to work, tried setting compatibility to w7 and w8 still nothing. If anyone else has w10 and got this but fixed it please help! :P

I guess I'm glad I haven't upgraded it yet. Have you tried updating the drivers? If so, I guess you should tweet @Rocksmithgame or @UbisoftStudioSF about your problem and ask if it's a commun issue and if they know what you should do.

 

Sorry, I can't help you more than that.

 

EDIT: Found this, might be helpful. http://forums.ubi.com/showthread.php/1232522-Windows-10-amp-Rocksmith-2014

look for ununbiumross post, he seems that also had sound issues, but got them fixed.

Link to comment
Share on other sites

  • 0

This is the only problem I've encountered so far and it seems like very few have this problem. I saw a long list of games working on w10 from somewhere listing pretty much all my games and on Ubisoft's forums including Rocksmith 2014 so I went ahead and installed it. Didn't work out for me and RS2014 though :P

 

 

**Edited by : ForgeOn

Link to comment
Share on other sites

  • 0

Ive been running windows 10 for several months, first as a technical preview, and windows 10 final since the 27th .. rocksmith and cdlcs have been working just fine for me.

Yes, but as I recall you had the same sound error,, I just don't remember what you did to fix it. Wasn't it the Rocksmith Cable Driver ?

 I'm Allergic To Stupidity. I Break Out In Sarcasm.

Link to comment
Share on other sites

  • 0

i actually didnt install my win10 as an update .. i installed it as a new/fresh install ... but im off topic.  Ive had no problems with rocksmith in windows 10.  I had the gain turned way up on my cable, and had to turn it down to get rid of a bunch of noise.  but i can hardly blame windows for that. 

Link to comment
Share on other sites

  • 0

I fixed the audio initialization problem yesterday. Already tried updating all the drivers through device manager many times but I decided to take a look around on the realtek website anyway and found a windows 10 driver, installed it and everything seems to be fine now.

  • Like 1
Link to comment
Share on other sites

  • 0

Custom DLC work.

The only thing i had to change was LatencyBuffer from 2 to 4 Y_Y (2 no sound, 3 very crappy sound)

Im working on MaxOutputBuffer size.

This is very bad and i cant understand why...

 

This is the same thing happening to me.

 

Prior to the Win10 upgrade, I was able to run with Latency Engine set to 2 which was awesome because I had zero lag. Now after the upgrade, I have to change it to 4 which causes a very slight delay. I would love to find a fix.

Link to comment
Share on other sites

  • 0

Same for latency 4.

 

Another minor bug seems to be when I select quit, it brings me back to the title screen (Rocksmith 2014) to press Enter and doesn't close the application (unless that's because CGT is running?)

Link to comment
Share on other sites

  • 0

I have same issue, can not normal to play at win10. Work only as posted above: buffers=4 and size=0, else no any sound.

But with this setting very big lattency in sound of guitar, and lags with all graphics, unplayble. Look like need rollback to win7 or 8.

 

p.s. And yet bugs win10 - stop worked "start menu@ after changing monitors, and dropping drivers graphics digitizer, bad work handwrite panel, cutted functions.  Full shit.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy