Jump to content

Can't Import Tone(s).


Nullstate
 Share

Recommended Posts

I'm getting much closer to an actual work CDLC thanks to the help I received previously, but I've hit another snag.

 

When trying to import tones I get the following error:

 

Can't Import Tone(s).

Invalid Package

 

My tones are stored in the C:\Steam\userdata\ [hidden user ID] \221680\remote directory.

 

I'm running the toolkit as admin.

 

I reloaded RS and the tones are still present and working.

 

Any ideas?

Link to comment
Share on other sites

  • Developer

Do a Windows Explorer file name search for "*_prfldb" or "localprofiles.json".  These files are in the directory you want to choose if your are trying to import tones from your user profile (game save). 

 

Make sure you are selecting the proper file type in the toolkit 'Select CDLC Song Package or Tone File or your Profile' popup.  It should be 'Rocksmith 2014 Game Save Profile (*_prfldb) and then select the *_prfldb file you found with Windows Explorer. 

 

There are several other ways to import tones in the toolkit, just make sure you are selecting the correct method to match the type of file you are importing from.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

I have the correct directory ( I have steam installed directly on C:\ not in C:\program files). The _prfldb files and localprofiles.json are located there.

 

The file name is 1D28A8133E4E42D18123EEA99527601C_PRFLDB

 

There are two other _prfldb files as there are multiple profiles on my copy of RS2014, but that should be the correct one judging by the date the file was modified.

 

It's when I try to import the _prfldb in the toolkit that I get the error.

 

-----------

Also,  I'll be away for a few days so if you post something and I don't get back to you that's why.

Link to comment
Share on other sites

  • Developer

So that _prfldb that you sent link to has three tones in it that the toolkit can use ImglygL, ImglygR, and imglM2. 

 

1) In the toolkit Creator under Tones groupbox click on Import button.  Change 'File of type:' to Rocksmith 2014 Game Save Profile (*_prldb)  and select the 1D28A813*_PRFLDB file.  Click Open.

 

2)  Select the tuning you want to use from the Tone List.  (I picked ImglygL (-30.38069))  Click Continue.  You will get message that Tone(s) imported: 1  (you can pick any or all of your custom tones to import)

 

3) In toolkit Creator in Tones groupbox click on 'Default'  then click 'Del' button

 

4) In the Arrangements groupbox click on the arrangement that you want to change the tone of and click Edit button

 

5) In the Edit Arrangements popup box in the Tone Selector groupbox change the tone to your tone, ie ImglgL  (Choose Base and Tone A etc to match your tone) Click ok.

 

6) Generate

 

Keep trying, toolkit works as expected.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

That's what I've been doing, or rather trying to do. When I try to import is when I get the error.

 

Good to know that some can get it working though. Which should mean that the prfldb isn't the probelm. Thanks for that.

 

I just tried importing those tones tones in a new (blank) project under the creator. Still getting the error.

 

I'm going to try removing an reinstalling the toolkit again. Wish me luck, I suspect I'll need it.

Link to comment
Share on other sites

Okay, I just reinstall the toolkit, again. Version 2.6.0.0 gave me that same error as before, but for some reason this time 2.6.1.0 worked when run as admin (which is what I'd been doing). I'd tried that same process three times without success.

 

Weird. At least it is working now, but I do wish I know why it hadn't worked up until now

 

Thank you guys for all the help. Hopefully I can get this custom ready for beta testing now.

Link to comment
Share on other sites

  • Developer

Moral of story ... ALWAYS use the latest beta build.  Looking for bugs in old release version is ... (fill in the blank).

  • Like 1

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy