Jump to content

RS 2014 wont start anymore


Recommended Posts

Well after a new graphicscard driver was installed RS2014 wont boot up anymore, I get the white screen but the short black screen which initialize the game itself is missing instead it gets back to the desktop.

I tried now older Geforce driver and the internal drivers from windows but no can do anymore.

Is this a known problem with you guys or is it the first time you heard about it?

Link to post
Share on other sites

Hello,

I have had this same issue after computer or system upgrades over the years and have reinstalled the game and was back in business. Before you do this back up your dlc folder so you can install your current dlc folder to your fresh install of the game. I hope this helps!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy