Jump to content

  • 0

How do I get rocksmith to work with external interface and OBS?


InSKATANweTrust
 Share

Question

How do you get sound from rocksmith to OBS? I can't get rocksmith to work with my external interface (apogee quartet), only with headphones connected to the internal soundcard on the mainboard. So I'm really missing out on my potensial quality sound thru my studio monitores 😞 Any suggestions / solutions? I'm on a Windows PC btw.

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 0

good question, I'm struggling with the same thing. I have OBS working on a dual pc streaming setup. Maybe its the audio exclusivity option?

'99 Fender Power House Strat Deluxe Series Black

TBX tone pot Vintage American Noiseless Pups Active MidBoost

 

Dads Samick Torino 2 Red

 

Focusrite Scarlet 2i4 Behringer FSB1010 Reaper Amplitube 

Twin in Training Alex and Daniel

Link to comment
Share on other sites

  • 0

I struggled with this for quite a while until I found a working solution, and it works perfectly for me. I'm personally using a Focusrite Scarlett Solo, but it should work fine with any interface that is compatible with rs-asio. Make sure to follow the instructions very closely as it can get a little confusing (for me at least) when it gets to the voicemeeter config part.

 

Here is a link to a pastebin with the info: Click Here

For the record, I didn't write the guide (I found a link to it on Reddit), but I have been using this setup every day for months now without issue.

Good luck!

 

Started playing Bass with Rocksmith April 2019

Link to comment
Share on other sites

  • 0

I bought the M-Audio Air 192/4 that connects with a usb-c. I select it as primary sound device and Rocksmith also tells me no audio hardware found basically. Editing the Rocksmith.ini there are other settings not found in the game...

[Audio]
EnableMicrophone=0
ExclusiveMode=0
LatencyBuffer=1
ForceDefaultPlaybackDevice=0
ForceWDM=0
ForceDirectXSink=0
DumpAudioLog=0
MaxOutputBufferSize=0
RealToneCableOnly=0

I have not tried to tinker with the settings, but maybe someone here has idea if it would yield any results. 

Link to comment
Share on other sites

  • 0

I got my Audio Interface to work as a speaker output. Have not tried to set up the guitar input through it as a mic yet. I think its possible to tell the game to use microphone for input and tell windows to use the interface in recording properties. I don't know if by me changing that line to 1 in force default audio device mattered, but 1 would be true and 0 false. This is what I set to make it work. I also disabled the other output devices like my the built in motherboard audio and the NVidea audio in the same sound properties on the top left in case it confused rocksmith. make sure the audio interface is not trying to use anything but 48,000. Or it told me no sound device or it simply would not have sound and just show animating speakers with no sound in the game. Hope this helps !  Oh, I leave audio exclusivity on when the game is booting until the intro screens are playing the warming up guitar sound then I alt tab to the sound options and uncheck those two boxes with audio exclusivity and I get a much louder playback that seems correct for my volume settings. For some reason that setting makes everything very low volume in game. I leave it on in the program too, but trick it while its booting up. You will know if it worked when you alt tab back and its a lot louder. That is when I am using my internal sound card for sound. Don't need to fool with it with my audio interface cause I have separate volume for speakers and earphones. 

Untitled.jpg

Link to comment
Share on other sites

  • 0
1 hour ago, artistterrymartin said:

I got my Audio Interface to work as a speaker output. Have not tried to set up the guitar input through it as a mic yet. I think its possible to tell the game to use microphone for input and tell windows to use the interface in recording properties. I don't know if by me changing that line to 1 in force default audio device mattered, but 1 would be true and 0 false. This is what I set to make it work. I also disabled the other output devices like my the built in motherboard audio and the NVidea audio in the same sound properties on the top left in case it confused rocksmith. make sure the audio interface is not trying to use anything but 48,000. Or it told me no sound device or it simply would not have sound and just show animating speakers with no sound in the game. Hope this helps !  Oh, I leave audio exclusivity on when the game is booting until the intro screens are playing the warming up guitar sound then I alt tab to the sound options and uncheck those two boxes with audio exclusivity and I get a much louder playback that seems correct for my volume settings. For some reason that setting makes everything very low volume in game. I leave it on in the program too, but trick it while its booting up. You will know if it worked when you alt tab back and its a lot louder. That is when I am using my internal sound card for sound. Don't need to fool with it with my audio interface cause I have separate volume for speakers and earphones. 

Untitled.jpg

Have you tried using RS_ASIO https://github.com/mdias/rs_asio

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy