Jump to content

Why does EOF think I have two beats per measure?


lduperval
 Share

Recommended Posts

Hi,

 

I have a score which starts with an empty 2/2 measure, an empty 4/4 measure, and the third measure starts with a half rest. When I look at my measures in EOF, everything looks like  a 2-beat measure. is this a bug or a limitation? If a limitation, is my only recourse to redo my score with only 4/4 measures and resync? I compared with another of my songs, and it shows correct 4/4 beats.

 

I am using the 6-12-2019 version.

 

Thanks,

 

L

Link to comment
Share on other sites

When I import the Guitar Pro file and opt to import the time signature changes, it looks correct to me:

BNLvYy4.jpg

 

Make sure you're using the latest hotfix, otherwise please provide a screen shot showing what you end up with when you import the GP5 file.

Link to comment
Share on other sites

It looks like it's because the score was synced strangely in Go PlayAlong. The 4/4 time signature change is before 0 seconds, so it gets dropped from the import. I'll see if I can improve handling for this scenario, but if you apply another 4/4 time signature change at the beat where the first bass note occurs (either in the GP5 file or in EOF after import), it will work around this.

Link to comment
Share on other sites

Hi,

 

Hmm, not quite. This is before I added the beat:

 

https://drive.google.com/file/d/1AeGlRzoxDe-izYKy7spNSzTeRYLqFnUr/view?usp=sharing

 

and this is after:

 

https://drive.google.com/file/d/1yNwLyDwrSxqVV270XflWbBqE2Z0Wi0DE/view?usp=sharing

 

You'll notice that when i added the 4/4 signature the measures became shorter and it messed up my sync. It looks like I may have to restart.

 

What I'm trying to do: Add those clicks before the song starts so players know when the song begins. Maybe I did it wrong, I don't know. :(

 

This is the first time I've has so much trouble with a song.

 

L

Link to comment
Share on other sites

You will probably have to use "Beat>Time Signature>Convert" since the denominator is being changed and you don't want beat lengths to change. The only reason this happened is because the 4/4 time signature was defined before 0 seconds and was omitted by EOF during import.

Link to comment
Share on other sites

Hi,

 

I tried the time signature change, but it doesn't do what I want. I tried reexporting the song while changing the first three measures to 2/2 and at the third measure make it 4/4 but I still don't get the beat on every note. I still get it every two notes.

 

So it's OK, I'll wait until you're able to release the next patch and try again then.

 

Thanks!

 

L

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy