Jump to content

Can't Change Tuning... sort of...


Tysylio
 Share

Recommended Posts

I'm having a weird issue with EoF.  I had previously made a bass part in my current project that was tuned to BEAD in PART REAL_BASS_22, but I have instead created a 5-string bass part in the PART REAL_GUITAR track, and I now want to use PART REAL_BASS_22 for a Rhythm guitar track.

 

I'm fairly confidant I've done this before, so I erased the track I didn't want anymore, set the tuning back to standard EADG, then set the number of strings to 6, and the Arrangement Type to Rhythm.  I am tabbing the song I'm working on by ear, and I was having an issue isolating the strums for the first few bars.  I decided to change my sound card to a different mode to allow me to change the balance and some other audio features to isolate the sounds I'm trying to hear, so I saved and closed EoF. After I changed the audio setting on my sound card, I reopened EoF and found that it had reverted the track back to BEAD tuning and to only 4 strings. However, I've found that the Arrangement Type stays intact.

 

I'm didn't think this behaviour was expected, so I decided to report it here. Am I mistaken that I can use PART REAL_BASS_22 for a 6-string guitar track? And, why does EoF revert back to the old tuning?  Weird right?

 

Here is my current project, and I'm using EoF version 2-15-2016.

 

Thanks for your help,

Tysylio

Keep smiling. It makes people wonder what you've been up to.

See my Workshop here.

Link to comment
Share on other sites

This problem seems to be caused by having Rock Band export enabled, because in other rhythm games, pro bass tracks aren't capable of having any number of strings other than 4. When you load the project, one of the related files is read and overrides the string count for the bass track. I'm going to have to think about whether to keep this logic, but in the mean time, the easiest solution would be to disable "Save FoF/GH/Phase Shift files" preference and then delete the song.ini file in the project folder.

  • Like 1
Link to comment
Share on other sites

Those files were exported during save until a change on June 14, 2015 where I made that user preference. If you worked on the project with an old enough version of EOF, the song.ini file would have been created automatically. If removing that file doesn't resolve the problem, and it continues to still load that track with 4 strings after you set it back to 6 and save the project, let me know.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy