Jump to content

No audio through dedicated sound card


Kojei
 Share

Recommended Posts

I just tried to load up EoF after installing an Asus Xonar DG soundcard. EoF will not put any audio out through that. When I switched back to the onboard sound card, it worked fine. Any reason that might be happening or anything I can change on my setup? It's not a huge deal to switch it back and forth, just annoying when I want to load up the program. Currently running Win 7 if that makes a difference.

Link to comment
Share on other sites

My hands will mostly be tied on whether audio plays back or not. For the most part, EOF will just play audio out of whatever the OS's default sound playback device is. If the default device is changed while EOF is running, EOF will probably have to be re-opened to pick up that device. This was behavior somebody reported a long time ago when they'd plug in USB headphones.

 

If that doesn't help, but a third party solution like CheVolume does, let me know and I can mention it in the documentation.

Link to comment
Share on other sites

Tried CheVolume and it made no difference. It actually crashed a few times trying to force EoF to the sound card. It is set as the default and I tried a clean boot but still no audio from the application. Audio works fine in every other program. Just tried it with USB headphones and it works fine. Maybe something weird with the XONAR software jacking it up. No idea what's going on, but not a huge deal. I can do the headphones for quick edits or just pop the cable over for long sessions.

Link to comment
Share on other sites

Looking into that brand again, here's an excerpt from EOF's FAQ:

There are some sound driver settings that might not work with Allegro (the game design library EOF uses). One known issue is if your sound card uses a feature to emulate EAX hardware (ie. this is called "GX Mode" in Xonar branded sound cards), the sound may not work in EOF. The fix for this is to disable the sound driver's EAX emulation feature. Kudos to fatdog for this fix.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy