Jump to content

Problem with RST


Fedro
 Share

Recommended Posts

  • Developer

@@Fedro

I am unable to reproduce the error.  Plz check Toolkit>Configuration>Wwise Path, and make sure it is set to the correct Wwise version.  If this is not the problem then it may be that the CDLC has a corrupt audio file.  Plz provide a link to the CDLC that throws the error.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

  • Developer

@@Fedro So problem is with that CDLC.  It does not contain any preview audio.  So the quick fix is:

 

1) toolkit>CDLC Creator>Files>Audio selection button and select Pixies_Veloria_v1_RS2014_Pc\EOF\song_pixeiesvelorie_fixed.ogg

2) press the 'Generate' button

3) enjoy!

I'll add a permafix later for CDLC that is missing preview audio.

 

EDIT:  Can I have a link to the original CDLC before repair?  I want to check it.

            Utoh ... Try latest version of toolkit ... works for me on that song without doing the above.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

The fact is that I have this problem with all the CDLCs, even those with originals that come from the customsforge database (I tested).

 

At the same time, if the audio preview file is missing, it should be generated with Wwise.

The problem will then come either from RST or from Wwise.

 

The link to the original file:

http://customsforge.com/process.php?id=16033

 

Thank you Cosy1.

Link to comment
Share on other sites

  • Developer

@@Fedro So then I need your detailed workflow because I can not reproduce the error with the latest toolkit build.  Did you use the latest build of CFSM to make the repairs?  If not then this could be source of problem as well.  Thanks.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

@cosy1

- To answer your question, I used the latest version of CFSM.
- I tested with another CDLC (same error)
- I tested with the original that I shared from customsforge Search (same error)
- I tested with a CDLC that I created myself (no problem)

 

My finding is that RST fails to compile when DOS windows open, for the test my CDLC creates, the DOS windows did not open.

 

Here is my workflow:

1) Toolkit > CDLC Creator > Import Package > (Pixies_Velouria_v1_p) > open > Select Folder (Same place as .psarc) > RST Import OK
2) Arrangements > Guitar – Lead > Edit > Scroll Speed 1.6 > Ok
3) Generate > (Desktop (other place)) > Save

4) Three DOS windows opens after the error and arrives at the third window.

 

Once again thank you.

Link to comment
Share on other sites

  • Developer

Master @Fedro  What version of Wwise do you have installed?  (I recommend using this version)  Is WwiseCLI.exe path properly selected in General Config or is it blank?   (if you performed default Wwise installation then I recommend leaving the path blank)

Are you running Windows 10?  According to a Windows 10 user, you can unblock the toolkit DLL's and EXE's by running the following command in Windows PowerShell 'gci ./toolkit | unblock-file'.  I would also recommend having a look here for how to elevate privileges.  It is quite possible a Windows update is messing with you.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

I am on Windows 7

For the version of Wwise, I use two versions 2010 and 2015 for RS 2012 and RS 2014 and installed in the right order ie Wwise 2010 then Wwise 2015 as seen with you here:

http://customsforge.com/index.php/topic/47533-creating-dlc-for-rs1/?do=findComment&comment=292090

Regarding Wwise's path in RST, I have tested without indicating the path and then indicating it (same error).

 

I'll be thinking of using Wwise 2013 instead of Wwise 2015 if it's better.

 

Master as an attribute is far too superior to me. Parasite would be more appropriate.

 

Thanks again.

Link to comment
Share on other sites

The problem seems to be solved even though I still have to check some things.

 

Apparently the problem came from Wwise 2015.

 

I completely erased all Wwise as well as RST and then I put everything back.

 

Problem can be marked as resolved.

 

Thank you cosy1.

Link to comment
Share on other sites

  • Developer

Doing my happy dance now!

  • Like 1

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy