Jump to content

Got a song that crashes after tuning? Here's how to fix it.


Recommended Posts

So, you have a song that crashes after the tuning window, and the author isn't responding to your SOS messages. What do you do? First, you read this thread: http://customsforge.com/topic/901-how-to-use-custom-dlcs-in-rs2014/

Already did that? Didn't help? Okay, plan B:

 

1) Download and extract the toolkit. Come on, you know where to find it. Alright, FINE. Here it is: http://www.rscustom.net/builds

2) Open toolkit (Rocksmithtoolkitgui.exe <- open that one. For sure)

3) Click on Import Package (insert penis joke here). It's at the bottom, see?

 

http://thumbnails110.imagebam.com/34291/bf3b06342903522.jpg

 

4) Select your package. The .psarc file. Not your crown jewels.

5) The toolkit will ask you where to put the unpacked files. It will create a folder called Artist_Songtitle. Press Select folder. This should be the end result:

 

http://thumbnails111.imagebam.com/34291/bc6b5a342902863.jpg

 

6) To re-pack, press generate. It's to the right of the "Import Package" you clicked on earlier, remember? No? Too bad. Game over.

 

7) Select the folder where you want to put your new package. I suggest the RS2014/dlc folder. Ya know, so you can actually use it.

 

8) If you gave the package a different name (I call mine Mini-Me. Original eh?), make sure to delete the old package.

 

9) Enjoy your new non-crashing CDLC!

 

Note: If repackaging did not fix it, you either did it wrong (Go back to step 3), or there's something else going on with the arrangement. Contact the author. Or suck it up and import it into EoF and fix it.

  • Like 5
Link to post
Share on other sites

Would you consider the note highway just not showing up at all a crash?  On some of my songs (most work fine), I will get the tuning window, then the two amps on either side come down, however the area where the note highway usually appears will just stay blank.  I cannot escape out and have to force quit.  

  • Like 2
Link to post
Share on other sites

Would you consider the note highway just not showing up at all a crash?  On some of my songs (most work fine), I will get the tuning window, then the two amps on either side come down, however the area where the note highway usually appears will just stay blank.  I cannot escape out and have to force quit.  

 

Yup.

Link to post
Share on other sites

I've got the same problem. I'm on a mac and when i use the tookit to select the m.psarc file, after selecting a folder (folder called Artist_Songtitle wasn't created, so i created one, but that didn't seem to matter) i get this error message.

https://imagizer.imageshack.us/v2/560x652q90/674/6dRehS.png

Anyone know what to do?

Thanks in advance.

  • Like 1
Link to post
Share on other sites

  • 4 weeks later...

@@FATstuntman, make sure that you've got wine installed and your Mac can run windows exe files.

 Thanks for the reply @@Alex360 and pardon my ignorance.. but I have no idea how to do that?

 

After some googling, I learn wine is some kind of emulator and not a delicious alcoholic beverage? Do I run RS through it, or the creator?

Link to post
Share on other sites

@@FATstuntman, you can use "Wineskin" if it's too difficult to build wine yourself,  basically this app allow to use windows apps, you need it for RSToolkit program, you've got native RS2014 support for Mac(It would be waste to run PC game at MAC through emulator\translator)

Link to post
Share on other sites

  • 3 weeks later...

I'm trying this on PC but getting the same problem mentioned above: after repacking, song still crashes.  Followed the directions that were given, but no Artist_Songtitle folder gets created.  Also I found that only 2 of the songs (out of like 30 I downloaded) showed up on RS for me to even try to play (and they both crashed in the way that was described above).

  • Like 1
Link to post
Share on other sites

  • 5 months later...

I've got an issue w/ one of my own CDLCs. 10.15 Saturday Night has worked fine for me on Mac since I made it, but despite regenerating at least 4 times & re-uploading, everyone on PC keeps getting crashes. I can't test on PC so I can't tell exactly where or how it's crashing, and the CDLC Verifier doesn't work under wine since it doesn't create any windows to drag & drop onto. Is there any way someone can figure out wtf is going wrong w/ this thing so I can prevent future packages from having this issue? Or am I doomed to just keep regenerating & re-uploading potentially dozens of times until it finally actually works for everyone?

Link to post
Share on other sites

  • 2 weeks later...

I've got an issue w/ one of my own CDLCs. 10.15 Saturday Night has worked fine for me on Mac since I made it, but despite regenerating at least 4 times & re-uploading, everyone on PC keeps getting crashes. I can't test on PC so I can't tell exactly where or how it's crashing, and the CDLC Verifier doesn't work under wine since it doesn't create any windows to drag & drop onto. Is there any way someone can figure out wtf is going wrong w/ this thing so I can prevent future packages from having this issue? Or am I doomed to just keep regenerating & re-uploading potentially dozens of times until it finally actually works for everyone?

 

nm, it's fixed now. I ended up reopening it in (a newer) EOF, & re-creating the Toolkit package entry from scratch.

Link to post
Share on other sites

  • 1 month later...
  • 2 years later...

Would you consider the note highway just not showing up at all a crash?  On some of my songs (most work fine), I will get the tuning window, then the two amps on either side come down, however the area where the note highway usually appears will just stay blank.  I cannot escape out and have to force quit.  

 

I have the same issue. repacked twice and all songs seem to do the same. Is there next steps? 

Link to post
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy