Jump to content

Errors repairing (some) CDLC


Winston Smith
 Share

Recommended Posts

OS: Win7 Ultimate, 64-bit

CPU: AMD FX-6100

AV: Microsoft Security Essentials

.NET Framework version: 4.6.1

 

I'm running the 1.2.7.9 beta that I just downloaded a little over an hour ago.  The first thing I did was run the bulk repair with these settings:

 

Skip Previously Repaired CDLC: Yes (but again, first time running it)

Add DD (if not already present): Yes

Repair 100% Mastery Bug: Yes

    Preserve existing song stats: Yes

    Run Repair using (.org) files: No

    Ignore Multitone Exceptions: No

Repair Maximum Playable Arrangements: No

 

Of the 271 files processed, 224 were skipped because they were ODLC (I verified this by checking the "Repair Status" contents afterward).  So that leaves us with 47 CDLC; 39 of those repaired without errors and I assume they're good to go.  The remaining eight failed for four different reasons which I've included below; I left off the song names 'cause I don't know whether that's kosher or not, but if a mod can confirm that it's OK I can provide them if it'll help.

 

The first failure reason (which accounts for five of the eight failures) is:

Repair failed ... Access to the path 'C:\Program Files (x86)\CustomsForgeSongManager\RocksmithToolkitLib.TuningDefinition.xml' is denied.

I'm a bit confused by this, as I just installed the application (over the previous release, if that matters) and then ran it from the prompt at the end of the installer.  Presumably it's running as the same user that installed the files, so I can't imagine why it wouldn't be able to read that file.  I checked the security settings for the file and its containing directory and everything looks good.

 

The other three failures (one CDLC each) are:

Repair failed ... ww2ogg process error.
Audiokinetic Wwise RIFF/RIFX Vorbis to Ogg Vorbis converter 0.19 by hcs
Input C:\Users\Winston Smith\AppData\Local\Temp\song_name_goes_here_p_Pc\audio\windows\888109081.wem
Parse error: unknown chunk type

This looks like it might be a showstopper; it's too bad because I really wanted to learn that one and it's too hard for me to use the original version of the CDLC that doesn't have DD, but...it is what it is.

Repair failed ... There is tone name error in XML Arrangement Bass  bassir is not properly defined.Use EOF to re-author custom tones or Notepad to attempt manual repair.

I'm not afraid of a little recreational text editing; is this something I can fix myself with minimal handholding?

Repair failed ... Maximum playable arrangement limit exceeded

This last one I actually sort of understand from previous things I've read on the forums.  What I'm curious about here is whether there's a "recommended" or "safest" way to resolve this, or do I just need to pick which instruments I can live without and delete them?  Was this something to do with a weird way of doing Dynamic Difficulty?  I'm fuzzy on the details and I can't find the original post where I read about this before.

Link to comment
Share on other sites

  • Developer

The first access error for RocksmithToolkitLib.TuningDefinition.xml is very strange.  If access is denied to that file, I would have expected this error for every single CDLC.  Plz check and confirm the access properties of the file.  The best solution would be to download the newest Beta of CFSM and try again.  Be sure you delete the CFSM folder in MyDocuments before reinstalling.

 

The other errors are good (valid) errors.  You have CDLC that have real problems/corruption.  The error message explains exactly what the issue is with these CDLC.  The newest Beta version of CFSM will allow you to ignore the multitone error and convert the CDLC to a single tone.

 

To fix Max Playable Arrangement (Max5) error you need to select this option in the repairs dialog along with 'Remove Bonus Arrangements'.

 

To fix the vobis error you would have to reauthor the CDLC in the toolkit.  Something is wrong with the BNK file in that CDLC and it needs to be repackaged.

 

Looks like CFSM is doing its job and found problems with your CDLC.  Now you have some options for how to handle.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

The first access error for RocksmithToolkitLib.TuningDefinition.xml is very strange.  If access is denied to that file, I would have expected this error for every single CDLC.  Plz check and confirm the access properties of the file.  The best solution would be to download the newest Beta of CFSM and try again.  Be sure you delete the CFSM folder in MyDocuments before reinstalling.

 

I did check the permissions on the file (and its containing directory); I confirmed that the Administrators group had read/write/execute permissions to both.  I'm running CFSM as a user in the Administrator's group (my normal user account), and that's also the account I used to install it.  I'm certainly down for trying a reinstall, but be advised that I'm already using the latest beta (unless there's something newer than the 1.2.7.9 beta I downloaded and installed last night, just before creating this topic, which still shows as the most recent version at http://ignition.customsforge.com/cfsm).  Can you clarify precisely which permissions are necessary?  I come from a UNIX background, so while I understand the concepts of file permissions I'm not necessarily familiar with the subtleties of the MS Windows terminology and interface and I might be missing something.

 

As far as the multitone and Max5 errors, it sounds like I need to either let CFSM strip out part of the CDLC and hope for the best, or try and re-author it.  That's kinda what I expected, but thanks for the clarification.  And the last one just flat out has to be re-authored, no getting around it.  Of course, that's the one I care about the most.  ;)

 

OK then...I'll try deleting CFSM's directory in "My Documents", then reinstalling the 1.2.7.9 beta and having another go.  I'll let it have its way with the multitone and Max5 ones...maybe I'll be happy with the results.

Link to comment
Share on other sites

  • Developer

"Can you clarify precisely which permissions are necessary?" 

I have never tried to run CFSM as a user in the admin group.  I always just run CFSM from the main admin account which Unix may call root.

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

"Can you clarify precisely which permissions are necessary?" 

I have never tried to run CFSM as a user in the admin group.  I always just run CFSM from the main admin account which Unix may call root.

 

OK; I think we're talking about the same thing and I'm just over-explaining it.  :)  I only have one user (the one I created during OS installation)...it's in the Administrators group just like I assume every MS Windows default install user is.  I just tried to go into minute detail because it seems like a really weird issue and I figured whatever it was, had to be something small and subtle.

 

Here's where the plot thickens: I deleted CFSM's directory in "My Documents", then uninstalled CFSM 1.2.7.9, then reinstalled 1.2.7.9 again.  I went back in and did the bulk repair, and got all the same errors on the same files again.

 

I ran the Max5 fix and it successfully fixed that file that had that problem (so when I ran the regular bulk repair to fix the 100% bug, everything reported success).  Victory!

 

I ran the fix with "Ignore Multitone Exceptions" checked, and it did not fix the file with this error:

Repair failed ... There is tone name error in XML Arrangement: Bass  bassir is not properly defined.Use EOF to re-author custom tones or Notepad to attempt manual repair.

Is that not the right way to fix that problem, or is this file broken in a way that isn't fixable by an automatic tool?

 

As for the five with the permissions error...I'm just as confused as you.  Is it possible that there's something about those specific CDLC files that causes that XML file to be used, when it's not used for the others?  I agree that the error says file permissions and that should be independent of CDLC file, but nevertheless it's 100% consistent: these five files fail with that error every time, and no other file ever fails with that error.

 

By the way, thanks for taking the time to look into this (not to mention the time and effort required to create the tool in the first place)!  I'm going to go to the CDLC search and see if any of these files have updated versions...maybe I can dodge around the problem by just updating the data files.  :)  Still, even if I get things working, feel free to let me know if you want me to try more stuff for troubleshooting.

Link to comment
Share on other sites

OK, so, update; I went through the CF search engine and looked up all the CDLCs and re-downloaded them.  Except, as it turns out, the one I really wanted with the corrupted BNK file that was just borked and would definitely have to be completely rebuilt...turns out Rocksmith actually has that song as ODLC now, so, problem solved!  :)

 

The one with the messed-up tone name is still showing the same symptoms, and still doesn't get fixed with "Ignore Multitone Exceptions".  However, there's a second CDLC of the same song now, and that one downloads and goes through the repair process with no issues.  Problem solved again!

 

Here's where it gets strange.  When I ran the default repair (Repair 100% bug, Add DD, preserve stats, nothing else checked) it did fix four of the five "I can't read this XML file" ones.  This is after I confirmed that the files I already had were the same files I re-downloaded (evidence: identical filenames and byte counts...I don't know of a way to do an actual diff on MS Windows but I figure if they're exactly the same number of bytes, that's pretty conclusive).  Then I moved all the newly-fixed CDLC out of the way and ran the same repair again, with just that one CDLC file in the directory, and it worked too.  I can't even begin to guess why, but I'm letting you know in case it helps you in some way in the future.

 

Soooo, while I didn't necessarily solve all the problems, I am at the desired end state.  I mean, I guess it's worth noting that I've been doing all this 100% in CFSM...I haven't actually fired up RS2014 at any point to actually see whether these files work in the game, but I'm sure that's just a formality.  Like I said, if you want me to run tests on anything for troubleshooting purposes, let me know (it's the least I can do in return) but in practical terms I'm all set now.  Thanks again!

Link to comment
Share on other sites

  • Developer

Way to stay with it and not give up.  Maybe your Windows vs Linux questions can be answered by googling.  If you are using a Windows Home Version OS (I see that you are not) then the main admin account is hidden and you have to unhide it to get access. 

 

AV: Microsoft Security Essentials  - try adding CFSM to your AV's whitelist of safe apps.

.NET Framework version: 4.6.1 - try installing Net 4.0.30319  (you may have to uninstall 4.6.1 first)

 

Could you please PM me a link to the CDLC that has the tone issue?  The newest version of CFSM should have been able to fix that.  Thanks

Are you tired of AV False Positives???  Now accepting donations on my website (Click Here)  Your donation will be used towards buying a code signing certificate.   CGT is now compatible and safe to use with Rocksmith® 2014 Remastered ... 

 

Latest Build of Custom Game Toolkit (CGT) w/ Game Save Gigbox       Latest Build of Rocksmith Toolkit       Latest Build of Customs Forge Song Manager (CFSM)

 

All bug reports and help requests please include your: OS, CPU, AV, .NET Framework versions along with a description of the issue (include screenshots of error if possible).  It should go without having to say ... make sure you are using the latest build before submitting bug reports or asking for help.

 

*  Remember to use your magic words (please and thank you) if you would like a response.  Don't use phrases like 'thanks anyhow' as it is demeaning.

Link to comment
Share on other sites

I tried to open http://customsforge.com/page/customsforge_rs_2014_cdlc.html/_/pc-enabled-rs-2014-cdlc/the-chosen-ones-r2931 in EoF, to fix that "not properly defined" problem, but i can't see where the problem is. The tone changes have correct names, and the name listed in the toolkit error is nowhere to be found. "there is a tone name error in XML arrangment: combo introdistortion is not properly defined"

 

Can't figure out where the problem is. I have tried to change the xml files in notepad, but no luck yet.

Link to comment
Share on other sites

I finally managed to fix the tone issue in this song, using just notepad and EoF to find out when the tone changes, and what tone it changes to. The problem was: Tone A, B, C and D didnt have the same name as the name here: <tone time="30.286" id="1" name="WRONG TONE NAME HERE" /> And that was the same for all the tone change times in the song.

 

This part of the XML files is the problem:

 

  <tonebase>Knights_verb</tonebase>
  <tonea>Knights_verb</tonea>
  <toneb>Knights_verb_intro</toneb>
  <tonec>REMHurts_clean</tonec>
  <toned>Now_dist</toned>
  <tones count="5">
    <tone time="30.286" id="1" name="WRONG TONE NAME HERE />
    <tone time="48.9" id="2" name="WRONG TONE NAME HERE" />
    <tone time="73.718" id="3" name="WRONG TONE NAME HERE" />
    <tone time="237.352" id="2" name="WRONG TONE NAME HERE" />
    <tone time="261.92" id="3" name="WRONG TONE NAME HERE" />

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Guidelines. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. - Privacy Policy