Jump to content

Welcome to CustomsForge
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account

Learn & Play Rocksmith!

Want to play the songs you love? Registration and the use of this website is 100% free.
The only thing you need is a legal copy of Rocksmith 2014 w/ a cable. Click here to buy it.
 
Having trouble logging in or registering? Please click "Support" below.



Photo

Using external USB sound adapter garbles sound and slows game to a crawl


  • Please log in to reply
11 replies to this topic

#1
Offline   lduperval

lduperval

    Master Guitarist

  • Donator
  • PipPipPipPipPip
  • 322 posts
  • 3 thanks
  • Rocksmith:Steam
(Posted this on the UBI forums as well)
 
Hi,
 
My laptop's sound card gave out and I tried buying an external adapter. It works fine with other audio, but when I play Rocksmith, after about 3 minutes it slows down the whole game, and distorts the sound. I suspect it,s because the USB ports are managing the input and output of the game and at some point it becomes too much, but I wanted to know if any others have faced this and if so, if you had a way of fixing it.
 
Some facts:
 
- Lenovo T440s
- core i5
- Win 10
- 8 MB of ram
 
If the device is the problem and you've used a better one, I'm interested also.
 
Thanks,
 
L


#2
Offline   Xellot

Xellot

    Hardcore Guitarist

  • Donator
  • PipPipPip
  • 99 posts
  • 0 thanks
  • LocationLubbock, TX
  • Rocksmith:Steam

edit your Rocksmith.ini file



#3
Offline   lduperval

lduperval

    Master Guitarist

  • Donator
  • PipPipPipPipPip
  • 322 posts
  • 3 thanks
  • Rocksmith:Steam

Uh... OK, and what do I change:

 

[Audio]
EnableMicrophone=1
ExclusiveMode=1
LatencyBuffer=4
ForceDefaultPlaybackDevice=
ForceWDM=0
ForceDirectXSink=0
Win32UltraLowLatencyMode=1
DumpAudioLog=0
MaxOutputBufferSize=0
[Renderer.Win32]
ShowGamepadUI=0
ScreenWidth=1280
ScreenHeight=720
Fullscreen=2
VisualQuality=3
RenderingWidth=0
RenderingHeight=0
EnablePostEffects=0
EnableShadows=1
EnableHighResScope=0
EnableDepthOfField=0
EnablePerPixelLighting=1
MsaaSamples=1
DisableBrowser=0
[Net]
UseProxy=1
 
L


#4
Offline   Alex360

Alex360

    Guitar God

  • Rocksmith Custom Developer

  • PipPipPipPipPipPipPipPip
  • 2,223 posts
  • 313 thanks
  • Rocksmith:Steam

"- 8 MB of ram"

that's gorgeous

But hey, it's a well known fact that rocksmith doesn't like any usb soundcards and you should prefer internal or PCI(PCI-E) one it has larger throughput and lower latency

try this settings

[Audio]
EnableMicrophone=0
ExclusiveMode=1
LatencyBuffer=2
ForceDefaultPlaybackDevice=1
ForceWDM=0
ForceDirectXSink=0
Win32UltraLowLatencyMode=1
DumpAudioLog=0
MaxOutputBufferSize=256
 
 
and don't forget to change your speakers to 16 bit 48 000 Hz to avoid re-sampling, which gives you loss of performance


#5
Offline   lduperval

lduperval

    Master Guitarist

  • Donator
  • PipPipPipPipPip
  • 322 posts
  • 3 thanks
  • Rocksmith:Steam

Great,, I managed to get thru the Monkees song with this setup. Excellent, thanks!

 

If in the future it starts acting up again, when can I find an explanation of buffer size and latency value effects on game play?

 

Thanks again!

 

L



#6
Offline   firekorn

firekorn

    Done Nothing for the Community

  • Administrator

  • PipPipPipPipPipPipPipPip
  • 3,235 posts
  • 455 thanks
  • LocationVillers-CotterĂȘts, France
  • Rocksmith:Steam

@Alex360 I never had any issue with multiple different USB soundcard so far so i'm not sure why you would consider RS doesn't like any at all. Most of the time it's setup issue (or people trying to use the soundcard as an input instead of the RTC but that's a completely different topic).


Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity


#7
Offline   Alex360

Alex360

    Guitar God

  • Rocksmith Custom Developer

  • PipPipPipPipPipPipPipPip
  • 2,223 posts
  • 313 thanks
  • Rocksmith:Steam

@firekorn, that's what ubi say every time someone asks for help with "USB headphones" lol.
and yes setup is always required, unfortunately nothing works out of the box yet.



#8
Offline   firekorn

firekorn

    Done Nothing for the Community

  • Administrator

  • PipPipPipPipPipPipPipPip
  • 3,235 posts
  • 455 thanks
  • LocationVillers-CotterĂȘts, France
  • Rocksmith:Steam

Rare are the USB headphone that support 48kHz though which is required for RS.


Firekorn's workshop
In Flames Discography

#FirekornHasDoneNothingForTheCommunity


#9
Offline   lduperval

lduperval

    Master Guitarist

  • Donator
  • PipPipPipPipPip
  • 322 posts
  • 3 thanks
  • Rocksmith:Steam

Well, it started acting up again, and now I can't even get past the splash screen.:(

 

I'll investigate those options further to see how to fix it. Until then, looks like I'm off RS for a while.

 

L



#10
Offline   Xellot

Xellot

    Hardcore Guitarist

  • Donator
  • PipPipPip
  • 99 posts
  • 0 thanks
  • LocationLubbock, TX
  • Rocksmith:Steam

Well, it started acting up again, and now I can't even get past the splash screen. :(

 

I'll investigate those options further to see how to fix it. Until then, looks like I'm off RS for a while.

 

L

try something like this. i use  surface pro tablet a my desktop and this sounds the best to me... especially with the lateny setting on 8 or 9...  i dont care what anyone says mine sounds pure ans clean as ****!! :)  Also on the bottom right hand corner of your screen right click the little speaker icon then properties then driver and click update and see  if that does anything.  also while you're there make sure your settings are as the guys mentioned above.  try Configuring your speakers, make sure after you mess with all of the settings you do recording devices next and make sure your cable is set to dvd mode at 48



#11
Offline   lduperval

lduperval

    Master Guitarist

  • Donator
  • PipPipPipPipPip
  • 322 posts
  • 3 thanks
  • Rocksmith:Steam

Hi @Xellot,

 

I'm not sure what you are suggesting. Are you saying that I should be using a Surface Pro to use Rocksmith? Or are you saying that I should be using a higher level of latency?

 
 I did check the driver for the device, and I'm using the latest Microsoft driver. Furthermore, it is also set to 16 bit 48 kilohertz audio.
 
Finally, I tried modifying the recording device but everytime I click on a device, whether it's a USB microphone, the Rocksmith real tone cable, or the device for the new external audio device, it always crashes the mixer app. I've had this problem for a long time and have no idea how to fix it.
 
L


#12
Offline   lduperval

lduperval

    Master Guitarist

  • Donator
  • PipPipPipPipPip
  • 322 posts
  • 3 thanks
  • Rocksmith:Steam

Well, this worked for now:
 

[Audio]
EnableMicrophone=0
ExclusiveMode=1
LatencyBuffer=6
ForceDefaultPlaybackDevice=1
ForceWDM=0
ForceDirectXSink=0
Win32UltraLowLatencyMode=0
DumpAudioLog=1
MaxOutputBufferSize=1024
[Renderer.Win32]
ShowGamepadUI=0
ScreenWidth=1280
ScreenHeight=720
Fullscreen=2
VisualQuality=3
RenderingWidth=0
RenderingHeight=0
EnablePostEffects=0
EnableShadows=1
EnableHighResScope=0
EnableDepthOfField=0
EnablePerPixelLighting=1
MsaaSamples=1
DisableBrowser=0
[Net]
UseProxy=1