Jump to content

Welcome to CustomsForge
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account

Learn & Play Rocksmith!

Want to play the songs you love? Registration and the use of this website is 100% free.
The only thing you need is a legal copy of Rocksmith 2014 w/ a cable. Click here to buy it.
 
Having trouble logging in or registering? Please click "Support" below.


Donate

Don't forget to join our Partnered Discord, like us on Facebook and Twitter!
Donate to our monthly goal to keep us running.


Photo

Custom songs stopping game from closing properly.


  • Please log in to reply
5 replies to this topic

#1
Offline   mechanicalbride

mechanicalbride

    Beginner Guitarist

  • Member
  • Pip
  • 3 posts
  • 0 thanks
  • Rocksmith:Steam

Hi all,

Ever since importing CDLC into my game I've noticed a change which is really annoying.

The game starts & works just fine, but once I attempt to exit the game, it just hangs up for eternity on a black screen. I can't ctrl + alt + del or anything to fix this, so my only recourse is to restart my PC.

My OS is Windows 10 and I have an i7 3770k, GTX 670 FTW with 16 gb of RAM. And like I said I never had this issue until I placed CDLC into my game.

Thanks for any help.



#2
Offline   Bluetac

Bluetac

    Touring Guitarist

  • Donator
  • PipPipPipPipPipPip
  • 550 posts
  • 21 thanks
  • LocationUK
  • Rocksmith:Steam

Donator

Are you using cdlc that you downloaded from here? (if not they may well be poorly made/not been updated in some time) tone bug etc
Are you using the latest D3DX9_42 .DLL file  grab it from here

there is an app made to scan and repair cdlc that can be found here go to repairs tab check the ones i have checked in the screen shot then hit *run selected repair options as highlighted at the bottom.

 this will take it a while to do so sit back and grab a coffee or three dependant on how many you have and the speed of the drives

song%20manager%20fix_zpsih9ymcfh.png


76561197968639313.png

Guitars: ESP LTD F-54 Bass, Tanglewood Curbow4 Bass, Stagg BC300-N Bass, Yamaha BBN5bk (5String), ESP LTD AX-360, Plus a cheapo no name acoustic


#3
Offline   engineer

engineer

    Beginner Guitarist

  • Donator
  • Pip
  • 29 posts
  • 0 thanks
  • LocationHelsinki
  • Rocksmith:Steam

I also had the same problem, tried the repair above and that seems to have fixed the problem, many thanks for the tip  :plus1:

 

I avoided the problem by running RS in windowed mode, but hopefully the "exit stuck" problem is solved now.

Win 10, i7-5820k, NVidia GeForce GTX 960



#4
Offline   mechanicalbride

mechanicalbride

    Beginner Guitarist

  • Member
  • Pip
  • 3 posts
  • 0 thanks
  • Rocksmith:Steam
Thanks so much for your input bluetac but that particular solution didn't seem to work for me. The directory we are supposed to point the software to after hitting the 'run selected repair options' key is the /common/Rocksmith2014/dlc directory, correct?

#5
Offline   Bluetac

Bluetac

    Touring Guitarist

  • Donator
  • PipPipPipPipPipPip
  • 550 posts
  • 21 thanks
  • LocationUK
  • Rocksmith:Steam

Donator

Thanks so much for your input bluetac but that particular solution didn't seem to work for me. The directory we are supposed to point the software to after hitting the 'run selected repair options' key is the /common/Rocksmith2014/dlc directory, correct?

That is indeed correct, did you let it run after it scanned the directory? it will scan it to find what you have in there then need to run again afterwards to do the repairs by pressing the highlighted button mentioned above.


76561197968639313.png

Guitars: ESP LTD F-54 Bass, Tanglewood Curbow4 Bass, Stagg BC300-N Bass, Yamaha BBN5bk (5String), ESP LTD AX-360, Plus a cheapo no name acoustic


#6
Online   RubberDave

RubberDave

    Medium Guitarist

  • Donator
  • PipPip
  • 57 posts
  • 0 thanks
  • Rocksmith:Steam
I had this problem a few months back. The issue for me was the Windows display refresh rate. All I had to do was change from 60fps to 59fps and it's been fine ever since. If I get time later I'll try and find the link that explains why. Something to do with HD not being exactly 60fps.

EDIT: I can't find the link with the explanation but there are plenty of examples of people fixing the same problem by changing the refresh rate from 59hz to 60hz and vice versa. I think it's HDMI that refreshes at 59hz, but one way or the other might help.