Jump to content

Welcome to CustomsForge
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account

Learn & Play Rocksmith!

Want to play the songs you love? Registration and the use of this website is 100% free.
The only thing you need is a legal copy of Rocksmith 2014 w/ a cable. Click here to buy it.
 
Having trouble logging in or registering? Please click "Support" below.


Donate

Any amount helps! Donate to our donation goal to help keep us running.
http://customsforge.com/donate/goal-89-may-donation-goal/


Photo

Latest EOF releases (5-22-2017)


  • Please log in to reply
2147 replies to this topic

#2141
Online   theSG

theSG

    Beginner Guitarist

  • Member
  • Pip
  • 39 posts
  • 2 thanks
  • Rocksmith:Steam

Yes, I think it was enabled by default, and push offset back was one of last things I always did before realizing that it causes the problem.



#2142
Offline   raynebc

raynebc

    Guitar God

  • Rocksmith Custom Developer

  • PipPipPipPipPipPipPipPip
  • 2,398 posts
  • 690 thanks

https://drive.google...Q2JzOGsxV3BEQnM
1. Open the project.
2. Select beat 1 (though same thing will happen if you bpm changed from any beat)
3. Use "Beat>BPM change" to set a tempo of 145.00 BPM only adjust notes selected (I just tried to change bpm to 150 and that surprisingly works fine)
4. Use "Beat>Push offset back" 5 times (I always use this from the first beat and push it back 1 measure)

And if I do ctrl+a, ctrl+shift+r on a track after this most FHPs left a bit too late, which is the most annoying part of this bug if FHPs were edited manually.


I can't reproduce the problem with these steps with either the current hotfix or 1.8RC12. For "Beat>Push offset back", it doesn't matter which beat is selected, the result is the same.

#2143
Offline   PC Plum

PC Plum

    Hall of Fame Guitarist

  • Magna Charter
  • PipPipPipPipPipPipPip
  • 1,877 posts
  • 790 thanks
  • LocationEdinburgh

I believe that I am using the lastest EoF (eof1.8RC12 5-3-2017) and I can produce cyan at will:

 

- Load the sample project

- Select any beat

- Use Push Offset Back (the more times you use POB, the more cyan lines you get)

- Resnap chart

- Hit undo

 

POB looks to be knocking the notes off slightly, I don't know how much of a problem it is though.  My normal workflow would deal with slightly off grid notes, plus I don;t use the highlight non grid snapped notes feature so I don't know how often (or if) notes are going slightly off grid in my own projects.



#2144
Online   theSG

theSG

    Beginner Guitarist

  • Member
  • Pip
  • 39 posts
  • 2 thanks
  • Rocksmith:Steam
 
I can't reproduce the problem with these steps with either the current hotfix or 1.8RC12. For "Beat>Push offset back", it doesn't matter which beat is selected, the result is the same.

 

Weird, just tried downloading rc12 and I can reproduce it exactly as in hotfix every time.

Thanks for looking into it anyway, at least now I know how to avoid the problem.



#2145
Offline   raynebc

raynebc

    Guitar God

  • Rocksmith Custom Developer

  • PipPipPipPipPipPipPipPip
  • 2,398 posts
  • 690 thanks
The next hotfix will have multiple corrections to improve this type of issue (notes losing grid snap when clicking and dragging beats, or when undoing an operation that changed beat positions).

#2146
Offline   avdocatwork

avdocatwork

    Elite Member

  • Magna Charter
  • PipPipPipPipPipPipPip
  • 1,207 posts
  • 335 thanks
  • LocationDallas, Texas
  • Rocksmith:Steam

Hi, Guys

 

  I just installed the new EOF and Toolkit and I have a problem with EOF. The new customs I have been making have the problem in the picture below while playin' on RockSmith. Could it be a preference setting set wrong in EOF? Has anybody seen a problem like this before? Bass line looks OK and Lead Looks OK , but some chords look like the pic. below.

 

Thanks, Avdocatwork

 

lOvDFMW.jpg



#2147
Offline   raynebc

raynebc

    Guitar God

  • Rocksmith Custom Developer

  • PipPipPipPipPipPipPipPip
  • 2,398 posts
  • 690 thanks
Hi, folks.

The latest hotfix (5-22-2017) is in the first post. Changes are as follows:
*Corrected the "Export time range" function to export all of the track-specific details (ie. customized name, fret/string count, etc).
*Corrected the "Export time range" function to ensure the first exported beat explicitly has whatever time signature was in effect in the source project.
*Fixed a bug where setting the difficulty of the pro drum or harmony vocal difficulty to undefined while it was already undefined would mark the chart as modified.
*Improved the "Track>Set difficulty" menu to display a check mark reflecting the active track's currently defined difficulty. If the vocal and harmony difficulties are different, or drums and pro drums difficulties are different, the "Manually set" item is checked.
*Fixed a bug with the project save logic (also affects undo/redo states) that prevented supplemental precision beat timing data from being written in a usable way. Beat timings are now stored in the project to a precision of over 10 decimal places. This should reduce the number of notes that lose sync during certain beatmap alterations.
*Improved beat click and drag logic to immediately update the note and tab highlighting if any notes lost grid snap.
*Fixed bugs with the click and drag logic that (under specific timing circumstances) could cause beats to become desynced by 1ms with notes after the notes are auto-adjusted.

@avdocatwork
A common cause for this is not really using the latest toolkit (the "test build" which is version 2.8.2.0) and then not disabling the abridged XML feature in EOF despite the warning that older versions of the toolkit won't support it. If that isn't really the cause of the problem, please reply with more information.

Thanked by 1 Member:

#2148
Online   Chlipouni

Chlipouni

    Touring Guitarist

  • Member
  • PipPipPipPipPipPip
  • 892 posts
  • 310 thanks
  • LocationFrance
@raynebc,

During a GP tab import in EOF, a single note with a slide is terminated with a new gem related to the end fret position. I was expected to have only the first note with the slide and its end fret position, but not the last gem at the end of the sustain.
Is it the normal behaviour ?

Thanks

Envoyé de mon SM-G920F en utilisant Tapatalk