Jump to content

Welcome to CustomsForge Forums
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account

Learn & Play Rocksmith!

Want to play the songs you love? Registration and the use of this website is 100% free.
The only thing you need is a legal copy of Rocksmith 2014 w/ a cable. Click here to buy it.
 
Having trouble logging in or registering? Please click "Support" below.



Photo

Haven't Made a custom in awhile.. question..

- - - - -

Best Answer Snake3169, 20 March 2019 - 11:00 PM

Fixed it... my registry was screwed up and was messing with cmd.exe. So now it all works as it should. Only took me 3 hours to fix it.

Go to the full post »


  • Please log in to reply
9 replies to this topic

#1
Offline   Snake3169

Snake3169

    Touring Guitarist

  • Charter
  • PipPipPipPipPipPip
  • 977 posts
  • 260 thanks
  • Location:Crittenden

I haven't made a custom in over a year. I updated to the latest version of EoF and the latest hotfix for it.

 

Well I started the process as I remember it.

 

Open EoF, click on new, select the MP3 that I want to use.. select the bit rate I want it converted too... but then I get the window to select MP3, OGG.. etc etc pops up again after selecting the bit rate... what? So I select the MP3 AGAIN and then I get an error that it couldn't find guitar.ogg. Which I know of course is the audio file EoF uses for the backing track.. so i go into the folder and there is indeed no guitar.ogg file. It seems EoF is not creating the guitar.ogg file at all.

 

Is there something I am missing here?

 

I have been away for a long time, so.. this part of the creation process went pretty smooth back in the day.

 

Any help would be appreciated. Thanks.



#2
Offline   Snake3169

Snake3169

    Touring Guitarist

  • Charter
  • PipPipPipPipPipPip
  • 977 posts
  • 260 thanks
  • Location:Crittenden

No one knows, at all?



#3
Offline   Snake3169

Snake3169

    Touring Guitarist

  • Charter
  • PipPipPipPipPipPip
  • 977 posts
  • 260 thanks
  • Location:Crittenden

I manually converted the MP3 into an ogg file myself and renamed the .ogg file guitar.ogg. However this doesn't really fix anything because I still can't edit or save anything because it EoF refuses to encode the .ogg file itself. Any help?



#4
Offline   Snake3169

Snake3169

    Touring Guitarist

  • Charter
  • PipPipPipPipPipPip
  • 977 posts
  • 260 thanks
  • Location:Crittenden

The Error I get when trying to add leading silence to an Guitar.ogg I had to make myself...

 

Error opening file.

Make sure there are no unicode or extended ASCII characters in this Chart's File Path.

 

obviously there isn't.

 

Its just 'Guitar.ogg" as the file name.

 

Keep in mind I had to manually create guitar.ogg and that EoF did not actually make it which is the crux of the problem. As I stated above. So, I guess if I can't get this sorted out. I ain't gonna be making customs anymore I guess. Because if EoF can't create an .ogg file.. then it won't be able to encode all of this into a CDLC file. 



#5
Online   raynebc

raynebc

    Guitar God

  • Rocksmith Custom Developer

  • PipPipPipPipPipPipPipPip
  • 2,838 posts
  • 756 thanks
First, make sure you're using the 2-20-2019 hotfix, as the one before that had some audio file handling problems.

Otherwise: What option are you picking for the location of the new chart? When I create a new project, select an MP3 and choose the source audio file's folder for the destination, it has me select a bitrate and then it creates an OGG as expected. If I instead opt to create a new folder, it creates a new folder named "[ARTIST] - [SONG TITLE]" in my configured song folder (defined with "File>Song folder"). If you have no song folder defined, it should default to EOF's program folder but then you can run into permissions or file name compatibility problems depending on where you've stored EOF, ie. if you put EOF within one of Windows's "Program Files" folders or if ANY folder in the path to the project folder includes any accented/Unicode characters.

That said, you could still create customs even if that didn't work because you could prepare the OGG file in Audacity or something. Only certain tools used by EOF have limitations with accented/Unicode characters in file paths.

#6
Offline   Snake3169

Snake3169

    Touring Guitarist

  • Charter
  • PipPipPipPipPipPip
  • 977 posts
  • 260 thanks
  • Location:Crittenden

i use source audio when creating a new project and i do have the latest hotfix.



#7
Offline   Snake3169

Snake3169

    Touring Guitarist

  • Charter
  • PipPipPipPipPipPip
  • 977 posts
  • 260 thanks
  • Location:Crittenden

I accidently stumbled across the problem when I was trying to fix another problem... for some reason my CMD is crashing on my windows 10 PC. Which is the reason why EoF isn't automatically encoding the guitar.ogg. Trying to fix my CMD crashing now.



#8
Offline   Snake3169

Snake3169

    Touring Guitarist

  • Charter
  • PipPipPipPipPipPip
  • 977 posts
  • 260 thanks
  • Location:Crittenden
✓  Best Answer

Fixed it... my registry was screwed up and was messing with cmd.exe. So now it all works as it should. Only took me 3 hours to fix it.



#9
Online   raynebc

raynebc

    Guitar God

  • Rocksmith Custom Developer

  • PipPipPipPipPipPipPipPip
  • 2,838 posts
  • 756 thanks
Very odd. The command prompt was completely broken? That would definitely break a few things in EOF.

#10
Offline   Snake3169

Snake3169

    Touring Guitarist

  • Charter
  • PipPipPipPipPipPip
  • 977 posts
  • 260 thanks
  • Location:Crittenden

Yeah something in the registry was borked and was causing the command prompt to run then immediately close. So it wasn't running the OGG encoder at all. Not sure how it ever got broken in the first place but I got it fixed after snooping around on the internet and found out it is a registry problem, cmd.exe was tagged as an autorun %comrun% and it screws with cmd. Its all a pain in the butt.








Change your privacy preferences (EU)